"Apply file extensions filter to batch downloads too" broken

Ask for help about FlashGot, no registration needed to post
l0b0
Posts: 1
Joined: Fri Mar 10, 2017 7:55 pm

"Apply file extensions filter to batch downloads too" broken

Post by l0b0 » Fri Mar 10, 2017 8:27 pm

How to reproduce:
  • Set the "Apply file extensions filter to batch downloads too" option:

    Code: Select all

    user_pref("flashgot.extfilter", true);
  • Try to open the "FlashGot All" dialogue either in the context menu or by pressing Ctrl-F3
What happens: Nothing. No window appears, no error message.

Disabling the option fixes the issue.

Using Firefox 52.0 and FlashGot 1.5.6.14 on Arch Linux
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

User avatar
therube
Ambassador
Posts: 7528
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: "Apply file extensions filter to batch downloads too" br

Post by therube » Sat Mar 11, 2017 6:19 pm

A little while back, I thought I ran into an issue with batch downloads - but dealing with the Build Gallery (& there might be something there, not sure)?


URL: https://www.google.com/search?q=trains& ... 00&bih=680
URL: https://www.custommodelrailroads.com/cm ... llery.html

FlashGot Options -> Downloads
File Extensions -> jpg ==> Add
Apply file extension filter to batch downloads too

FlashGot All

With both URLs, .jpg files are found as expected.

On my end, Win7, looks to be working.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46 Lightning/.4.46

Post Reply