Firefox for Android v50.1 blocks Flashgot install

Ask for help about FlashGot, no registration needed to post
Odiemouse

Firefox for Android v50.1 blocks Flashgot install

Post by Odiemouse » Fri Jan 20, 2017 7:09 am

Besides no longer finding it in Mozilla's add-on store, I get the following error when trying to install FG from anywhere.

BLOCKED ADD-ON
FIREFOX PREVENTED THIS SITE (FLASHGOT.NET) FROM ASKING YOU TO INSTALL SOFTWARE ON YOUR DEVICE.
DISMISS/ALLOW?

Choosing ALLOW puts my Android phone through the download/install paces, but the FG add-on never installs. I've heard something about Mozilla screwing several GOOD software developers with some new tweak. Is there any to bypass it and get FG to install?
Mozilla/5.0 (Android 5.1; Mobile; rv:50.0) Gecko/50.0 Firefox/50.0

User avatar
GµårÐïåñ
Lieutenant Colonel
Posts: 3339
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA
Contact:

Re: Firefox for Android v50.1 blocks Flashgot install

Post by GµårÐïåñ » Fri Jan 20, 2017 8:23 am

That warning is normal for anything that is not being installed from AMO.

If you trust it, which you should from our websites, then you will allow and that's that.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
________________ .: [ Major Mike's ] :. ________________
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

barbaz
Senior Member
Posts: 9344
Joined: Sat Aug 03, 2013 5:45 pm

Re: Firefox for Android v50.1 blocks Flashgot install

Post by barbaz » Fri Jan 20, 2017 5:11 pm

GµårÐïåñ wrote:If you trust it, which you should from our websites, then you will allow

... which they did -
Odiemouse wrote:Choosing ALLOW puts my Android phone through the download/install paces, but the FG add-on never installs.


FWIW, Flashgot is not marked as compatible with Firefox for Android.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
GµårÐïåñ
Lieutenant Colonel
Posts: 3339
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA
Contact:

Re: Firefox for Android v50.1 blocks Flashgot install

Post by GµårÐïåñ » Fri Jan 20, 2017 11:33 pm

barbaz wrote:FWIW, Flashgot is not marked as compatible with Firefox for Android.

Correct, the assumption is the user who is clicking to install something knows if it is meant for it or not.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
________________ .: [ Major Mike's ] :. ________________
Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36

Post Reply