Flashgot no longer seeing 1080 MP4 on youtube

Ask for help about FlashGot, no registration needed to post
User avatar
therube
Ambassador
Posts: 7455
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by therube » Mon Nov 04, 2013 11:21 pm

> It can detect them

I'm not seeing them, not 1080's, mp4?


Are they even there, at all, at 1080 mp4?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a2

user

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by user » Tue Nov 05, 2013 1:15 am

By "it can" I meant it's possible in general, not that it does detect them _now_. As for where the streams are, look at dashmpd or adaptive_fmts.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 SeaMonkey/2.19

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Tue Nov 05, 2013 10:57 am

user wrote:It can detect them, but you'll have to mux them after downloading, since they're separate video and audio tracks, as in there's a 1080p mp4 video-only stream and N audio-only streams with different bitrates.

Any idea of how hard would be tracking and muxing them at the end of the download in JavaScript?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

GenericUser

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by GenericUser » Tue Nov 05, 2013 11:40 am

Youtube is at it again, my FG 94rc2 can no longer see 480p(or 1080p) flv videos. :|
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Tue Nov 05, 2013 12:00 pm

GenericUser wrote:Youtube is at it again, my FG 94rc2 can no longer see 480p(or 1080p) flv videos. :|

Example URL(s)?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

GenericUser

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by GenericUser » Tue Nov 05, 2013 5:25 pm

Whoops, now it's detecting them fine again. I dunno what's wrong previously.. maybe YT was being sluggish or something.

Sorry for false alarm.
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0

user

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by user » Wed Nov 06, 2013 4:50 pm

Giorgio Maone wrote:Any idea of how hard would be tracking and muxing them at the end of the download in JavaScript?


Well, in theory, tracking the download completion shouldn't be hard: in the new API (that moronic Promise junk in FF 26) you can pass a completion callback to the download's start() method, and in the current API we have nsIWebProgressListener. In practice, there're browser restarts. As for writing a muxer, it's not hard, just very time-consuming - the spec is huge (and that's all I can remember as it was ages ago the last time I touched it). The hardest part (for me at least) would be to pretend there're no tools (like ffmpeg) that can do it better and faster.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 SeaMonkey/2.19

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Wed Nov 06, 2013 8:10 pm

user wrote:The hardest part (for me at least) would be to pretend there're no tools (like ffmpeg) that can do it better and faster.

Well, when the necessity arises we could propose user to download and "install" on the fly our own private, static and platform specific static ffmpeg build and use it :)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Guest

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Guest » Wed Nov 06, 2013 9:04 pm

Giorgio Maone wrote:
user wrote:The hardest part (for me at least) would be to pretend there're no tools (like ffmpeg) that can do it better and faster.

Well, when the necessity arises we could propose user to download and "install" on the fly our own private, static and platform specific static ffmpeg build and use it :)

More and more Youtube videos are only appearing in 720p for me. Like this one... http://www.youtube.com/watch?v=OH7WgtuUZVA
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

guest

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by guest » Thu Nov 07, 2013 11:45 pm

Yep, my flashgot is having a problem detecting 480p, 720p (webm), 360p (flv). The problem seems worse in newer videos even though they have had time to render in these formats as I can watch them embedded on youtube.
The problem started 3-4 weeks ago but then the above formats weren't detected on ANY youtube video (old or newish). Your 1.5.5.94 update seemed to fix this temporarily.
The problem detecting streams has started again and seemed to coincide with the new FF 25 update.
I've tried deleting cookies, starting with other addons disabled and have reset FF and reinstalled flashgot to no avail.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

User avatar
Giorgio Maone
Site Admin
Posts: 8732
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Fri Nov 08, 2013 7:23 am

Guest wrote:More and more Youtube videos are only appearing in 720p for me. Like this one... http://www.youtube.com/watch?v=OH7WgtuUZVA

I get 6 different formats on this one (Firefox 25, FlashGot 1.5.5.94).
Does your problem happen on a clean profile with just FlashGot installed?
Adobe Flash version?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Tetris

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Tetris » Fri Nov 08, 2013 8:43 am

I also think something changed again: for what I could see, at least for videos uploaded after November 1 whose maximum quality available is 480p, Flashgot doesn't detect the Webm-480p anymore. For videos uploaded before November, Flashgot still detects it. It's not a huge problem, but since Webm-480p files seem to have a better quality image than the flv-480p files, it would be great if Flashgot could detect it again. Thanks and keep up the good work ;)
Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0

guest

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by guest » Fri Nov 08, 2013 10:58 pm

Giorgio Maone wrote:
Guest wrote:More and more Youtube videos are only appearing in 720p for me. Like this one... http://www.youtube.com/watch?v=OH7WgtuUZVA

I get 6 different formats on this one (Firefox 25, FlashGot 1.5.5.94).
Does your problem happen on a clean profile with just FlashGot installed?
Adobe Flash version?


I get NOTHING on this with my current "dirty" profile. Not even a flashgot icon. Flashgot 1.5.5.94, Adobe Flash 11.9 r900
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Sekiho

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Sekiho » Fri Nov 08, 2013 11:17 pm

since today, i cant get videos in 480p or 1080p with flashgot 1.5.5.94 and firefox 24, it was working fine previously and i havent updated anything on my system...
please try to find the solution!

p.s.: should i update to firefox 25?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Guest

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Guest » Sat Nov 09, 2013 12:51 am

Giorgio Maone wrote:
Guest wrote:More and more Youtube videos are only appearing in 720p for me. Like this one... http://www.youtube.com/watch?v=OH7WgtuUZVA

I get 6 different formats on this one (Firefox 25, FlashGot 1.5.5.94).
Does your problem happen on a clean profile with just FlashGot installed?
Adobe Flash version?

I do also get 6 different formats too. But none of them is 1080p/MP4

And yes I do just have FlashGot installed... No "Script blocker" or anything... "Clean profile"... What's that?

Adobe Flash: 11.9.900.117
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Post Reply