Flashgot no longer seeing 1080 MP4 on youtube

Ask for help about FlashGot, no registration needed to post
kittymew

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by kittymew » Fri Nov 29, 2013 4:34 pm

ssjkakaroto wrote:@kittymew: This happened with a few videos for me too, but the muxed (audio+video with ffmpeg) files were playable.

I can't get any files 1080p downloaded with flashgot DASH to work, but the mixed audio+video 720p versions downloaded with flashgot are fine
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by al_9x » Sat Nov 30, 2013 1:08 am

the audio streams appear to be in a dash container, which is playable by vlc, but not winamp or itunes.

remuxing dash to m4a with ffmpeg does not work properly

Code: Select all

ffmpeg -i input.dash -acodec copy output.m4a


this again plays in vlc but not in winamp or itunes

aac_adtstoasc filter does not help

Code: Select all

ffmpeg -i input.dash -acodec copy -bsf:a aac_adtstoasc output.m4a


demuxing first to aac then muxing to m4a with aac_adtstoasc, does finally produce a proper m4a,

Code: Select all

ffmpeg -i input.dash -acodec copy -f adts - | ffmpeg -i - -acodec copy -bsf:a aac_adtstoasc output.m4a

but this ought to be possible with a single (non piped) command, does anyone know how?
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

CuF
Junior Member
Posts: 32
Joined: Fri Dec 06, 2013 10:14 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by CuF » Fri Dec 06, 2013 10:22 pm

Pretty much the 'largest' version of videos have become unFlashGottable. This can even be 480p if it's the highest rez.

While the biggest streams turn up in the DASH submenu (whatever that is), for whatever reason I can't get anything to recognize and mux them (mp4 muxers or MKV).
I see the post above uses ffmpeg, but I've never wanted to go near that CLI craziness. Those streams are not proper for whatever reason.

Is this being worked on? I'm kind of frustrated.
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

User avatar
Giorgio Maone
Site Admin
Posts: 8701
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Sat Dec 07, 2013 10:42 am

CuF wrote:Pretty much the 'largest' version of videos have become unFlashGottable. This can even be 480p if it's the highest rez.

While the biggest streams turn up in the DASH submenu (whatever that is), for whatever reason I can't get anything to recognize and mux them (mp4 muxers or MKV).
I see the post above uses ffmpeg, but I've never wanted to go near that CLI craziness. Those streams are not proper for whatever reason.

Is this being worked on? I'm kind of frustrated.

Could you please mention at least one URL where this is consistently reproducible?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by al_9x » Sat Dec 07, 2013 8:42 pm

Giorgio Maone wrote:Could you please mention at least one URL where this is consistently reproducible?


The audio problem I encountered (likely related to CuF's) appears to be universal, e.g. https://www.youtube.com/watch?v=oGspoOoK69s (lowest bitrate streams)

Using Winamp (it along with itunes is the most finicky) as a test, neither the m4a nor mp4 produced by standard ffmpeg command-line will play.

If the m4a is created as directed in my previous post and the mp4 is muxed from this m4a and the original dash video, then both will play.
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

CuF
Junior Member
Posts: 32
Joined: Fri Dec 06, 2013 10:14 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by CuF » Sat Dec 07, 2013 10:00 pm

Could you please mention at least one URL where this is consistently reproducible?


Sure, except this board's spam filter is preventing me from posting YouTube links.
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

User avatar
Giorgio Maone
Site Admin
Posts: 8701
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Sat Dec 07, 2013 10:44 pm

CuF wrote:
Could you please mention at least one URL where this is consistently reproducible?


Sure, except this board's spam filter is preventing me from posting YouTube links.

Even one per post?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

User avatar
therube
Ambassador
Posts: 7426
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by therube » Sun Dec 08, 2013 12:26 pm

I can't get anything to recognize and mux them

That is going to be more related to the decoders used & what they do or don't do when they see "dash" in a files header.

An old version of VLC will not play DASH.
An old version of Media Info does not know DASH.
A general all purpose "video" utility, encoder, decoder, muxer... that may work well for "everything", may fail when it comes to DASH. It could be a single component in the utility, that if replaced, will allow it to work.

A current VLC will play DASH.
A current version of MediaInfo has basic knowledge of DASH.
The same general purpose video utility, once you replace the Media Info dll with the current version, is then able to handle DASH.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23

User avatar
therube
Ambassador
Posts: 7426
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by therube » Sun Dec 08, 2013 1:49 pm

Oh, I'll just note that one time on Youtube I noticed FlashGot Media had stale data, IOW it had download link, description for the prior page I was on rather then the current.

Not sure of circumstances, but a page refresh corrected the problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23

tintin

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by tintin » Sun Dec 08, 2013 5:51 pm

FG now can't seems to detect mp4 256k audio stream anymore, there's only webm equivalent. Which is lower quality than mp4 I think.

And sometimes it even shows only the lowest quality audio(48k).

example link: http://www.youtube.com/watch?v=c1uH8Jic2-E
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0

CuF
Junior Member
Posts: 32
Joined: Fri Dec 06, 2013 10:14 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by CuF » Sun Dec 08, 2013 7:38 pm

Trying again: https://www.youtube.com/watch?v=F S S C Q L N M N q 4 (remove spaces)
Can't get a muxed version at 480p (large) from this.
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by al_9x » Sun Dec 08, 2013 8:18 pm

CuF wrote:Trying again: https://www.youtube.com/watch?v=F S S C Q L N M N q 4 (remove spaces)
Can't get a muxed version at 480p (large) from this.


try the following command (substitute audio.dash, video.dash, muxed.mp4):

Code: Select all

ffmpeg -i audio.dash -acodec copy -f adts - | ffmpeg -i - -i video.dash -acodec copy -bsf:a aac_adtstoasc -vcodec copy muxed.mp4
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

CuF
Junior Member
Posts: 32
Joined: Fri Dec 06, 2013 10:14 pm

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by CuF » Mon Dec 09, 2013 6:27 pm

I don't even have ffmpeg. Not a fan. If FlashGot is not going to download the highest resolutions as muxed streams, perhaps IT should be sending commands to ffmpeg on completion of the download.
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

User avatar
therube
Ambassador
Posts: 7426
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by therube » Mon Dec 09, 2013 6:31 pm

FG now can't seems to detect mp4 256k audio stream anymore

How are you determining "256k" (or "48k")?

I see "small" & "medium" audio/mp4.
Are there (or are there supposed to be) more then that?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 SeaMonkey/2.24a2

User avatar
Giorgio Maone
Site Admin
Posts: 8701
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Flashgot no longer seeing 1080 MP4 on youtube

Post by Giorgio Maone » Mon Dec 09, 2013 9:12 pm

CuF wrote:I don't even have ffmpeg. Not a fan. If FlashGot is not going to download the highest resolutions as muxed streams, perhaps IT should be sending commands to ffmpeg on completion of the download.

That's the plan, in facts.
(On a side note, FlashGot is not going to download the highest resolutions as muxed streams not by bad will, but because Youtube doesn't make them available anymore: they're demuxed or nothing).
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Post Reply