Anon in ABE bug

Discussions about the Application Boundaries Enforcer (ABE) module
JamesB

Anon in ABE bug

Post by JamesB » Tue Apr 25, 2017 11:41 pm

Hi,
I believe I have stumbled on a bug in ABE. "Anon" does not seem to be working.
Symptoms include:
Endless duplicate ABE errors are reported in browser console.
Web pages never finish loading.
4gb of memory runs low and begins to use most of 4gb swap.

To Reproduce:
Use Firefox 53, with new profile.
Install noscript 5.0.3 (and no other addons).
Allow Scripts Globally (only for test purposes)
Use the following test rule for ABE

Code: Select all

#### ANON TEST
Site .googlesyndication.com
Accept from .googlesyndication.com
Anon
Now go to a site such as http://distrowatch.com/ or any other site using google syndication.
The site will never finish loading and endless errors will appear in Broswer Console.

Firefox is in multiprocess/e10s mode, by the way.

I have tried Noscript 5.0.4rc1 (dev build) too, but no luck.

Thanks
Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

barbaz
Senior Member
Posts: 9266
Joined: Sat Aug 03, 2013 5:45 pm

Re: Anon in ABE bug

Post by barbaz » Sat Sep 21, 2019 12:12 am

Guest wrote:
Fri Sep 20, 2019 6:00 pm
This is thread for anon (== without annoying registration) ABE bug reports?
No, it's only for the specific bug report of the OP. Posting anywhere in this ABE section of the forum, including creating new threads, does not require registration.

Guest, I split your post to viewtopic.php?f=23&t=25744 , please continue there.
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply