Authentication required when open firefox after installing N

Discussions about the Application Boundaries Enforcer (ABE) module
vahidjavani
Posts: 3
Joined: Sat Oct 10, 2015 7:43 pm

Authentication required when open firefox after installing N

Post by vahidjavani » Sat Oct 10, 2015 7:50 pm

Whenever I open Firefox authentication required pop-up appeared even when NoScript is in Allow Script Globally mode. The text of this pop-up is: 'A username and password are being requested by http://MY_INTERNET_IP_ADDRESS. The site says: "DSL-xxxxx" ' when I type user/pass my router or close it pop-up disappeared, but if fill out with wrong password ask me again.

In NoScript addon there is no any blocked script. Also this happen only when I connect to the router (connect via Ethernet), even not happen when I connect to another router with WiFI.

Finally my problem solved when uncheck WAN IP -> LOCAL in ABE section
Could you please tell me what should I do and why this happened.
Last edited by barbaz on Sat Oct 10, 2015 8:42 pm, edited 1 time in total.
Reason: kill live link to address intended only as example
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0

barbaz
Senior Member
Posts: 9148
Joined: Sat Aug 03, 2013 5:45 pm

Re: Authentication required when open firefox after installi

Post by barbaz » Sat Oct 10, 2015 8:45 pm

Oh, I don't know... check the redirection chain of the router login... look at the ABE message(s) in the Browser Console (Ctrl-Shift-J) when this issue occurs (and post them here please)... do a DNS lookup of the addresses whose DNS lookup you don't know or aren't sure of... install NoRedirect and configure it to block all redirects (Regex: .*, check only "Source") if the console message is gone...

Well anyway, something along those lines should get you an explanation. Please post the results, thanks.
*Always* check the changelogs BEFORE updating that important software!
-

vahidjavani
Posts: 3
Joined: Sat Oct 10, 2015 7:43 pm

Re: Authentication required when open firefox after installi

Post by vahidjavani » Sun Oct 11, 2015 6:41 am

barbaz wrote:look at the ABE message(s) in the Browser Console


Thanks for your answer, that problem occurred because I have a GET request to http://MY_INTERNET_IP ADDRESS.
http://textuploader.com/ay149
Could you please tell me what should I do again (to prevent this request at start firefox).
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0

barbaz
Senior Member
Posts: 9148
Joined: Sat Aug 03, 2013 5:45 pm

Re: Authentication required when open firefox after installi

Post by barbaz » Sun Oct 11, 2015 3:31 pm

Not sure but I think you may have already found out how to do that. Try un-check the "WAN IP LOCAL" box, then change your SYSTEM ruleset to look like this?

Code: Select all

# Prevent Internet sites from requesting LAN resources.
Site LOCAL YOUR_INTERNET_IP_ADDRESS YOUR_INTERNET_DOMAIN_NAME(S)_IF_ANY
Accept from LOCAL SELF+
Deny


As indicated above, you'll need to reverse-DNS-lookup your WAN IP to see what resolved to it, then add those domains (if any) as well, separated by one space.


(You're supposed to be able to simply add the IP to noscript.ABE.localExtras, but last I checked that causes *all* traffic to be blocked.)


EDIT Oh, and I should have said that the reason it happens is because NoScript fingerprints the device on your WAN IP in order to protect it better.
*Always* check the changelogs BEFORE updating that important software!
-

vahidjavani
Posts: 3
Joined: Sat Oct 10, 2015 7:43 pm

Re: Authentication required when open firefox after installi

Post by vahidjavani » Sun Oct 11, 2015 8:47 pm

OK, thank you so much.
Be happy :)
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0

barbaz
Senior Member
Posts: 9148
Joined: Sat Aug 03, 2013 5:45 pm

Re: Authentication required when open firefox after installi

Post by barbaz » Sun Oct 11, 2015 8:49 pm

np :)
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply