Turn off / truncate ABE warning

Discussions about the Application Boundaries Enforcer (ABE) module

Turn off / truncate ABE warning

Postby krbvroc1 » Thu Nov 09, 2017 11:30 pm

All of a sudden on tube ABE is messing up the browser. See linked image for what I mean.

1) Can I just turn off the warning display (while keeping ABE on)?
2) Better yet - can it be fixed so it truncates to a single line? The long URL is messing up the scrollbar and requires expanding the window very wide to even get to the 'Options' button.

Thanks

(FF ver 52.4.0 ESR - Linux) and NS 5.1.5

Image
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
krbvroc1
 
Posts: 6
Joined: Thu Nov 09, 2017 11:04 pm

Re: Turn off / truncate ABE warning

Postby barbaz » Thu Nov 09, 2017 11:41 pm

1) Yes - go to NoScript Options > Notifications, un-check "ABE"

2) Not that I know of.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7417
Joined: Sat Aug 03, 2013 5:45 pm

Re: Turn off / truncate ABE warning

Postby krbvroc1 » Thu Nov 09, 2017 11:49 pm

Thanks for the quick reply - not sure how I missed that option - i thought that was disabling ABE - but obviously being under the 'notifications' tab says otherwise.

As far as it getting fixed - is this where a bug report is to be filed? Obviously the behaviour of messing up the browser width isn't correct and depending on your monitor size you might not even be able to get to the 'options' button since it might require widening the window beyond the dimensions of your desktop size.
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
krbvroc1
 
Posts: 6
Joined: Thu Nov 09, 2017 11:04 pm

Re: Turn off / truncate ABE warning

Postby barbaz » Fri Nov 10, 2017 1:59 am

krbvroc1 wrote: is this where a bug report is to be filed?

Yes. All you need to do to turn this thread into a bug report is post full steps to reproduce the problem.

However, the specific ABE warning in your screenshot is not a good example IMO. It is indicative of a misconfigured HOSTS file. And anyway ABE is not supposed to fire any notification for blocking that request, its doing so is another bug.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7417
Joined: Sat Aug 03, 2013 5:45 pm

Re: Turn off / truncate ABE warning

Postby krbvroc1 » Fri Nov 10, 2017 2:37 am

barbaz wrote:However, the specific ABE warning in your screenshot is not a good example IMO. It is indicative of a misconfigured HOSTS file. And anyway ABE is not supposed to fire any notification for blocking that request, its doing so is another bug.


You imply a misconfigured hosts file. I use an external DNS that blocks many things via dnsbl lists - certainly doubleclick.net is one of them. Oddly, unless tube changed something this never happened prior to today so I wonder if something in a recent NS broke something.

The post you linked is 3 1/2 years old...doesn't sound promising for ever being fixed.

To be honest, I'm not sure a reproducible sample should be needed to fix this concept. NS, whatever it decides to display, should not be messing up the browser frame like that. When it attempts to display the URL, it exceeds the browser width but doesn't add any scrollbar. It is like wordwrapping or the window size is not computed properly. It should also truncate with a '...' after a reasonable length. Trying to display a 500 character URL doesn't seem reasonable in any case.

All that left margin on the video was NOT there until NS displays the URL notification. It shifted the entire video player frame to the right by 25% or so.
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
krbvroc1
 
Posts: 6
Joined: Thu Nov 09, 2017 11:04 pm

Re: Turn off / truncate ABE warning

Postby barbaz » Fri Nov 10, 2017 3:23 am

krbvroc1 wrote:You imply a misconfigured hosts file. I use an external DNS that blocks many things via dnsbl lists - certainly doubleclick.net is one of them.

Then your external DNS may be misconfigured. Can you please post the output of running this command in a terminal? -
Code: Select all
dig googleads.g.doubleclick.net


krbvroc1 wrote:To be honest, I'm not sure a reproducible sample should be needed to fix this concept.

I've seen massive URLs cause oversized notifications before, but never seen the Options button get pushed off screen. So yes, clear and complete steps to reproduce are needed. Please also include the size of your browser window, which you can get by running this bookmarklet -
Code: Select all
javascript:alert(window.outerWidth+'x'+window.outerHeight);


krbvroc1 wrote:All that left margin on the video was NOT there until NS displays the URL notification. It shifted the entire video player frame to the right by 25% or so.

That looks like Youtube put the video in theater mode.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7417
Joined: Sat Aug 03, 2013 5:45 pm

Re: Turn off / truncate ABE warning

Postby krbvroc1 » Fri Nov 10, 2017 3:41 am

barbaz wrote:
krbvroc1 wrote:You imply a misconfigured hosts file. I use an external DNS that blocks many things via dnsbl lists - certainly doubleclick.net is one of them.

Then your external DNS may be misconfigured. Can you please post the output of running this command in a terminal? -
Code: Select all
dig googleads.g.doubleclick.net


10.x.x.x (internal address on different subnet than my PC) - returns a 1 pixel gif image
(external IP listed in ABE for my router is correct)

barbaz wrote:
krbvroc1 wrote:To be honest, I'm not sure a reproducible sample should be needed to fix this concept.

I've seen massive URLs cause oversized notifications before, but never seen the Options button get pushed off screen. So yes, clear and complete steps to reproduce are needed. Please also include the size of your browser window, which you can get by running this bookmarklet -
Code: Select all
javascript:alert(window.outerWidth+'x'+window.outerHeight);


1247x1170

barbaz wrote:
krbvroc1 wrote:All that left margin on the video was NOT there until NS displays the URL notification. It shifted the entire video player frame to the right by 25% or so.

That looks like Youtube put the video in theater mode.


I had the player set in theater mode myself. (not something I normally use to be honest)
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
krbvroc1
 
Posts: 6
Joined: Thu Nov 09, 2017 11:04 pm

Re: Turn off / truncate ABE warning

Postby barbaz » Fri Nov 10, 2017 3:56 am

krbvroc1 wrote:10.x.x.x (internal address on different subnet than my PC) - returns a 1 pixel gif image

Did you deliberately set this up for logging purposes? If not, your DNS should be returning either 0.0.0.0 or NXDOMAIN for blocked domains.

krbvroc1 wrote:1247x1170

That's bigger than my browser window. So I did a quick test with a massive made-up URL, and I still see the Options button. Shrinking the window horizontally did not cause the Options button to disappear. It stayed visible on screen the whole time.

Does disabling all extensions other than NoScript (Tools > Add-ons Manager) prevent the disappearance of the Options button?
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7417
Joined: Sat Aug 03, 2013 5:45 pm

Re: Turn off / truncate ABE warning

Postby krbvroc1 » Sat Nov 11, 2017 1:20 am

barbaz wrote:
krbvroc1 wrote:10.x.x.x (internal address on different subnet than my PC) - returns a 1 pixel gif image

Did you deliberately set this up for logging purposes? If not, your DNS should be returning either 0.0.0.0 or NXDOMAIN for blocked domains.


It is the way the firewall (pfsense and the dns blocker handle it). Logging is probably the main reason - if something is being blocked and you want to whitelist it you can enable logging to troubleshoot what is being routed to that IP, etc. Not sure if having 'something' in the HTML DOM (even 1 pixel) can preserve some page layout or not. Regardless this isn't the issue - I changed the DNS to return 0.0.0.0 and same issue.

barbaz wrote:
krbvroc1 wrote:1247x1170

That's bigger than my browser window. So I did a quick test with a massive made-up URL, and I still see the Options button. Shrinking the window horizontally did not cause the Options button to disappear. It stayed visible on screen the whole time.

Does disabling all extensions other than NoScript (Tools > Add-ons Manager) prevent the disappearance of the Options button?


I know you said you used a massive URL - I just checked - the one I am seeing is at approx 1747 chars.

I only have 3 other extensions - disabling them made no difference.

Widening the Firefox window to 2048 pixels shows to the Options button. Widening it further is fine - it expands. Narrowing it causes the option button to scroll off screen. It appears to be the equivalent of setting a 'min-width:2048px' on that notification area. It messes up all tabs of the browser too - even preferences tab. I tried changing default font (have mine set at 16) preferences but it made no difference. I tried zoom/unzoom the page and it scaled the video but not the notification bar. I tried normal and theater mode - same.
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
krbvroc1
 
Posts: 6
Joined: Thu Nov 09, 2017 11:04 pm

Re: Turn off / truncate ABE warning

Postby barbaz » Sat Nov 11, 2017 3:38 am

krbvroc1 wrote: I changed the DNS to return 0.0.0.0 and same issue.

Huh. I can confirm this behavior. I'm pretty sure that's not supposed to happen. Or at least, it didn't used to for me.

I will start another thread about this. EDIT Done - viewtopic.php?f=10&t=23535

krbvroc1 wrote:I only have 3 other extensions - disabling them made no difference.

Please create a clean profile from scratch. Install only NoScript latest development build, leaving all the defaults.
Does the problem still exist?

If yes, I suggest just disabling the notification until NoScript Webext is out. Please let us know if this is still an issue in NoScript Webext.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7417
Joined: Sat Aug 03, 2013 5:45 pm

Re: Turn off / truncate ABE warning

Postby krbvroc1 » Sun Nov 12, 2017 7:56 pm

barbaz wrote:Please create a clean profile from scratch. Install only NoScript latest development build, leaving all the defaults.
Does the problem still exist?


With a clean profile and the devel build 5.1.5rc2 I see the same behaviour. The only thing different I noticed is that the word wrap is even worse. I need to increase the browser width to 2658 pixels before I see the first pixel of the Options button start to show.

barbaz wrote:If yes, I suggest just disabling the notification until NoScript Webext is out. Please let us know if this is still an issue in NoScript Webext.


I am running on Centos 7 (which uses Firefox 52 ESR). Since they are using extended release versions, I imagine we will probably remain on 52 ESR until the next ESR version comes out which is Firefox 59 ESR. How will this work with NS? Will the newer Webextensions version work on version 52 ESR? Or will older version be maintained until the next 59 ESR?
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
krbvroc1
 
Posts: 6
Joined: Thu Nov 09, 2017 11:04 pm

Re: Turn off / truncate ABE warning

Postby barbaz » Sun Nov 12, 2017 8:25 pm

krbvroc1 wrote:I am running on Centos 7 (which uses Firefox 52 ESR). Since they are using extended release versions, I imagine we will probably remain on 52 ESR until the next ESR version comes out which is Firefox 59 ESR. How will this work with NS? Will the newer Webextensions version work on version 52 ESR? Or will older version be maintained until the next 59 ESR?

NoScript Webext will only work with Firefox 57 and up. But NoScript supports Tor Browser, which is based on Firefox ESR, so legacy NoScript isn't going away immediately when NoScript Webext is released.

More info: viewtopic.php?f=7&t=23173
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 7417
Joined: Sat Aug 03, 2013 5:45 pm


Return to ABE

Who is online

Users browsing this forum: Bing [Bot] and 1 guest