So I Fired Up A New Computer

General discussion about web technology.
Post Reply
User avatar
therube
Ambassador
Posts: 7236
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

So I Fired Up A New Computer

Post by therube » Sat Nov 17, 2018 7:37 am

So I Fired Up A New Computer...

actually, an old computer that I hadn't used in (4 or so) years, so "new", in that respect.
and it had some (now) ancient version of SeaMonkey on it, of course.
so I fired that up.
& it loaded up a boatload of pages & tabs & some (now) ancient version of NoScript, of course.

& it looked & worked & did everything well, (well except for failing on some https: sites - expected).
& had someone come along & put that outdated SeaMonkey version on my current computer, it would have taken me a while to realize that I was in fact running something quite "outdated".

and today, I fired up FF (63), which I really haven't paid any mind to of late, with NoScript 10, of course, & I am simply baffled. flustered. both by the browser (UI & UX), & now also on how to accomplish "simple" tasks in NoScript (10). so I do what I typically do in a situation like that - with NoScript, I did a Reset. which accomplished, nothing. still flustered.


(Suppose I could make a similar analogy between WinXP/Win7 & Win10.)



(That old computer, i5-750, 4 GB RAM, Win7 x64, I can almost guarantee that it runs "better" then my brothers newly purchased Dell Optiplex i5-8600, 8 GB RAM, Win10. It might not win in outright "horsepower", but it will respond better & work better to user inputs then that Dell. Am I a better builder then Dell? Do I know better then Dell? Then why am I happy with my old box, yet cringe when placed in front of a Win10 machine?)



All-in-on printer you say?
We've had a Brother AIO.
Works fine. Old. Rather slow, it works.

Brother's wife, she saw an HP demo & decides she's going to get some HP MFC 526f (or some such) AIO.
And it's fast too. (It is, really. But then so is FF 63 ;-).)
So I install the driver/software on her Win10. That worked fine.
And then I install that same driver/software on another Win10.
Fail. Try this, try that... Fail.
Call HP.
HP connects to the machine. Try's the install again. Fail.
But he knows what to do, he knows all the tricks. Points me to the "universal" driver, & that "worked".
But then we also need the software end.
Which still doesn't work.
But he again knows the trick - an "app".
And I ask, what is an "app"? And how is that different from a "program"?
Anyhow, "app" it is, & it too "worked".

"Worked".
Well both the installed program, on 1 Win10 machine, & the "app" on a 2nd Win10 machine, suck. Basically some piece of drek software program - that hasn't been updated in years, that has a rather awful UI/UX. A true pain compared to the straight forward, even if a bit more simplistic software that came with the Brother machine.

The UI (pint sized screen) of the printer itself... well for a person who doesn't use a cellphone, & has actual, fingers, lets just say, not to my liking.

And did I mention WinXP? Yep got some of them too. So on that same call with HP, he wants to see that software not install on XP. I tell him it won't, but he wants to see, so now he's connected to the XP machine, & guess what, the software doesn't install. Go figure. And with that XP was out of his league. He wasn't coming up with any answers on that, short of, "replace the machine".

I figured it out, though - at least getting a driver installed so that you could at least print to it.

And with that, oh, you thought I was going to say we were done?
I wish.
So on that 2nd Win10 machine, my brother comes to me & says, "I printed this report & it's not right".
Yes, it was not right, not by a long shot.
So I called up the girl where I first installed the software on her Win10 machine.
"Have you printed a wide report from the accounting to the new HP printer"?
No, she hadn't.
With that, I simply assume that had she attempted she would have run into the same situation.
(And you know what happens with that.)
So I try, from XP, where all that was installed was a driver, so should be OK, OK?
Nope. Easily better then the 2nd Win10, but that XP also was not working right.

So I think... call HP, again... but figuring the guy's gonna be out of tricks.
So I look at the drivers & I start looking through the .inf's, of which there were 3 available.
And not that I know what the differences are, but I figure if one of them didn't work, it can't hurt to try the other two.
Now which of the 3 was installed on a particular machine is anyone's guess.
I couldn't figure out how to tell.
I could tell which .inf looked to be the expected correct one, but that proved to be wrong ;-).
So I "tried" the others.

"Tried".
Tried, as I selected a particular .inf, but after that it was not clear just what was being installed, or even if anything different from what was there was being installed? (This was true over all OS's.)
Anyhow, 1 of the 3 did actually work. Got it working on XP. Got it working on the 2nd Win10.

Then I went to the 1st Win10, where the full driver/software did install, but where printing through accounting hadn't actually been tested. And guess what? Yep, you guessed. It WORKED.

So XP, HP is unable to figure that out. Got it working.
On Win10 #1, it worked, from the start.
On Win10 #2, flat out failed. Had to get HP to "fix" that. And that "fix" also did not work, fully. So I had to "fix" that too.
(I hope my fix ends up being the fix ;-).)



Did I mention I'm looking for a new computer for myself :lol:.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus

Post Reply