Firefox and general browser trouble

General discussion about web technology.
Post Reply
Vordreller
Junior Member
Posts: 36
Joined: Thu Mar 26, 2009 7:58 am

Firefox and general browser trouble

Post by Vordreller » Tue Jul 28, 2009 10:57 pm

I'm experiencing something very odd on my laptop these days.

I've had it for almost 2 years, and have used Firefox on it all the time. I have all other major browsers on it, just in case and, and update them when a new release is out.
Never had trouble before, untill now.

For some reason, firefox will stop loading images, take very long to load a site and even time out a connection.
I thought "maybe it's just firefox", but the other browsers have it too.

What helps is starting in safe mode and resetting everything. Then I re-enabled all the addons and plugins, and stuff just works again.
But the good times usually only last for 24 hours or less. Then I have to do it again.

Odd thing is that doing this also affects the performance of all other browsers: Opera, Chrome and IE8
Non of them will load images and most websites, until I reset firefox.

Are there any addons know to do this?
Also, I keep getting a message every now and then that the Key Management Service can't verify me. And usually the firefox stuff starts an hour or 2 after that.
It's the same install I did 2 years ago and the KMS system has existed for over a year now. I don't get it, I really don't get what's wrong here.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

User avatar
Giorgio Maone
Site Admin
Posts: 8686
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Firefox and general browser trouble

Post by Giorgio Maone » Wed Jul 29, 2009 12:03 am

Since it affects other browsers as well, this is hardly a Firefox-specific issue.
Are you behind a proxy?
Have you got any personal Firewall?
Could you check if your connection parameters (and especially the DNS servers) are OK? (you may want to switch to Open DNS)
I'd also perform a full virus scan, possibly offline on boot.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Vordreller
Junior Member
Posts: 36
Joined: Thu Mar 26, 2009 7:58 am

Re: Firefox and general browser trouble

Post by Vordreller » Wed Jul 29, 2009 7:59 am

Giorgio Maone wrote:Are you behind a proxy?

No, I've never used a proxy in my entire life. All my settings on the programs I use(MSN messenger and such) are explicitly set to "no proxy" instead of "use system settings"
Giorgio Maone wrote:Have you got any personal Firewall?
Windows Firewall is turned completely off and I have no extra firewall software installed.
Giorgio Maone wrote:Could you check if your connection parameters (and especially the DNS servers) are OK? (you may want to switch to Open DNS)
I'd also perform a full virus scan, possibly offline on boot.

Sadly, I have no access to the router through which my traffic goes.
Concerning the virusscan, I'm using mcaffee and really have no clue as to how to do that with this program.

What I do know is that when playing an online game, like a First Person Shooter, everything works like it should. No lag, no nothing wrong with it.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Post Reply