Page 2 of 10

Re: µMatrix thread

Posted: Tue Nov 17, 2015 2:30 am
by barbaz
Thrawn wrote:I believe he supports Pale Moon, too.

Indeed so, looks like this all started materializing @ https://github.com/gorhill/uMatrix/commit/d265619145aa0f51e5171dedbd913fac23e190ad FWIW. Also seems that SeaMonkey support had come and gone before.. hopefully this time SeaMonkey support is here to stay.

(I haven't tried using µMatrix on Pale Moon.)

Re: µMatrix thread

Posted: Tue Nov 17, 2015 2:42 am
by Thrawn
Well, I know the Pale Moon folks are happy to have him on board, because ABP wouldn't play ball. Wladimir decided he doesn't trust the codebase to keep up and be supportable.

Re: µMatrix thread

Posted: Wed Nov 18, 2015 4:56 am
by Thrawn
Been trying out uMatrix for the past day or two, and I'm liking it a lot.

Unfortunately the "Very bare walkthrough for first time users" has never been finished...and from what the Pale Moon folks are saying, the filtering works fine without Australis but the icon does not. So Seamonkey is probably out of luck.

However, the functionality seems like a good mix of RP, ABP, and ABE. Choose the origin scope (domain, subdomain, or global), then you have a matrix of destinations (at different granularities) and request types that appear on the current page. You can whitelist or blacklist any combination by clicking the top or bottom of each row, column, or cell. You can also disable all filtering on the current origin scope, spoof user agent or referrer, force HTTPS...pretty sweet.

Truthfully, it does cast a lot of doubt on the value proposition of SABER...ABE can still do things that uMatrix can't, but you probably want to write that kind of specialised stuff directly in text anyway. For the kind of day-to-day usage where you really want a GUI, I think uMatrix may have it covered, better than I could do without a whole lot more time than I think I'll have to invest in it.

Thoughts? [edit by barbaz: that discussion was moved to the main SABER thread viewtopic.php?f=19&t=8059 ]

Re: µMatrix thread

Posted: Wed Nov 18, 2015 3:35 pm
by gorhill
Thrawn wrote:So Seamonkey is probably out of luck.

SeaMonkey is officially supported, meaning if something does not work on it, I will look into it. There are fixes related to the toolbar icon in the latest dev build (0.9.3.2b2 on AMO). Ultimately, just as with uBO, if there are toolbar icon issues which still persist, the usual cure is to force the "legacy mode" (pre-Australis mode) for the toolbar icon, i.e. to set the `about:config` preference `extensions.umatrix.forceLegacyToolbarButton` to `true`.

Re: µMatrix thread

Posted: Wed Nov 18, 2015 7:06 pm
by barbaz
gorhill wrote:SeaMonkey is officially supported, meaning if something does not work on it, I will look into it.

That is good news! :D 8-)

gorhill wrote:`about:config` preference `extensions.umatrix.forceLegacyToolbarButton` to `true`.

Where are µMatrix's about:config prefs documented? I can't find it in the wiki.
There aren't any default values, so without reading documentation it's hard to figure out what can be set and how.

Re: µMatrix thread

Posted: Wed Nov 18, 2015 10:33 pm
by Thrawn
barbaz wrote:Where are µMatrix's about:config prefs documented? I can't find it in the wiki.

If you search Github for 'defaultLocalUserSettings', you'll find some of them.

Re: µMatrix thread

Posted: Thu Nov 19, 2015 12:46 am
by Thrawn
Btw, one of the types that uMatrix can filter is cookies, so it has at least a partial implementation of the Anonymize action.

Re: µMatrix thread

Posted: Thu Nov 19, 2015 1:06 am
by barbaz
Thrawn wrote:Btw, one of the types that uMatrix can filter is cookies, so it has at least a partial implementation of the Anonymize action.

which can be used as a partial stopgap for this RFE viewtopic.php?f=10&t=20150

Re: µMatrix thread

Posted: Thu Nov 19, 2015 6:35 pm
by barbaz
I'm not sure if this is a µMatrix bug or NoScript bug (or neither?)...

I have all plugin content blocked in µMatrix, and www.youtube.com whitelisted in NoScript.
If go to some youtube video such that I get the Flash video player, then Allow scripts on s.ytimg.com via NoScript (or is it Allowing the Flash object?), then the Flash player itself loads but the video does not play.

Why is this happening? I don't think the Flash object should load at all.

(I have no "special" addons for youtube.)

Re: µMatrix thread

Posted: Thu Nov 19, 2015 7:20 pm
by barbaz
^ Apparently µMatrix thinks the requests are coming from "behind-the-scene", where filtering is disabled. Is my only option to enable & tweak matrix filtering for "behind-the-scene", or is it a bug in µMatrix?
(Blocking with another addon has the expected effect...)

Re: µMatrix thread

Posted: Thu Nov 19, 2015 10:47 pm
by Thrawn
Have you filed it on the uMatrix Github issue tracker?

Re: µMatrix thread

Posted: Fri Nov 20, 2015 1:29 am
by barbaz
No, because I don't have a GitHub account and cannot register one. Can you file it for me with a link to my post?

Re: µMatrix thread

Posted: Fri Nov 20, 2015 12:10 pm
by barbaz
@Thrawn: What is your opinion about moving the SABER related posts to the SABER thread so that they don't get mixed up with general µMatrix discussion?

Re: µMatrix thread

Posted: Mon Nov 23, 2015 12:33 am
by Thrawn
barbaz wrote:@Thrawn: What is your opinion about moving the SABER related posts to the SABER thread so that they don't get mixed up with general µMatrix discussion?

Go ahead.

Re: µMatrix thread

Posted: Mon Nov 23, 2015 2:41 am
by Thrawn
Issue was filed as https://github.com/gorhill/uMatrix/issues/417 and marked as expected behavior.