Page 9 of 10

Re: µMatrix thread

Posted: Fri Jul 07, 2017 8:27 pm
by barbaz
yes_noscript wrote:if you use uMatrix you dont need [...] ghostery
µMatrix and Ghostery are not redundant. How do you figure that µMatrix makes Ghostery unnecessary?

Re: µMatrix thread

Posted: Sat Nov 18, 2017 2:59 am
by barbaz
https://github.com/gorhill/uMatrix/comm ... 354a266307

Does this mean that Pale Moon support is being dropped and SeaMonkey won't be supported until it gets WebExtensions support? Or just that users of those browsers will have to self build µMatrix releases from the source from now on?

Re: µMatrix thread

Posted: Sat Nov 18, 2017 6:36 pm
by yes_noscript
I would say, yes.
But with Basilisk a "new" Pale Moon start which support (not all) webextensions

Re: µMatrix thread

Posted: Mon Nov 27, 2017 3:01 am
by gracious1
barbaz wrote:https://github.com/gorhill/uMatrix/comm ... 354a266307

Does this mean that Pale Moon support is being dropped and SeaMonkey won't be supported until it gets WebExtensions support? Or just that users of those browsers will have to self build µMatrix releases from the source from now on?
It means that they are ceasing the XPCOM edition of uMatrix (umatrix.firefox.xpi). There will be one for Firefox Quantum, which is WebExtension (umatrix.webext.xpi), and one for Chromium (umatrix.chromium.xpi).
  • Going forward, uMatrix will not work on:
    • SeaMonkey (until it gets WebExt support)
    • Pale Moon (which will never support WebExt)
    • Any other Gecko/Goanna browser that will not support WebExt
    It will work on:
    • Firefox Quantum
    • Waterfox
    • Cyberfox
    • Basilisk
      also
    • Chromium
    • Chrome
    • Opera
FYI: the same developers will continue to develop the XPCOM edition of uBlock Origin, which blocks a lot of stuff and can be made more powerful with dynamic filtering.

HTH

Re: µMatrix thread

Posted: Mon Nov 27, 2017 3:10 am
by barbaz
Thanks gracious1.

Oh well, at least µMatrix 1.1.0 works well for me.

EDIT
Apparently there is now a Github issue about this - https://github.com/gorhill/uMatrix/issues/826

Re: µMatrix thread

Posted: Tue Nov 28, 2017 9:30 am
by gracious1
yes_noscript wrote:I would say, yes.
But with Basilisk a "new" Pale Moon start which support (not all) webextensions
Basilisk is in no sense a "new" Pale Moon. It is a different browser. It is created by Moonchild Productions, which also created Pale Moon. They are two separate products which Moonchild Productions shall continue to develop indefinitely.

Re: µMatrix thread

Posted: Wed Jan 03, 2018 2:56 am
by barbaz
In µMatrix legacy, it was possible to mostly disable placeholders using user.js. By "mostly disable" I mean only (i)frames had placeholders, and other elements had no visual placeholders, i.e. they looked like browser default behavior for blocked content.

Code: Select all

user_pref("extensions.umatrix.placeholderBackground", "");
user_pref("extensions.umatrix.placeholderBorder", "");
user_pref("extensions.umatrix.placeholderImage", "");
I'm now using µMatrix webext 1.1.20. How to disable placeholders for everything other than (i)frames now?

btw, Happy New Year @gorhill :D

Re: µMatrix thread

Posted: Wed Jan 03, 2018 4:36 pm
by kukla
With my 52esr, I'm stuck on v.1.0.0. Going forward, at least until 52esr EOL, what are the security implications of running uMatrix, for all intents and purposes, unsupported?

Re: µMatrix thread

Posted: Wed Jan 03, 2018 4:56 pm
by barbaz
No need to use a version quite that old. I suggest you use µMatrix 1.1.0, as I did before moving to a Webext-compatible browser.

You can look at the changelog to see what changes you're missing - https://github.com/gorhill/uMatrix/releases

Re: µMatrix thread

Posted: Wed Jan 03, 2018 6:18 pm
by kukla
barbaz wrote:No need to use a version quite that old. I suggest you use µMatrix 1.1.0, as I did before moving to a Webext-compatible browser.

You can look at the changelog to see what changes you're missing - https://github.com/gorhill/uMatrix/releases
Thanks, but for v.1.1.0 at https://addons.mozilla.org/en-US/firefo ... /versions/

seeing "this version not compatible...."

Re: µMatrix thread

Posted: Wed Jan 03, 2018 6:31 pm
by barbaz
kukla wrote:Thanks, but for v.1.1.0 at https://addons.mozilla.org/en-US/firefo ... /versions/

seeing "this version not compatible...."
Yeah, which is why I provided the link where you can get the legacy version 1.1.0.

Re: µMatrix thread

Posted: Wed Jan 03, 2018 9:40 pm
by kukla
Didn't understand (obviously). Thanks, will get that.

Re: µMatrix thread

Posted: Wed Jan 03, 2018 11:37 pm
by kukla
Wrinkle: downloaded the Firefox 1.1.0 xpi from github. "Could not be installed because not verified"

Re: µMatrix thread

Posted: Wed Jan 03, 2018 11:41 pm
by barbaz
kukla wrote:Wrinkle: downloaded the Firefox 1.1.0 xpi from github. "Could not be installed because not verified"
about:config > set xpinstall.signatures.required to false

Re: µMatrix thread

Posted: Thu Jan 04, 2018 1:09 am
by kukla
Knew there was something like that, couldn't remember just where. Will give that a go later on.