Board is SLOW

Discussion about the board itself, forums organization and site bugs.
User avatar
therube
Ambassador
Posts: 7247
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Board is SLOW

Post by therube » Mon Dec 03, 2018 11:57 pm

Board is SLOW of late.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

User avatar
GµårÐïåñ
Lieutenant Colonel
Posts: 3325
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA
Contact:

Re: Board is SLOW

Post by GµårÐïåñ » Tue Dec 04, 2018 1:03 am

It is but not too bad. Afterall years of data is hogging the database and it takes up space and parsing that will take longer over time.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
________________ .: [ Major Mike's ] :. ________________
Mozilla/5.0 (Windows; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

barbaz
Senior Member
Posts: 8831
Joined: Sat Aug 03, 2013 5:45 pm

Re: Board is SLOW

Post by barbaz » Wed Dec 05, 2018 9:04 pm

I too have noticed this slowness in the last few days. It's tolerable for normal browsing, but it really kills my scripts for this site.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7247
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Board is SLOW

Post by therube » Thu Dec 06, 2018 3:59 pm

it really kills my scripts for this site
Is it this, slowness, or is it Sledge, or is it just my Sledge is outdated?

The other day, when I originally posted this SLOW, at some point it kind of worked, at least it (eventually) displayed the prompts, but then on clicking it, it did not do what it should have, del+ban.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

User avatar
therube
Ambassador
Posts: 7247
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Board is SLOW

Post by therube » Thu Dec 06, 2018 4:05 pm

In addition to SLOW, thinking it is the board itself too.

Even 'Select All' in a

Code: Select all

 box is not working.

Sledge was last updated March 2018, so I must be current with that.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

barbaz
Senior Member
Posts: 8831
Joined: Sat Aug 03, 2013 5:45 pm

Re: Board is SLOW

Post by barbaz » Thu Dec 06, 2018 4:16 pm

therube wrote:Even 'Select All' in a

Code: Select all

 box is not working.[/quote]
[img]http://i.psyche.me/confused_2.gif[/img] It works fine for me.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7247
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Board is SLOW

Post by therube » Thu Dec 06, 2018 5:30 pm

Ah, you're right, oh, & that's going to be the reason why Sledge wasn't working - I had, javascript.enabled;false.
Must have toggled it at some point, for some reason, & forgotten about it.

Anyhow, things here are still slow :-).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

barbaz
Senior Member
Posts: 8831
Joined: Sat Aug 03, 2013 5:45 pm

Re: Board is SLOW

Post by barbaz » Tue Dec 18, 2018 10:55 pm

Now the slowness is intermittent, and sometimes I just get this error during the periods of slowness -
General Error

SQL ERROR [ mysqli ]

Too many connections [1040]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7247
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Board is SLOW

Post by therube » Wed Dec 19, 2018 1:54 pm

Now the fastness is even more intermittent ;-).

And as of yesterday, even more of these too:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Too many connections [1040]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
(I wanted to report this yesterday, but the board was too intermittent ;-).)
(Updated SQLite is out, perhaps with yet another .dot release due too, even if it may happen to be immaterial to this board's issue.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

User avatar
therube
Ambassador
Posts: 7247
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Board is SLOW

Post by therube » Wed Dec 19, 2018 1:54 pm

Now the fastness is even more intermittent ;-).

And as of yesterday, even more of these too:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Too many connections [1040]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
(I wanted to report this yesterday, but the board was too intermittent ;-).)
(Updated SQLite is out, perhaps with yet another .dot release due too, even if it may happen to be immaterial to this board's issue.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.5

User avatar
GµårÐïåñ
Lieutenant Colonel
Posts: 3325
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA
Contact:

Re: Board is SLOW

Post by GµårÐïåñ » Wed Dec 19, 2018 4:51 pm

I am getting the same thing. Unless the site is under attack, this should not be happening.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
________________ .: [ Major Mike's ] :. ________________
Mozilla/5.0 (Windows; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

User avatar
Giorgio Maone
Site Admin
Posts: 8654
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Board is SLOW

Post by Giorgio Maone » Wed Dec 19, 2018 11:06 pm

I've been investigating a bit. It might be a DDOS, but we also had more than 200K registered users, of which just 4K had posts.
I've deleted them and restarted the SQL Server. Let's watch how it goes...
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

barbaz
Senior Member
Posts: 8831
Joined: Sat Aug 03, 2013 5:45 pm

Re: Board is SLOW

Post by barbaz » Wed Dec 19, 2018 11:45 pm

Thanks Giorgio for looking into this, but...
Giorgio Maone wrote: we also had more than 200K registered users, of which just 4K had posts.
I've deleted them
... one of these users, "kol", had a lot of PM exchanges with me, more than enough for me to know they're a legitimate user. Deleting their account not only seems erroneous, it might be causing glitches for me. Now sometimes when accessing my PMs, the forum is logging me out. And I seem to be missing the PMs they sent me.

Would it be possible to restore kol's account, while keeping the other zero-post users deleted?

EDIT I think the old link to kol's account might be https://forums.informaction.com/memberl ... e&u=263513
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 8654
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Board is SLOW

Post by Giorgio Maone » Thu Dec 20, 2018 12:32 am

barbaz wrote: Would it be possible to restore kol's account, while keeping the other zero-post users deleted?
I've actually restored his and all the other 200K, because I've found the culprit and it was (is) a DDOS attack indeed.
Attackers are mostly 39.105.x.x and 46.229.168.x.
They've got plenty spare IPs and are creating hundreds of distinct guest sessions per minute from each IP, clogging the sessions table and putting the SQL server down to its knees.
I've deployed some dynamic countermeasures (not based on their IPs) which seem to be working for now :)
Let's cross our fingers...
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

barbaz
Senior Member
Posts: 8831
Joined: Sat Aug 03, 2013 5:45 pm

Re: Board is SLOW

Post by barbaz » Thu Dec 20, 2018 12:43 am

Board is back to normal speed atm, and restoring kol's account looks to have fixed the logout glitch for me. Thank you Giorgio for resolving this! 8-)
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply