[BUG][E10s] Cannot Flashgot link with E10s enabled

Bug reports and enhancement requests

[BUG][E10s] Cannot Flashgot link with E10s enabled

Postby sabret00the » Sun Apr 26, 2015 8:50 pm

Cannot Flashgot link nor Flashgot selection with E10s enabled.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:40.0) Gecko/20100101 Firefox/40.0
sabret00the
Senior Member
 
Posts: 76
Joined: Mon Apr 05, 2010 9:10 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby sabret00the » Tue May 05, 2015 10:44 am

Cannot Flashgot selection either.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:40.0) Gecko/20100101 Firefox/40.0
sabret00the
Senior Member
 
Posts: 76
Joined: Mon Apr 05, 2010 9:10 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Sun Jan 10, 2016 11:36 am

Flashgot selection doesn't work here either.

Flashgot link (ctrl+f1) works it was never broken as far as I experienced. I don't use the context menu so I can't comment on that.

Too bad this extension is not maintained anymore...
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby Giorgio Maone » Sun Jan 10, 2016 5:36 pm

avada wrote:Too bad this extension is not maintained anymore...

FlashGot is maintained. Actually, I'm currently working with Mozilla to ensure that it can be supported as a WebExtension as soon as possible.
In the meanwhile, if e10s gets enabled in the stable channel before WebExtensions are viable, show-stopping bugs like these will be fixed.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 8640
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Sun Mar 06, 2016 10:37 am

Update:
So I've been testing with extensions.interposition.enabled;false (which disabled compatibility shims), and flashgot is one of the addons that's totally broken this way.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby Thrawn » Mon Mar 07, 2016 1:09 am

Of course. I think Giorgio's comment above should make it clear that FlashGot does not currently work without the compatibility shims, as he has other urgent work, but if it becomes essential (due to e10s being enabled), then he'll take time to fix it.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
User avatar
Thrawn
Senior Member
 
Posts: 3106
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Wed Mar 30, 2016 12:40 pm

v 1.5.6.13
=====================================================
+ e10s-compatible API


Hmm... What does this mean? I still can't flashgot a selection when e10s is enabled.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Thu Nov 24, 2016 3:09 pm

It'd be nice if Flashgot got a bit of attention. For a long-long while now it's: Noscript 100% - Flashgot 0%
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby barbaz » Thu Nov 24, 2016 3:39 pm

avada wrote:For a long-long while now it's: Noscript 100% - Flashgot 0%

avada, how do you know this? It can't be based on activity on the forums, because Giorgio wasn't posting in NoScript sections either in the months before NoScript 2.9.5, a major change in NoScript, was made public. And given Giorgio's comment above, it can't be based on release dates either.

... but without making it clear how you know for a fact that NoScript has been getting all Giorgio's attention and Flashgot gets none, your comment doesn't look good for you.
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 8725
Joined: Sat Aug 03, 2013 5:45 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Fri Nov 25, 2016 5:35 pm

barbaz wrote:... but without making it clear how you know for a fact that NoScript has been getting all Giorgio's attention and Flashgot gets none

Well, noscript getting releases and FG don't speaks for itself.

Anyways, FG basically only has one feature broken, "flashgot selection". (But for at least a year and a half.) I suspect getting that working would have took a tiny fraction of an effort compared to a new noscript version. Yet the huge noscript release got precedence.

barbaz wrote:your comment doesn't look good for you.

If you mean it's filled with sadness, then true. :)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby barbaz » Fri Nov 25, 2016 6:12 pm

avada wrote:Well, noscript getting releases and FG don't speaks for itself

Yep, and what it's saying is, FlashGot-is-being-redone-as-a-WebExtension. Listen closely.

avada wrote:I suspect getting that working would have took a tiny fraction of an effort compared to a new noscript version. Yet the huge noscript release got precedence.

Keep in mind that it's less time-consuming to fix what you've already got than rewrite an entire software for another platform. So generally it's better to just fix the bug. But when A) you're going to be stuck with the rewrite anyway, B) most users don't see the bug, and C) no one is forced to be affected by the bug - guess where you'll put the effort.

avada wrote:
barbaz wrote:your comment doesn't look good for you.

If you mean it's filled with sadness, then true. :)

If it makes you feel happier, we can tell you that Giorgio is helping to design the WebExtensions API.

How does that look for the long-term future of all his extensions?
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 8725
Joined: Sat Aug 03, 2013 5:45 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Fri Nov 25, 2016 7:04 pm

barbaz wrote:Keep in mind that it's less time-consuming to fix what you've already got than rewrite an entire software for another platform. So generally it's better to just fix the bug. But when A) you're going to be stuck with the rewrite anyway, B) most users don't see the bug, and C) no one is forced to be affected by the bug - guess where you'll put the effort.

Well, I would have been entirely happy with a hacky, scotchtape fix.
barbaz wrote:Yep, and what it's saying is, FlashGot-is-being-redone-as-a-WebExtension. Listen closely.

That's cool. Hopefully some Firefox users still remain by the time it's done to use it. :)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Sun May 07, 2017 10:02 am

Well, flashgot is good as dead...
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby barbaz » Sun May 07, 2017 3:49 pm

avada wrote:Well, flashgot is good as dead...

Do you really think that approach will get this fixed faster? Calling FlashGot "good as dead" after Giorgio wrote "FlashGot is maintained", you see the problem there don't you? It just discourages Giorgio and makes you sound ungrateful for FlashGot. But I think that is not what you're aiming for, as your replies to me say, actually you really appreciate FlashGot and would be sad to see it die.

So how about working with what Giorgio wrote and using it in your favor? Watch and learn:
_____________________

Giorgio Maone wrote:In the meanwhile, if e10s gets enabled in the stable channel before WebExtensions are viable, show-stopping bugs like these will be fixed.

e10s is now enabled by default in the stable channel for some users - viewtopic.php?f=7&t=22793#p87943

... and FlashGot is not yet a WebExtension. Can this bug please be fixed?

Thanks!
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 8725
Joined: Sat Aug 03, 2013 5:45 pm

Re: [BUG][E10s] Cannot Flashgot link with E10s enabled

Postby avada » Sun May 07, 2017 4:07 pm

barbaz wrote:
avada wrote:Well, flashgot is good as dead...

Do you really think that approach will get this fixed faster? Calling FlashGot "good as dead" after Giorgio wrote "FlashGot is maintained", you see the problem there don't you? It just discourages Giorgio and makes you sound ungrateful for FlashGot. But I think that is not what you're aiming for, as your replies to me say, actually you really appreciate FlashGot and would be sad to see it die.

So how about working with what Giorgio wrote and using it in your favor? Watch and learn:
_____________________

Giorgio Maone wrote:In the meanwhile, if e10s gets enabled in the stable channel before WebExtensions are viable, show-stopping bugs like these will be fixed.

e10s is now enabled by default in the stable channel for some users - viewtopic.php?f=7&t=22793#p87943

... and FlashGot is not yet a WebExtension. Can this bug please be fixed?

Thanks!

At this point it doesn't matter. Those quotes are a year old, or older. Flashgot selection doesn't work for 2-3 years now. A bunch of times downloads fail to start when added by to DTA by flashgot.
Flashgot has 1/3 of the userbase of noscript, but is an order of a magnitude less complex. But it got about 0% dev time in the past years. Now that the XUL phaseout is near there's no chance for a fix to the addon as it is. Noscript will yet again will take precedence, when porting to webextension. So we might not see a functioning flashgot for a year or two, or never.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
avada
Junior Member
 
Posts: 29
Joined: Wed Oct 27, 2010 5:20 pm

Next

Return to FlashGot Development

Who is online

Users browsing this forum: No registered users and 2 guests

cron