Page 1 of 1

[RESOLVED] Links Filter dialog does not appear for wget

Posted: Mon Jan 28, 2013 11:34 am
by Zelphar
From viewtopic.php?f=6&t=12192

When I set FlashGot's Download Manager option to (Browser Built In), and I use FlashGot Selection or FlashGot All, I get the following links filter dialog: https://dl.dropbox.com/u/19234057/filterdialog.png

However, when I set it to wget, a wget instance is immediately launched for each link, and no links filter dialog appears.

I am running FlashGot 1.5.3 and my config for wget is:

Code: Select all

/C start wget -c --ca-certificate=C:\Utils\Wget\cacert.pem [--referer=REFERER] [--post-data=POST]  [--header=Cookie:COOKIE] [-O D:\Downloads\FNAME] [URL] 


If there's any more information you need, or if there's anything I should test, please let me know.

Re: Select URL(s)/Links Filter dialog does not appear for wg

Posted: Mon Jan 28, 2013 11:55 am
by Giorgio Maone
It's because you don't specify the destination folder path parameter, which is needed to trigger the choice dialog.
Please try with

Code: Select all

/C start wget -c [-O FNAME] [--directory-prefix=FOLDER] [--referer=REFERER] [--post-data=POST]
[--load-cookies=CFILE] [--header=Cookie:COOKIE] [--input-file=UFILE]

Re: Select URL(s)/Links Filter dialog does not appear for wg

Posted: Mon Jan 28, 2013 1:41 pm
by Zelphar
Ah, that does the trick, thanks!

I previously had issues with wget saving downloads to the wrong directory, so wound up explicitly specifying the path in the -O parameter.

Only problem now is that when a URL results in a 302 redirect, wget ignores the -O parameter and uses the last component of the new URL. This happens with both [ URL] and [--input-file=UFILE] so I suspect it's a wget issue. Then again, according to the wget documentation, the -O argument does not do what we think it does anyway, especially when used with --input-file. I'll have to play around some more, maybe upgrade my wget 1.10.1 setup to something newer.

Thanks again. :)

Re: Select URL(s)/Links Filter dialog does not appear for wg

Posted: Tue Jan 29, 2013 9:23 am
by Zelphar
Updating wget to 1.14 from https://code.google.com/p/osspack32/dow ... ist?q=wget seems to have done the trick to resolve the redirect filename issue.