Page 1 of 1

Script removed by snapshot save

PostPosted: Wed Jan 05, 2011 4:05 pm
by AlbertoDG
Hello everybody,

This is a trascription from another forum. It describes a problem that I had with NoScript.

I do like NoScript, but this behavior is really bad for me . Is it a bug? Is it possible to disable this feature (completely)?

TRANSCRIPTION:



Thanks Chris and Sarah.

It is NoScript.

I tried before just disabling it, but this action alone did not work. Now I understand why. Using safemode everything works fine.

Disabling didn't work. Uninstalling didn't work... I had to uninstall NoScript from ALL the different profiles I had in FF.
There must be something wrong in NoScript. Quite unfortunate, because I like it in general.

Do you know if it is possible to eliminate just this feature in NoScript? or any alternative to NoScript?

Thanks again,

Alberto



At 16:13 05/01/2011, Chris wrote:
Are you using noscript?

At 16:01 05/01/2011, Sarah wrote:
How are you going about saving pages in Firefox? Are you just doing File
> Save Page As...? Or are you using some kind of add-on? I just tried
the Save Page As method and didn't notice this issue. I have the same
version of Firefox. If you're not sure if there's an add-on interfering,
start Firefox in safe mode and save the page again to see if you still
have the same problem.
--
> Do you know about this new behavior of Firefox with javascript?
>
> When I save any page, the contents of all script tags or .js files
> called from the page are replaced by this text (as a comment):
>
> Script removed by snapshot save
>
> Does this happen to everybody? Any idea about the origin? (update?
> Plugins? Complements?) Is it possible to disable this feature? (In my
> firefox, of course!! I don't want to break any security of others, just
> save pages as I used to do it).
>
> I am using Firefox 3.6.13 (the latest, I think). I know this is not the
> best forum for a Firefox question, but I couldn't get information in any
> other place.

Re: Script removed by snapshot save

PostPosted: Wed Jan 05, 2011 4:48 pm
by Giorgio Maone
This is NOT from NoScript, neither a feature nor a bug.
AlbertoDG wrote:Disabling didn't work. Uninstalling didn't work...

This fact alone should have hinted you that the problem was elsewhere.

Please try to disable all your extensions except NoScript and see if it works.
Alternatively, please try on a clean profile with just NoScript installed.

If either works, you may want to perform Standard Diagnostic, in order to find the real offender.

Re: Script removed by snapshot save

PostPosted: Thu Feb 24, 2011 10:58 pm
by seanferd
For future reference:

This would be due to the Mozilla Archive Format extension. Visit the extension properties and change "Take a faithful snapshot" to "Preserve scripts and source". (Or, "Use browser save system".) This affects page saves even when you think you aren't using the MAF extension.

I noticed the same issue and did a quick search before checking extensions, just to narrow down what might be causing this. Indeed, your post is copypasta all over the internet, partly from you and partly from sites copying other sites' content. What really ruins the search, though, is all the pages online which have been saved by this method, therefore containing the noted text.

Of course Giorgio Maone is correct here. ;) In fact, this is the last place I would have looked for hints, but I couldn't resist visiting when I saw a result pointing to IA. :)