[Fixed] Existing site's CUSTOM permissions remain inappropriately visible during using "Search or add a website"

Bug reports and enhancement requests
Post Reply
barbaz
Senior Member
Posts: 9871
Joined: Sat Aug 03, 2013 5:45 pm

[Fixed] Existing site's CUSTOM permissions remain inappropriately visible during using "Search or add a website"

Post by barbaz » Fri Nov 27, 2020 3:45 am

Firefox 83.0
NoScript 11.1.6rc1
new profile

STR:

1) NoScript Options > Per-site Permissions, set any site to CUSTOM. Leave permissions visible.

2) While the checkboxes for that CUSTOM are still displayed, type in "Search or add a website:" a site that's not listed at all

Expected results: Nothing should show below "Search or add a website".

Actual results:

The CUSTOM permissions still show, but the associated site is hidden. Intuitively, this looks like the new site is gonna be added as CUSTOM with those permissions set. But it's actually totally unrelated.
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Giorgio Maone
Site Admin
Posts: 9065
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Existing site's CUSTOM permissions remain inappropriately visible during using "Search or add a website"

Post by Giorgio Maone » Wed Dec 02, 2020 10:21 pm

Please check latest development build, thanks:

v 11.1.6rc2
============================================================
x [UI] Fixed bug in CUSTOM sites filtering (thanks barbaz
for reporting)

x Fixed bug in automatic HTML events build-time updates
x Updated HTML events
x Updated TLDs
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0

barbaz
Senior Member
Posts: 9871
Joined: Sat Aug 03, 2013 5:45 pm

Re: Existing site's CUSTOM permissions remain inappropriately visible during using "Search or add a website"

Post by barbaz » Thu Dec 03, 2020 12:52 am

Looks good, thanks for fixing it!
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply