NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Bug reports and enhancement requests
Post Reply
User avatar
Lucas Malor
Senior Member
Posts: 71
Joined: Tue Nov 09, 2010 2:01 pm
Contact:

NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by Lucas Malor » Fri Sep 27, 2019 10:30 am

Steps:

1. go to https://www.mitsubishi-motors.it/trova-concessionaria
2. allow temporarily all the sites
3. click on a black pin with a letter on the map. An error page will appear
4. go back, disable NoScript for this tab and repeat. Now the page works

I use Noscript 11.0.3
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

barbaz
Senior Member
Posts: 9279
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by barbaz » Fri Sep 27, 2019 3:37 pm

I can confirm this in NoScript 11.0.4rc1. Nothing obviously related in Browser Console.
*Always* check the changelogs BEFORE updating that important software!
-

musonius
Senior Member
Posts: 109
Joined: Sun Jul 08, 2018 5:38 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by musonius » Fri Sep 27, 2019 4:49 pm

I allowed mitsubishi-motors.it and maps.googleapis.com and it seems to work, at least I don't see anything which seems wrong after clicking on a black pin with a letter on the map. I use NoScript 10.0.3.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

barbaz
Senior Member
Posts: 9279
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by barbaz » Fri Sep 27, 2019 7:17 pm

Oops, this doesn't happen to me in a new profile with only NoScript installed.

Back to my main profile, disabling all extensions except NoScript didn't help.
*Always* check the changelogs BEFORE updating that important software!
-

musonius
Senior Member
Posts: 109
Joined: Sun Jul 08, 2018 5:38 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by musonius » Fri Sep 27, 2019 7:22 pm

Yes indeed. My profile is less than a month old and I use only one extension: NoScript.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

barbaz
Senior Member
Posts: 9279
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by barbaz » Fri Sep 27, 2019 7:23 pm

Solved. You need to allow "fetch" permission for mipulse.co
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Lucas Malor
Senior Member
Posts: 71
Joined: Tue Nov 09, 2010 2:01 pm
Contact:

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by Lucas Malor » Fri Sep 27, 2019 9:43 pm

barbaz wrote:
Fri Sep 27, 2019 7:23 pm
Solved. You need to allow "fetch" permission for mipulse.co
...but mipulse.co does not appear in NoScript site list...
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

barbaz
Senior Member
Posts: 9279
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by barbaz » Sat Sep 28, 2019 1:01 am

Lucas Malor wrote:
Fri Sep 27, 2019 9:43 pm
...but mipulse.co does not appear in NoScript site list...
... so add it manually in NoScript Options > Per-site Permissions.
*Always* check the changelogs BEFORE updating that important software!
-

skriptimaahinen
Senior Member
Posts: 164
Joined: Wed Jan 10, 2018 7:37 am

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by skriptimaahinen » Sat Sep 28, 2019 6:06 pm

The reason why mipulse.co does not appear in the list is because the site does not try to access it until the "pin" is clicked, however, unless mipulse.co is already allowed, the site will quickly redirect to the error page, leaving user no time to check the updated list.

This situation can happen if user has modified the DEFAULT preset to disallow "fetch".

This could be averted if NoScript remembered all seen domains even after page refresh/navigation (for the session?). Or just allow logging seen messages to the console for quick debug?
Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0

barbaz
Senior Member
Posts: 9279
Joined: Sat Aug 03, 2013 5:45 pm

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by barbaz » Sat Sep 28, 2019 8:06 pm

skriptimaahinen wrote:
Sat Sep 28, 2019 6:06 pm
The reason why mipulse.co does not appear in the list is because the site does not try to access it until the "pin" is clicked, however, unless mipulse.co is already allowed, the site will quickly redirect to the error page, leaving user no time to check the updated list.
So this is another case like viewtopic.php?f=10&t=24043 , i.e. yet another reason to bring back "Recently blocked sites".
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
Lucas Malor
Senior Member
Posts: 71
Joined: Tue Nov 09, 2010 2:01 pm
Contact:

Re: NoScript block this site, you have to allow scripts globally, even if all sites are allowed

Post by Lucas Malor » Sat Sep 28, 2019 8:40 pm

barbaz wrote:
Sat Sep 28, 2019 8:06 pm
So this is another case like viewtopic.php?f=10&t=24043 , i.e. yet another reason to bring back "Recently blocked sites".
+1 dude.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Post Reply