Page 1 of 1

NoScript Icon Dropdown Hangs in Nightly

Posted: Wed Jun 26, 2019 4:25 pm
by therube
I'll just casually mention...

Something like the NoScript Icon Dropdown "Hangs" on Nightly (what is that FF 69, currently) of late (oh I'll say the last few days at least).

Kind of like if "elements" of the page are still loading & you click the NoScript icon, all you get is a little "blob" (sort of looks like part of a cloud) that displays (rather then any sites).
Once the page has finished doing what it is doing, at that point you can then click on the NoScript icon & it is then usable.

Thinking more apparent on a slow loading page, or maybe a page where "media" is slow to load.

Re: NoScript Icon Dropdown Hangs in Nightly

Posted: Wed Jun 26, 2019 6:37 pm
by Giorgio Maone
Trying to reproduce on build 20190626093633 (Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0) with no luck (on Yotube).
Any other site/config where you think this could be easier to notice?

Re: NoScript Icon Dropdown Hangs in Nightly

Posted: Thu Jun 27, 2019 12:24 am
by therube
URL: ... ero-781148

NoScript: 10.6.3rc8
(Or maybe 11.0rc1, now. /I/ installed 10.6.3rc8. Something cause 11.0rc1 to download - AFAIK, silently ? & I don't think I restarted FF?)
FF: 69.0a1 x64, 20190625215814, Win7

What I /think/ must have been a fairly clean Profile.
(It only opened up to a "You’ve just been upgraded to Firefox Nightly 69" & pages.
No extensions, initially.)

Installed NoScript.
Opened, seemed OK.
Opened a couple other sites.
Opened URL.
(Had no idea what it was, what was there, what to expect.)

Seemed OK.
Knew there had to be "more", & nothing stood out to allow, so I simply Allow All This Tab.
Seemed OK.
Revoked (all the allows were) Temporary Allows.
Allowed, again.
Page refreshed, seemed OK.
Not knowing what to allow next, selected, & Allowed.

At that point (& you've basically got to be hovering, then clicking the NoScript icon), I saw a "cloud" instead of the list of sites dropping down - until the page finished what it had to do, & then I could get the dropdown to work as expected.

What it appears is that other sites are populating the dropdown, or whatever type of crap on the page itself is loading, or trying to load, & until it's done, NoScript icon is ineffectual.

Thinking that once you Allow, alternate between Allow, then Disallow (Default) it, each time going back to the NoScript icon, clicking it. Might take a few repetitions, but thinking you'll see it.

I made a video of it (screen cap, rectangular area of the area in question), but oddly the dropdown was not captured - at all, likewise the "cloud".
Mouse click showed where I had clicked,, between allow/disallow..., but the entire dropdown simply was not picked up.

Video, FWIW, ... sp=sharing, 1.4 MB wmv.
I got the "cloud" around the 49 second mark.

Re: NoScript Icon Dropdown Hangs in Nightly

Posted: Sun Jun 30, 2019 10:00 am
by therube
My "cloud" looks similar to this (though more cloud-ish):


Re: NoScript Icon Dropdown Hangs in Nightly

Posted: Thu Jul 25, 2019 5:14 am
by therube

And to top it off, this time, when the options "dropdown" opened, it was in a non-modal dialog.

Re: NoScript Icon Dropdown Hangs in Nightly

Posted: Thu Aug 15, 2019 11:48 pm
by therube
Oh, BTW, this looks to be an integral feature (;-)) of Quantum.
I've now seen the same with other extensions.

I'll have to get around to filing a bug.