Adding an indication that the list of sites is loading

Bug reports and enhancement requests
Post Reply
User avatar
Swiftness
Posts: 6
Joined: Mon Jul 02, 2018 5:02 pm
Location: Scandinavia

Adding an indication that the list of sites is loading

Post by Swiftness » Mon Jul 02, 2018 6:13 pm

Sometimes when I click the NoScript button in my toolbar the list of sites takes a few seconds to load. I don't really mind this, but when this first happened I thought the add-on froze since the "bubble" is blank while loading.

Image

To address this, I suggest that a short animation is placed there to indicate that the list is loading; like a spinning circle or three blinking dots.
Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

barbaz
Senior Member
Posts: 9279
Joined: Sat Aug 03, 2013 5:45 pm

Re: Adding an indication that the list of sites is loading

Post by barbaz » Mon Jul 02, 2018 9:57 pm

*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7468
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Adding an indication that the list of sites is loading

Post by therube » Mon Jul 02, 2018 11:08 pm

(Yes, the same, IMO. I have seen what the OP shows, which then turns into what the other thread shows.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

Post Reply