(Classic) Strange XSS error

Bug reports and enhancement requests
Post Reply
barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

(Classic) Strange XSS error

Post by barbaz » Mon Jun 18, 2018 7:12 pm

Attempting to load https://mega.nz/#!U3wlDbZR!Wjo7SNnRPgF- ... KfEPbvtyYY spins briefly, then it just stops and nothing happens. This error appears in the Browser Console (Ctrl-Shift-J) -

Code: Select all

[NoScript XSS] xss.reason.[Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService2.newURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: chrome://noscript/content/IOUtil.js?1cga4v92v4ifo2n5uj9 :: newURI :: line 174"  data: no] --- newURI@chrome://noscript/content/IOUtil.js?1cga4v92v4ifo2n5uj9:174:14
onHttpStart@chrome://noscript/content/RequestWatchdog.js?1cga4v92v4ifo2n5uj9:148:34
observe@chrome://noscript/content/MainParent.js?1cga4v92v4ifo2n5uj9:97:24
Disabling the XSS filter does not help. I have to completely disable NoScript to get that link to load.
*Always* check the changelogs BEFORE updating that important software!
-

barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

Re: (Classic) Strange XSS error

Post by barbaz » Mon Jun 18, 2018 7:23 pm

It's a conflict with µMatrix. Disabling µMatrix gets it working too.

So is this a NoScript bug, a µMatrix bug, or both, or neither?
*Always* check the changelogs BEFORE updating that important software!
-

barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

Re: (Classic) Strange XSS error

Post by barbaz » Mon Jun 18, 2018 7:24 pm

Workaround: µMatrix dashboard > More, set

Code: Select all

enforceEscapedFragment false
*Always* check the changelogs BEFORE updating that important software!
-

User avatar
therube
Ambassador
Posts: 7469
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: (Classic) Strange XSS error

Post by therube » Mon Jun 18, 2018 7:27 pm

(Too quick for me.)

Image
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.3

barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

Re: (Classic) Strange XSS error

Post by barbaz » Mon Jun 18, 2018 7:29 pm

Since Waterfox isn't officially supported by either addon, testing again with Firefox 56.0.2, new profile.

STR:

1) install µMatrix from https://addons.mozilla.org/addon/umatrix/; install NoScript Classic latest development build 5.1.8.7rc1

2) visit link in OP

Same broken result. Same workaround gets it working.
*Always* check the changelogs BEFORE updating that important software!
-

barbaz
Senior Member
Posts: 9282
Joined: Sat Aug 03, 2013 5:45 pm

Re: (Classic) Strange XSS error

Post by barbaz » Mon Jun 18, 2018 7:37 pm

*Always* check the changelogs BEFORE updating that important software!
-

Post Reply