Cursor shows Busy when homepage is about:blank

Bug reports and enhancement requests
Post Reply
User avatar
therube
Ambassador
Posts: 7409
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Cursor shows Busy when homepage is about:blank

Post by therube » Mon Jun 04, 2018 1:51 pm

New Profile
Set 'When Firefox starts' to 'Show your home page'
Set 'Home Page' to about:blank

Quit FF

Start FF

Result: "Cursor" shows as "busy" (so long as cursor remains in the body of the FF window)


The first number of times this happened, I thought that FF had hung, which didn't seem to make sense to me. So I closed FF & reopened, only to see the same. And again...

Had no clue in what state my Profile was, but thought it to be fairly clean.

Yet it did it. Check processes & no CPU or I/O being used. Checked for hang (WhatIsHang), but nothing was hung.
And at that point, it was like, whatever.
Closed the browser & didn't use it.

So today, I open FF & it's still the same (though not like anything was done to "correct" things). On a lark I move the cursor to the 3-bar thing, "options" or whatever it is intended to mean, & I click it & it opens, & I'm like oh, so something is working.

And I restart once more, still the same. And then I type in a URL, & the page opens & all is working as expected. Everything works as expected.

The only thing that isn't working as expected, it the busy cursor.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

geek99
Junior Member
Posts: 20
Joined: Wed Dec 13, 2017 12:36 am

Re: Cursor shows Busy when homepage is about:blank

Post by geek99 » Mon Jun 04, 2018 10:19 pm

Not sure this problem is dependent on Noscript ... I discovered it many months ago.

My solution was to change my homepage (in FF options) to about:newtab

See if that works for you.

I reproduced the problem (with homepage set to about:blank), then disabled Noscript ... problem remained. Changed homepage to about:newtab, and enabled Noscript ... problem gone.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

User avatar
therube
Ambassador
Posts: 7409
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Cursor shows Busy when homepage is about:blank

Post by therube » Mon Jun 04, 2018 11:58 pm

Now disable all that nonsense that is "home page" & test again.

So...

disable all that crap
set home page to about:newtab
& test


(I was going to get to that, once I had some time.)


Actually, I can do that now...


Gear (wow, that's meaningful)
Uncheck; Search, Top Sites, Pocket, Highlights, Snippets -> Done

Set 'When Firefox starts' to 'Show a blank page'
Set 'Home page' to about:blank or to about:newtab
Restart FF

And...

Busy cursor.


Now, this may not "be" (perhaps ?) a "NoScript issue", but it is affected, exacerbated, by NoScript, so happens in these circumstances.

And actually, it may be related to or the same as the other about:blank issues I've mentioned?


about:newtab is a far cry from about:blank (IMO).
about:newtab is an abomination (IMO).
If someone wants an about:newtab-like page, then let it be an extension (as Mozilla is quite adept at telling us once they remove a feature we've all become reliant on - oh, go find an extension to do it - on, we don't support Legacy extensions any more, oh, sorry, webextensions don't support those functions any longer, oops, too bad).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

geek99
Junior Member
Posts: 20
Joined: Wed Dec 13, 2017 12:36 am

Re: Cursor shows Busy when homepage is about:blank

Post by geek99 » Tue Jun 05, 2018 7:04 pm

therube,

I agree with you ...


>about:newtab is a far cry from about:blank (IMO).
I AGREE

>about:newtab is an abomination (IMO).
I AGREE

You did this ...
>Set 'When Firefox starts' to 'Show a blank page'
>Set 'Home page' to about:blank or to about:newtab

That is not quite the exact work-around I use to fix the "busy cursor" problem. Try this ...
In the "When Firefox starts" section, select "Show your home page".
In the "Home Page" section, enter ... about:newtab

Then restart FF. Does your "busy cursor" problem go away? If so, then all you need to do is remove everything that is displayed in your about:newtab page ... so that your about:newtab page is essentially a blank page. Then, when FF starts (or when you open a new tab) you get a blank page (and the "busy cursor" is fixed).

The cause of the "busy cursor" is probably a bug in FF, but rather than waiting for Mozilla to fix the bug, I use the above work-around.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Post Reply