NoScript 10.1.1, FF 57.0 Noscript menue causes FF to glitch

Bug reports and enhancement requests
Post Reply
yoshi
Posts: 6
Joined: Fri Apr 03, 2015 9:44 pm

NoScript 10.1.1, FF 57.0 Noscript menue causes FF to glitch

Post by yoshi » Tue Nov 21, 2017 4:02 am

The NoScript menue (the one you get when clicking on the Options button in the dropdown) causes the FF UI to almost lock on Arch Linux when I scroll down the list of sites quickly enough. During scrolling there is first a noticable delay in the scrolling and then the NoScript icons in the menue are no longer rendered. (See screenshot https://i.imgur.com/YWqOqI1) At that point, the UI of FF starts to develop issues, commonly switiching tabs no longer works, at least once all tabs went blank or the FF menue no longer opened. (But in that case the x of the window decoration still worked to close the browser.)

Some additional information:

64 bit Arch Linux
GNOME Shell 3.26.2

Code: Select all

$uname -a
Linux angmar 4.13.12-1-ARCH #1 SMP PREEMPT Wed Nov 8 11:54:06 CET 2017 x86_64 GNU/Linux
Running FF from a shell, FF emitted a lot of error messages like

Code: Select all

[GFX1-]: Failed 2 buffer db=0 dw=0 for 0, 0, 24, 24
[Parent 2537, Main Thread] WARNING: file /build/firefox/src/mozilla-unified/ipc/chromium/src/base/shared_memory_posix.cc, line 216
so the issue may be with FF rather than NS, or a combination of the two.

Other than that, I am very happy to have NoScript back, great work.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

Lekensteyn
Junior Member
Posts: 31
Joined: Thu May 19, 2011 12:01 pm

Re: NoScript 10.1.1, FF 57.0 Noscript menue causes FF to gli

Post by Lekensteyn » Tue Nov 21, 2017 10:55 pm

Using 10.1.1rc99 here with Firefox 57.0 on Arch Linux as well, but with KDE. After installation, Firefox became sluggish and there were graphical artifacts to the point that whole Firefox windows got obscured with a single color.

I have noticed that the Error Console referred to error code 24 (Too many files). Surely enough, the default fd limit is 1024 and inspection of ls -l /proc/$(pgrep firefox)/fd | wc -l showed a very large number. Most of the files are named like /dev/shm/org.chromium..... Further analysis with strace -e file -p $(pgrep firefox) shows:

Code: Select all

...
openat(AT_FDCWD, "/dev/shm/org.chromium.oWIZd9", O_RDWR|O_CREAT|O_EXCL, 0600) = 1018
stat("/dev/shm/org.chromium.oWIZd9", {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
unlink("/dev/shm/org.chromium.oWIZd9")  = 0
openat(AT_FDCWD, "/dev/shm/org.chromium.3qVvyC", O_RDWR|O_CREAT|O_EXCL, 0600) = 1020
stat("/dev/shm/org.chromium.3qVvyC", {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
unlink("/dev/shm/org.chromium.3qVvyC")  = 0
openat(AT_FDCWD, "/dev/shm/org.chromium.men5S5", O_RDWR|O_CREAT|O_EXCL, 0600) = 1022
stat("/dev/shm/org.chromium.men5S5", {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
unlink("/dev/shm/org.chromium.men5S5")  = 0
openat(AT_FDCWD, "/dev/shm/org.chromium.j0tIdz", O_RDWR|O_CREAT|O_EXCL, 0600) = -1 EMFILE (Too many open files)
stat("/dev/shm/org.chromium.j0tIdz", 0x7ffd5effdd60) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/dev/shm/org.chromium.itBny2", O_RDWR|O_CREAT|O_EXCL, 0600) = -1 EMFILE (Too many open files)
stat("/dev/shm/org.chromium.itBny2", 0x7ffd5effdd60) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/dev/shm/org.chromium.5ji4Sv", O_RDWR|O_CREAT|O_EXCL, 0600) = -1 EMFILE (Too many open files)
stat("/dev/shm/org.chromium.5ji4Sv", 0x7ffd5effdd60) = -1 ENOENT (No such file or directory)
...
I have built up a pretty long list of sites over time, could that have an impact on this?

(Btw, is the Github repo already public? There is only one older one at https://github.com/hackademix)
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

DaveDub
Posts: 4
Joined: Thu Nov 23, 2017 8:47 am

Re: NoScript 10.1.1, FF 57.0 Noscript menue causes FF to gli

Post by DaveDub » Thu Nov 23, 2017 8:53 am

I also have this problem. Graphical glitches on the settings page, scrolling down causes slowdown, affects other tabs. Browser requires restart to be usable again.

Linux Mint 18 64-Bit
Cinnamon 3.0.7
Firefox 57.0 (64-bit)
NoScript 10.1.2
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

User42
Posts: 3
Joined: Tue Nov 21, 2017 8:50 am

Re: NoScript 10.1.1, FF 57.0 Noscript menue causes FF to gli

Post by User42 » Thu Nov 23, 2017 11:12 am

Same here on Ubuntu 16.04 TLS.
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

DaveDub
Posts: 4
Joined: Thu Nov 23, 2017 8:47 am

Re: NoScript 10.1.1, FF 57.0 Noscript menue causes FF to gli

Post by DaveDub » Tue Nov 28, 2017 3:53 pm

This seems to have gotten worse with the latest update (NoScript 10.1.3c2)
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

That Random Guy
Posts: 5
Joined: Thu Nov 30, 2017 8:51 pm

Same.

Post by That Random Guy » Thu Nov 30, 2017 8:55 pm

I've been getting a glitch as well.

I'm running NS 10.1.3 on Windows 10 Pro 64-bit with FF 57.0.1.

Every time I click on the extension link via the >> menu, it causes FF to minimize slightly and shift it to the right. Not sure why...
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

barbaz
Senior Member
Posts: 9350
Joined: Sat Aug 03, 2013 5:45 pm

Re: Same.

Post by barbaz » Thu Nov 30, 2017 8:58 pm

That Random Guy wrote:Every time I click on the extension link via the >> menu, it causes FF to minimize slightly and shift it to the right. Not sure why...
That issue is https://forums.informaction.com/viewtop ... =7&t=23942, please discuss it there.
*Always* check the changelogs BEFORE updating that important software!
-

Post Reply