Page 1 of 1

(Gecko 52 / UXP, e10s disabled) ABE Anonymize breaks devtools

Posted: Fri Feb 24, 2017 5:16 am
by barbaz
SeaMonkey 2.46
NoScript 5.0rc2
new profile

STR:
1) NoScript Options > Advanced > ABE > USER, add

Code: Select all

Site .hackademix.net
Anonymize
2) visit https://hackademix.net/
3) right-click the top blog entry's title > Inspect Element

Expected results: element and its CSS rules show up in the devtools inspector

Actual results: CSS rules pane is blank. Commenting out the ABE rule lets it work as expected. Changing the ABE rule to this also works -

Code: Select all

Site .hackademix.net
Accept INC(CSS) from .hackademix.net
Anonymize
Browser Console messages are what you'd expect from ABE, plus this -

Code: Select all

Exception {  }  resource://devtools/shared/protocol.js:907
Protocol error (unknownError): Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIChannel.contentCharset]  resource://devtools/client/inspector/shared/utils.js:157
Protocol error (unknownError): Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIChannel.contentCharset]  resource://devtools/client/inspector/rules/rules.js:883
(This thread might be related, but not the same issue - viewtopic.php?f=10&t=22372)

Re: ABE Anonymize breaks devtools

Posted: Fri Feb 24, 2017 5:58 am
by therube
What is the rule supposed to do?

If enabled, https://hackademix.net/ won't even load (at least in FF).

Re: ABE Anonymize breaks devtools

Posted: Fri Feb 24, 2017 6:01 am
by barbaz
From ABE Rules .pdf -
https://noscript.net/abe/abe_rules.pdf wrote:Anonymize (synonyms are Anon and Logout) – strips Authorization and Cookie headers, turns methods different than GET, HEAD and OPTIONS into GET, remove upload data, then sends the modified request.
I guess it shouldn't really affect hackademix.net at all. I'm just using that site as an example.

Re: ABE Anonymize breaks devtools

Posted: Thu Jan 03, 2019 2:08 am
by barbaz
I don't see this issue in Waterfox 56.2.6 + NoScript 5.1.9rc1.

Quick test with SeaMonkey 2.49.4 + NoScript 5.1.9rc1, and I can still reproduce the issue there. So I tried Firefox 52.9, and could not reproduce this issue there...until I tried disabling e10s.

UXP-based apps, e.g. Basilisk, are also affected.

So is this a NoScript issue, or a platform issue?

Re: (Gecko 52 / UXP, e10s disabled) ABE Anonymize breaks devtools

Posted: Thu Jan 03, 2019 3:39 am
by therube
Assuming I've done it correctly "my" 5.1.9rc1 looks to be working correctly.
SeaMonkey 2.49.5, 2.53, Basilisk 2018.12.18 (all x64, Windows 7 x64).

"My" (hacked version), viewtopic.php?f=10&t=23319.
(IMO, some extension [internal] settings, features really bugger up "legacy" browsers - simply by being there.)


Oh, I guess I could test with an unhacked...


Still working.
Did I do something wrong, with ABE?

User:

Code: Select all

# User-defined rules. Feel free to experiment here.

Site .hackademix.net
Anonymize

Re: (Gecko 52 / UXP, e10s disabled) ABE Anonymize breaks devtools

Posted: Thu Jan 03, 2019 3:48 am
by therube
OK, lets start again...
Actual results: CSS rules pane is blank.
The pertinent part. And for those who don't know what they're supposed to be looking for or what they're looking at...

"My" (hacked version)
Immaterial (to this issue).


So...

SeaMonkey 2.49.5 & Basilisk (FF 52 based, I believe), fail.

SeaMonkey 2.53 (FF 56 based), works.


(Was going to check FF 52, but I don't have my signing hack in there, so forgetaboutit! [said nicely]. But then Mozilla doesn't pay attention anyhow, so I should have said it not so nicely.)

Re: (Gecko 52 / UXP, e10s disabled) ABE Anonymize breaks devtools

Posted: Thu Jan 03, 2019 4:04 am
by barbaz
therube wrote:
Thu Jan 03, 2019 3:48 am
(Was going to check FF 52, but I don't have my signing hack in there, so forgetaboutit! [said nicely].
What signing hack? I don't use any "hack" to disable requiring addon signing, I just set xpinstall.signatures.required to false and it's done.

Re: (Gecko 52 / UXP, e10s disabled) ABE Anonymize breaks devtools

Posted: Thu Jan 03, 2019 5:25 am
by therube
Oops, I was confusing 52 & 56.

So...

FF 52.9 with NoScript 5.1.9 installed, is not showing Rules on my end?

Regardless of the value of, browser.tabs.remote.autostart (& restarting).
(Is that the correct Pref?)


(I started with a new Profile, initially with SM 2.49, then the same with 2.53, then the same with FF 52, so no longer "new", in that sense.)

Re: (Gecko 52 / UXP, e10s disabled) ABE Anonymize breaks devtools

Posted: Thu Jan 03, 2019 5:52 am
by therube
Some sites (well on one at least), I do get rules.

Code: Select all

# User-defined rules. Feel free to experiment here.

Site .hackademix.net
Anonymize

Site .yahoo.com
Anonymize

Site .pcqanda.com
Anonymize
www.yahoo.com gives me Rules.
www.pcqanda.com does not.