[FIXED] Bookmarklet not working

Bug reports and enhancement requests
Post Reply
Ria
Posts: 2
Joined: Fri May 30, 2014 8:00 pm

[FIXED] Bookmarklet not working

Post by Ria » Fri May 30, 2014 8:18 pm

Hi,

Since a few days (two or three days) my bookmarklet doesn't work anymore on a "forbidden" site with the latest Firefox nightly build.

My homepage (www.nu.nl) is a "forbidden" site because of an annoying cookiebar.
So after starting up the browser and reading my homepage I want to go to Gmail using this bookmarklet:
javascript:%20open('https://accounts.google.com/ServiceLogin?service=mail&continue=https://mail.google.com/mail/&hl=en');%20void%201

But it doesn't react.

When I click the bookmarklet on a whitelisted site, e.g. Google, there is no problem.
No big deal, but I thought I'd report it anyway. :)

Thanks for the attention,
Ria
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

User avatar
therube
Ambassador
Posts: 7521
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Bookmarklet not working

Post by therube » Fri May 30, 2014 10:30 pm

Confirmed.
But is it a NoScript issue or a Nightly issue?
I'm not sure if its working anywhere (i.e., even on an Allowed page)?
(At least in FF I wasn't sure. SeaMonkey is much easier to deal with.)

> a "forbidden" site

Appears all it needs to be is not allowed.

May or may not apply?
This was from FF, not seeing anything in SeaMonkey's Error Console.
(Though SeaMonkey Nightly is likewise affected.)

Code: Select all

"TypeError: Object.getPrototypeOf(...).open is undefined" JSURL.js:82
JSURL._run() JSURL.js:82
JSURL.load() JSURL.js:5
ns.executeJSURL() noscriptService.js:4424
noscriptBM.handleURLBarCommand/<() noscriptBM.js:36
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26

Ria
Posts: 2
Joined: Fri May 30, 2014 8:00 pm

Re: Bookmarklet not working

Post by Ria » Sat May 31, 2014 7:33 am

Last "working" build I have in my possession is this one: https://hg.mozilla.org/mozilla-central/rev/cbe4f69c2e9c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

barbaz
Senior Member
Posts: 9323
Joined: Sat Aug 03, 2013 5:45 pm

Re: Bookmarklet not working

Post by barbaz » Sat Jun 07, 2014 12:38 pm

Confirmed.

Code: Select all

--
[08:36:57.680] TypeError: Object.getPrototypeOf(...).open is undefined @ chrome://noscript/content/JSURL.js:82

This is the related error message given by SeaMonkey (it's not in the Error Console because it's getting logged via the content document's console.error instead of something like Cu.reportError - why this design choice? :?: ).
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29a1

User avatar
Giorgio Maone
Site Admin
Posts: 8771
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: Bookmarklet not working

Post by Giorgio Maone » Sun Jun 08, 2014 8:24 pm

Please check latest development build 2.6.8.29rc1, thanks.
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

barbaz
Senior Member
Posts: 9323
Joined: Sat Aug 03, 2013 5:45 pm

Re: Bookmarklet not working

Post by barbaz » Mon Jun 09, 2014 2:36 pm

Fixed 8-)
*Always* check the changelogs BEFORE updating that important software!
Mozilla/5.0 (X11; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29a1

Post Reply