icon not updated after marking non-allowed sites untrusted

Bug reports and enhancement requests
Post Reply
al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

icon not updated after marking non-allowed sites untrusted

Post by al_9x » Sat Oct 19, 2013 5:06 am

Fx 17.0.9ESR & 24.0.0, new profile, NS 2.6.8.3

  1. settings: forbid iframe, apply to trusted, show full domains
  2. go to http://www.livejournal.com/
  3. allow livejournal.com, refresh
  4. mark untrusted: google-analytics.com, counter.rambler.ru, nccgroup-webperf.com, ad.rambler.ru
  5. this moves all non allowed sites to untrusted, but the icon does not change
Last edited by al_9x on Thu Nov 28, 2013 12:49 pm, edited 1 time in total.
Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

User avatar
Giorgio Maone
Site Admin
Posts: 8830
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: ns icon not update after marking non allowed sites untru

Post by Giorgio Maone » Mon Oct 28, 2013 8:35 pm

Investigating, thanks.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: icon not updated after marking non-allowed sites untrust

Post by al_9x » Thu Nov 28, 2013 12:46 pm

  1. NS 2.6.8.7rc2, Fx 24.1.1, new profile
  2. embeddings: apply to trusted
  3. http://www.getmailbird.com/
  4. allow: getmailbird.com, zencdn.net, disqus.com
  5. add google-analytics.com, perfectaudience.com, punchtab.com, mxpnl.com to untrusted
  6. the icon continues to indicate blocked scripts even though there are no untrusted script domains in the menu
  7. reloading will usually show the proper icon, but not always
  8. you can repro again, by temp allowing one of the untrusted sites, forbidding it and making it untrusted, all without reloading
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

User avatar
Giorgio Maone
Site Admin
Posts: 8830
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy
Contact:

Re: icon not updated after marking non-allowed sites untrust

Post by Giorgio Maone » Wed Dec 11, 2013 1:18 pm

I cannot reproduce, I think: in both test cases I get the "allowed+partially untrusted+blocked embeds" icon (Image) as soon as I mark the last forbidden item as untrusted (don't even need to close the menu).
Maybe fixed accidentally along with something else? Or maybe I'm missing something...
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Hecuba's daughter
Senior Member
Posts: 93
Joined: Mon Oct 01, 2012 6:34 am

Re: icon not updated after marking non-allowed sites untrust

Post by Hecuba's daughter » Wed Dec 11, 2013 5:59 pm

For the second test case - getmailbird.com
All defaults, clean new profile, embeddings apply to trusted, 24.2.0ESR NS 2.6.8.8rc1

Can't reproduce, in the sense that if all sites are either in the whitelist or the Untrusted list, then the icon shows they are all blocked.
But...

Some strangeness seems to centre on the behaviour of vilondo.com scripts, related to the blocked vilondo web player perhaps?
I noted that without showing as a candidate for Allow or TA, vilondo.com is already listed in the list of candidates for Untrusted status. - - before any manipulation of the NS UI is undertaken at all.

In my sessions, no disqus.com presented in first menu list.

So could only TA getmb.com and zencdn.net at first refresh.
Disqus.com then appears and is TA at second refresh

At that point the Untrusted candidate list has 5 entries, not the 4 in the test list.
The extra site is
vilondo.com.

If all 5 are marked Untrusted, the icon changes to the expected one - that shown in Giorgio's post.

TA any of google-analytics.com, perfectaudience.com, punchtab.com, mxpnl.com from the Untrusted list, then forbidding them changes the icon to scripts partially allowed. Further TAs change the icon to none blocked again, as expected.
But, if vilondo.com is then TA from the Untrusted list, it doesn't appear in the menu as allowed.
In fact it totally disappears from the lists from then on.

What a mess some of those sites are.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: icon not updated after marking non-allowed sites untrust

Post by al_9x » Thu Dec 12, 2013 2:53 am

Giorgio Maone wrote:I cannot reproduce, I think: in both test cases I get the "allowed+partially untrusted+blocked embeds" icon (Image) as soon as I mark the last forbidden item as untrusted (don't even need to close the menu).
Maybe fixed accidentally along with something else? Or maybe I'm missing something...


The first problem is no longer reproducible with latest versions, the second one is, since you mentioned "the last forbidden item as untrusted", note that vilondo.com is not to be marked untrusted (it's in the untrusted menu but not in the main menu).
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

al_9x
Master Bug Buster
Posts: 931
Joined: Thu Mar 19, 2009 4:52 pm

Re: icon not updated after marking non-allowed sites untrust

Post by al_9x » Fri Dec 13, 2013 3:45 am

vilondo.com appears to be only a source of the video file http://cdn.vilondo.com/mailbird/MailbirdTrailer3.ogv, so it makes sense that it's not in the main menu when apply to trusted is checked, but it's still affecting the icon.
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

Post Reply