Disable/Enable Javascript without Page Refresh

Bug reports and enhancement requests
Post Reply
Saad
Senior Member
Posts: 55
Joined: Sun Jan 23, 2011 12:32 pm

Disable/Enable Javascript without Page Refresh

Post by Saad » Tue Jul 16, 2013 8:30 am

Hi,
Firefox 23 has removed Disable/Enable javascript in options. Please add a Disable/Enable javascript in Noscript without need page refresh. Thanks.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

User avatar
Thrawn
Senior Member
Posts: 3106
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia
Contact:

Re: Disable/Enable Javascript without Page Refresh

Post by Thrawn » Tue Jul 16, 2013 11:08 pm

You can already turn off automatic page reloads in NoScript using the Options - General tab.

Or you can go to about:config and toggle 'javascript.enabled' to false.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0

Saad
Senior Member
Posts: 55
Joined: Sun Jan 23, 2011 12:32 pm

Re: Disable/Enable Javascript without Page Refresh

Post by Saad » Fri Aug 09, 2013 12:49 pm

Oh my god... how i should say... for example for select the text when is locked, Noscript's disable javascript without page refresh doesn't work, but in previous versions of Firefox, disable javascript didn't not need to refresh page. .
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

Saad
Senior Member
Posts: 55
Joined: Sun Jan 23, 2011 12:32 pm

Re: Disable/Enable Javascript without Page Refresh

Post by Saad » Wed Oct 09, 2013 8:47 am

Finally i found! "QuickJava" do it well:
https://addons.mozilla.org/en-US/firefo ... quickjava/

not only Javascript... without refresh. please test. you should do this before.

And now i'm using Noscript just for block filtered pages alert.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

User avatar
Thrawn
Senior Member
Posts: 3106
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia
Contact:

Re: Disable/Enable Javascript without Page Refresh

Post by Thrawn » Wed Oct 09, 2013 10:06 am

Saad wrote:not only Javascript... without refresh. please test. you should do this before.

I'm not sure that that's actually possible. Are you certain that it is killing currently-running JavaScript?

And now i'm using Noscript just for block filtered pages alert.

It has a lot more uses than that.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0

Saad
Senior Member
Posts: 55
Joined: Sun Jan 23, 2011 12:32 pm

Re: Disable/Enable Javascript without Page Refresh

Post by Saad » Thu Oct 10, 2013 7:25 am

Yes, works. Please test. i suggested this feature to Noscript several times in past few years. but you didn't make this.

But attention, when you disable Javascript(or another) it will disable for all tabs... but is not problem for me.

Please make a option, so that, be possible to add icons in add-on bar to quickly disable/enable a engine, like QuickJava extension. you can make this option to make works for users more easily.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

User avatar
therube
Ambassador
Posts: 7561
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Disable/Enable Javascript without Page Refresh

Post by therube » Fri Oct 11, 2013 8:44 pm

> select the text when is locked

URL of a page that does that?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 SeaMonkey/2.23a2

User avatar
Thrawn
Senior Member
Posts: 3106
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia
Contact:

Re: Disable/Enable Javascript without Page Refresh

Post by Thrawn » Sat Oct 12, 2013 12:25 pm

therube wrote:> select the text when is locked

URL of a page that does that?

I'm not sure offhand, but searching Google for 'disable text selection' turns up plenty of instructions. OTOH, it looks like there are ways to do it with CSS and custom attributes, so disabling JavaScript might not help in all cases.

I'm still not convinced that it's possible for QuickJava or anything else to kill active JavaScript without reloading the page. Guardian/Giorgio, you would know more about this?
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0

User avatar
therube
Ambassador
Posts: 7561
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: Disable/Enable Javascript without Page Refresh

Post by therube » Sat Oct 12, 2013 1:59 pm

> looks like there are ways to do it with CSS and custom attributes, so disabling JavaScript might not help in all cases

Right.

> I'm still not convinced that it's possible for QuickJava or anything else to kill active JavaScript without reloading the page

I believe that may be the case.
You could do the same by interactively manually disabling JavaScript in FF. (I think you now need to go to about:config in FF to do that. In SeaMonkey you can still...)

Plugins used to work like that. You used to be able to go into Data Manager & disable Flash & all instances of Flash would interactively die. (I believe that has now changed.)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a2

Saad
Senior Member
Posts: 55
Joined: Sun Jan 23, 2011 12:32 pm

Re: Disable/Enable Javascript without Page Refresh

Post by Saad » Thu Oct 31, 2013 11:17 am

disabling javascript in some websites not work for select text, until page refresh.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Post Reply