localhost gets blocked but whitelisted

Bug reports and enhancement requests

localhost gets blocked but whitelisted

Postby BufferOverflow » Mon Feb 20, 2017 11:12 am

Hello.
I've started encounter a strange bug while debugging websites on localhost.
Image
As you see, site is marked as blocked by noscript icon, but when I open noscript submenu, it's being shown like there is nothing blocked on this page. The page didn't loads, which means that scripts actually blocked.
Now look at white list:
Image
As you see, localhost is declared here. To solve this problem, I can delete it and re-add to whitelist. After that, noscript stops blocking localhost... for some time. Nearly a 3-4 days and localhost is blocked again.
I've never encounter this bug in any site but localhost.
Mozilla/5.0 (Windows NT 6.1; rv:51.0) Gecko/20100101 Firefox/51.0
BufferOverflow
 
Posts: 1
Joined: Mon Feb 20, 2017 10:42 am

Re: localhost gets blocked but whitelisted

Postby barbaz » Mon Feb 20, 2017 5:29 pm

When this issue occurs, do you see anything related in the Browser Console? (Ctrl-Shift-J)
(if you don't know what's related, turn off CSS warnings and post everything else you see)
*Always* check the changelogs BEFORE updating that important software!
Board search is currently partially broken: https://forums.informaction.com/viewtopic.php?f=14&t=21752
Workaround: use your favorite search engine, add site:forums.informaction.com to your query
-
barbaz
Senior Member
 
Posts: 6951
Joined: Sat Aug 03, 2013 5:45 pm

Re: localhost gets blocked but whitelisted

Postby bart » Tue Feb 21, 2017 1:50 pm

I do encounter the same issue with NoScript version 2.9.5.3

My whitelist includes `localhost`, the console shows no messages related to javascript at all (only that some font downloads are blocked by NoScript). There's no other visual indication of blocked scripts, even though I enabled all notifications. Yet for anything at localhost (non-standard http port) the noscript tag is rendered and script tags are ignored.
Mozilla/5.0 Gecko Firefox
bart
 
Posts: 1
Joined: Tue Feb 21, 2017 1:43 pm

Re: localhost gets blocked but whitelisted

Postby imsodin » Sat Apr 15, 2017 9:21 pm

I have the same issue with 5.0.3-rc4 and I get the following output in the console:

Code: Select all
[ABE WAN] Detected WAN IP [...]
Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“toggleReaderMode”  browser.xul
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”  browser.xul
Content Security Policy: Couldn’t process unknown directive ‘worker-src’  (unknown)
Content Security Policy: Directive ‘frame-src’ has been deprecated. Please use directive ‘child-src’ instead.  (unknown)
SHIELD active


If I can do anything else to debug this, please give me instructions what to do.
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36
imsodin
 
Posts: 1
Joined: Sat Apr 15, 2017 9:17 pm


Return to NoScript Development

Who is online

Users browsing this forum: No registered users and 3 guests

cron