5.1.8.7rc4 is not signed

Bug reports and enhancement requests
User avatar
therube
Ambassador
Posts: 7409
Joined: Thu Mar 19, 2009 4:17 pm
Location: Maryland USA

Re: 5.1.8.7rc4 is not signed

Post by therube » Fri Oct 05, 2018 3:25 pm

Presumably you put two files into the FF installation directory.
Remove them (or rename) & restart FF.

> mozilla.cfg
> autoconfig.js

https://forums.informaction.com/viewtop ... 662#p98662
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball NoScript FlashGot AdblockPlus
Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 SeaMonkey/2.49.5

harryray2
Posts: 16
Joined: Wed Mar 08, 2017 4:53 pm

Re: 5.1.8.7rc4 is not signed

Post by harryray2 » Fri Oct 05, 2018 7:40 pm

Thanks, I did that but I got an error message stating 'failed to read the config file'

I don't know if it makes a difference but I'm running a portable version of FF
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

fatboy
Senior Member
Posts: 50
Joined: Fri Jul 25, 2014 6:56 am
Contact:

Re: 5.1.8.7rc4 is not signed

Post by fatboy » Sat Oct 06, 2018 12:03 pm

mozilla.cfg

Code: Select all

try {
// All lines of your code (without "//")
} catch (e) {
Components.utils.reportError(e);
}
"Then firefox will start and you can look at the console"
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 SM/2.38 NS/2.9.0.12

Wyatt
Posts: 1
Joined: Tue Jun 11, 2019 3:04 pm

Re: 5.1.8.7rc4 is not signed

Post by Wyatt » Tue Jun 11, 2019 3:31 pm

If, as I suspect is often going to be the case, you cannot modify the Firefox install directory because of company IT policy (likely the same policy that has you stuck on an old Firefox), I discovered (first hand) that as an alternative to the autoconfig.js approach, it also works to use the JS console.

1. set `devtools.chrome.enabled` to true in about:config
2. hit Ctrl + Shift + J to bring up the console
3. Paste this into the console and hit enter on Fx54 or earlier:

Code: Select all

try { Components.utils.import("resource://gre/modules/addons/XPIProvider.jsm", {}).eval("SIGNED_TYPES.clear()"); } catch(ex) {}
For Fx56 and (I hear) Fx55, you need this one instead:

Code: Select all

try { Components.utils.import("resource://gre/modules/addons/XPIInstall.jsm", {}).eval("SIGNED_TYPES.clear()"); } catch(ex)  {}
4. Install NoScript
5. Reset `devtools.chrome.enabled` and restart Firefox.

This might even be a better way to do it because it's an ephemeral change that won't persist past the restart.

EDIT: Source for the second bit of code is https://www.ghacks.net/2016/08/14/overr ... nt-4220684 I'll note also that there's another that claims to be better a few posts down, but I haven't figured out what it's exactly doing or tried it myself.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Post Reply