Search found 931 matches

by al_9x
Fri Jul 24, 2009 6:38 pm
Forum: NoScript Development
Topic: Fx2 post 1.9.5 iframe regression
Replies: 28
Views: 7921

Re: Fx2 post 1.9.5 iframe regression

Some weirdness was kind of expected because I noticed a change in how latest Gecko 1.8.x series builds handle request lifecycle and had to add an "Only from cache" restriction to the requests to be blocked in order to block them reliably. I'm investigating how to mitigate the side effects...
by al_9x
Thu Jul 23, 2009 8:54 pm
Forum: NoScript General
Topic: please update the feed links to https
Replies: 8
Views: 2233

Re: please update the feed links to https

GµårÐïåñ wrote:There is a dedicated feed for the betas, use that if you want separation.


The information about release type is already in the combined feed but hidden in the urls, it would be better if it was more clearly marked.
by al_9x
Wed Jul 22, 2009 8:15 pm
Forum: NoScript General
Topic: please update the feed links to https
Replies: 8
Views: 2233

please update the feed links to https

It also would be useful if the combined feed marked the entries as release or beta. The urls do show that, but something more visible would be nice.
by al_9x
Wed Jul 22, 2009 2:10 am
Forum: NoScript Development
Topic: Fx2 post 1.9.5 iframe regression
Replies: 28
Views: 7921

Re: Fx2 post 1.9.5 iframe regression

Yes, the error is identical, but the cure doesn't work for me.


I think you misunderstood, there is no cure.
by al_9x
Wed Jul 22, 2009 2:01 am
Forum: NoScript Development
Topic: Fx2 post 1.9.5 regression: POSTDATA that has expired
Replies: 5
Views: 1439

Fx2 post 1.9.5 regression: POSTDATA that has expired

confirmed on a new profile, Fx2 + NS 1.9.6.8 1) Forbid iframes, apply to trusted sites 2) go to http://youtube-global.blogspot.com/ 3) for expediency allow all this page twice or until everything is allowed 4) (re)load the page after everything is allowed 5) you should get an a Fx "Confirm"...
by al_9x
Wed Jul 22, 2009 1:26 am
Forum: NoScript Development
Topic: [RESOLVED] 1.9.6.2 and .6.5 causing "Offline" error message
Replies: 18
Views: 4561

Re: 1.9.6.2 and .6.5 causing "Offline" error message

Noticed this thread after I posted a bug. The two issues might be related.
by al_9x
Wed Jul 22, 2009 1:20 am
Forum: NoScript Development
Topic: Fx2 post 1.9.5 iframe regression
Replies: 28
Views: 7921

Fx2 post 1.9.5 iframe regression

1) forbid iframes, set no placeholders for untrusted 2) goto http://www.betanews.com/ which contains an ad iframe near the top 3) you will see Fx2 briefly load the "offline mode" error page in the iframe, which is then replaced by placeholder 4) this "offline mode" flashing wasn'...
by al_9x
Sun Jul 19, 2009 11:46 pm
Forum: NoScript Development
Topic: Flash placeholder missing when iframes forbidden
Replies: 17
Views: 4509

Re: Flash placeholder missing when iframes forbidden

then you also need to allow gmodules before the frame actually loads. & then you can click on a follower. the iframe loads because you a refreshing the page after allowing gmodules. That is not the scenario I am describing. If you click on the placeholder when everything is already allowed, the...
by al_9x
Sun Jul 19, 2009 11:25 pm
Forum: NoScript Development
Topic: Flash placeholder missing when iframes forbidden
Replies: 17
Views: 4509

Re: Flash placeholder missing when iframes forbidden

just some rambling ... needs blogspot.com & google.com. at that point, the frame placeholder loads. then you also need to allow gmodules before the frame actually loads. & then you can click on a follower. (It's time like that that the "i give up" button comes in handy.) Are you s...
by al_9x
Sun Jul 19, 2009 10:12 pm
Forum: NoScript Development
Topic: Flash placeholder missing when iframes forbidden
Replies: 17
Views: 4509

Re: Flash placeholder missing when iframes forbidden

What is a "Followers widget iframe"? 1) disable iframes for trusted 2) go to youtube-global.blogspot.com 3) scroll down 4) at the bottom of the right layout column there will be a iframe placeholder with a "Followers" heading 5) activate it, nothing loads it may be that in order...
by al_9x
Sun Jul 19, 2009 9:49 pm
Forum: NoScript Development
Topic: Flash placeholder missing when iframes forbidden
Replies: 17
Views: 4509

Re: Flash placeholder missing when iframes forbidden

Giorgio Maone wrote:Fixed in 1.9.6.2, thank you all.


Can anything be done about the Followers widget iframe? It doesn't load when activated. It is created by a script as are presumably other google widgets/gadgets/webelements so perhaps many of them won't work when activated.
by al_9x
Sun Jul 19, 2009 6:56 pm
Forum: NoScript Development
Topic: Flash placeholder missing when iframes forbidden
Replies: 17
Views: 4509

Re: Flash placeholder missing when iframes forbidden

No placeholder in one particular blogspot hosted blog with "forbid iframe" checked. Test case steps to reproduce in NS 1.9.6 This bug was introduced after 1.9.5, where the youtube flash placeholder does appear. Can you reproduce it in any other example? I can't find one. Official YouTube ...
by al_9x
Sun Jul 19, 2009 5:55 pm
Forum: NoScript Development
Topic: Flash placeholder missing when iframes forbidden
Replies: 17
Views: 4509

Re: Flash placeholder missing when iframes forbidden

Grumpy Old Lady wrote:No placeholder in one particular blogspot hosted blog with "forbid iframe" checked.

Test case steps to reproduce in NS 1.9.6


This bug was introduced after 1.9.5, where the youtube flash placeholder does appear.
by al_9x
Fri Jul 03, 2009 1:30 am
Forum: Web Tech
Topic: please help to reproduce Firefox 3+ bug 460880
Replies: 24
Views: 7333

Re: please help to reproduce Firefox 3+ bug 460880

unless you want me to create a VM that is 64 bit and that's going to take me MUCH longer to test since I have to build it first. no there is no point in 64. therube and I are both on 32 bit xp sp3 direct (no vm). As I mentioned, the only thing you can do to get closer to our environment is to try o...
by al_9x
Fri Jul 03, 2009 12:41 am
Forum: Web Tech
Topic: please help to reproduce Firefox 3+ bug 460880
Replies: 24
Views: 7333

Re: please help to reproduce Firefox 3+ bug 460880

therube wrote:I was on an AMD Sempron 3000


This one is single core?