Search found 188 matches

by skriptimaahinen
Tue Apr 10, 2018 5:52 pm
Forum: NoScript Support
Topic: Incomplete domain list in button menu
Replies: 8
Views: 2189

Re: Incomplete domain list in button menu

Hard to say. Have not had such problems. You might want to simply just reset all related page settings to default and redo them before trying to delete any files.
by skriptimaahinen
Tue Apr 10, 2018 5:31 pm
Forum: NoScript Support
Topic: Incomplete domain list in button menu
Replies: 8
Views: 2189

Re: Incomplete domain list in button menu

The minimum privileges I need to get the twimg.com shown are:

...webfail.com - script
...twitter.com - script and frame

If that doesn't work, you could try disabling uBO and see if that helps.
by skriptimaahinen
Tue Apr 10, 2018 4:57 pm
Forum: NoScript Support
Topic: Incomplete domain list in button menu
Replies: 8
Views: 2189

Re: Incomplete domain list in button menu

You need to first enable webfail.com and twitter.com, and then reload the page. After that the twimg.com will appear in the list. This is because twimg assests are loaded by the aforementioned scripts and cannot be seen by NS before they have run.
by skriptimaahinen
Tue Apr 10, 2018 4:40 pm
Forum: NoScript Support
Topic: [Firefox bug] infinite count badge loop on blocked media
Replies: 2
Views: 865

Re: [Firefox bug] infinite count badge loop on blocked media

It is possible. I can replicate the count badge loop on latest uBO with the steps above. However I cannot replicate the issue on yahoo.com with either uBO or NS alone.
by skriptimaahinen
Tue Apr 10, 2018 6:32 am
Forum: NoScript Development
Topic: NS10: TRUSTED<->TEMP TRUSTED no reload needed
Replies: 5
Views: 2478

Re: NS10: TRUSTED<->TEMP TRUSTED no reload needed

Or when just checking CUSTOM for the "seen" without actually changing permissions.

Would not mind having preference to disable automatic reload altogether though.
by skriptimaahinen
Tue Apr 10, 2018 6:30 am
Forum: NoScript Support
Topic: [Firefox bug] infinite count badge loop on blocked media
Replies: 2
Views: 865

[Firefox bug] infinite count badge loop on blocked media

FF 59.0.2 NS 10.1.8.1rc2 As stated in the title, this appears not to be NS but Firefox bug, so this post is just for the record as people seem to have encountered similar problems before. Steps to reproduce: - Page with media (e.g. https://commons.wikimedia.org/wiki/File:Sylvia_communis.mp3 ) - Only...
by skriptimaahinen
Sun Mar 18, 2018 1:58 pm
Forum: NoScript Development
Topic: RSS feed not working since this morning
Replies: 17
Views: 5729

Re: RSS feed not working since this morning

browser.contentScripts method seems to work fine, though apparently contentScripts.register doesn't understand urls with port numbers, so for the urls like http://localhost:8000 or http://127.0.0.1:8000, the contentscripts are not executed. This is however easily fixed with for example: let a = docu...
by skriptimaahinen
Fri Mar 16, 2018 12:28 pm
Forum: NoScript Development
Topic: RSS feed not working since this morning
Replies: 17
Views: 5729

Re: RSS feed not working since this morning

Looks like the rss feed fails if scripts are enabled and works when they are disabled.
by skriptimaahinen
Fri Mar 16, 2018 12:15 pm
Forum: NoScript Support
Topic: noscript refuses to trust localhost
Replies: 5
Views: 2039

Re: noscript refuses to trust localhost

Turns out the empty line is supposed to be the domain line for the localhost, but since tld.js doesn't recognize localhost as valid top level domain, the line is left empty. tld.js behaviour is bit odd though, as the next tests show: input -> returns "localhost" -> "" "localhost:8000" -> "" "http://...
by skriptimaahinen
Thu Mar 15, 2018 11:26 am
Forum: NoScript Support
Topic: noscript refuses to trust localhost
Replies: 5
Views: 2039

Re: noscript refuses to trust localhost

Enabling "List full addresses in the permissions popup (https://www.noscript.net)" in the Appearance options makes the localhost line visible again.

The purpose of the empty line is unclear to me though.
by skriptimaahinen
Wed Mar 14, 2018 7:25 am
Forum: NoScript Development
Topic: Noscript 10 web-font blocking
Replies: 11
Views: 3023

Re: Noscript 10 web-font blocking

Everything seems to be in order now. Thank you!
by skriptimaahinen
Tue Mar 13, 2018 2:13 pm
Forum: NoScript Development
Topic: Noscript 10 web-font blocking
Replies: 11
Views: 3023

Re: Noscript 10 web-font blocking

Aah, didn't even consider such blank permission as a possibility for the CSP. Very nice. However, there is still a minor issue with the "needed" marker not updating for the font. Unfortunately the https://yle.fi/uutiset was not the best site to test this as there were "normally" fetched fonts alongs...
by skriptimaahinen
Sat Mar 10, 2018 9:27 am
Forum: NoScript Development
Topic: [FIXED] NS10 WebGL permission bug
Replies: 5
Views: 1968

Re: [FIXED] NS10 WebGL permission bug

Ah, nice that this got fixed. However, looking at the code, I need to ask if you are familiar with the frame/iframe "workarounds"?
by skriptimaahinen
Sat Mar 10, 2018 9:25 am
Forum: NoScript Development
Topic: Noscript 10 web-font blocking
Replies: 11
Views: 3023

Re: Noscript 10 web-font blocking

Sorry, should have pointed the difference out. Also worth noting explicitly is that with the patch, if one wishes to allow/use fonts (awesome, gstatic, etc.) on some page, they are also forced to set that domain as allowed SOURCE of fonts. I wonder how big of a problem that is? Related, how big of a...
by skriptimaahinen
Fri Mar 09, 2018 8:53 am
Forum: NoScript Development
Topic: Noscript 10 web-font blocking
Replies: 11
Views: 3023

Re: Noscript 10 web-font blocking

Ah, sorry, have not been paying attention to this report for a while. Unfortunately no amount of clearing cache, history, etc., makes the icons disappear. Attached image to show difference between unblocked and blocked. https://i.imgur.com/853Rtq2.png As far as I can tell, Noscript currently blocks ...