Search found 213 matches

by skriptimaahinen
Sun Jul 01, 2018 7:22 pm
Forum: NoScript Development
Topic: [Fixed] NoScript Interferes w/ Home Button when about:blank
Replies: 9
Views: 2867

Re: [Fixed] NoScript Interferes w/ Home Button when about:bl

It happens again? The workaround should be still OK, as we don't really "select" the blank page in any way, we just stopped doing what was causing the bug. But if it's happening again, that means there is a new trigger for the bug. Cannot test myself as the newest FF has not yet landed on the Ubuntu...
by skriptimaahinen
Sun Jul 01, 2018 7:11 pm
Forum: NoScript Support
Topic: (S) v10: issues with main window and new top menu buttons.
Replies: 13
Views: 3308

Re: (S) v10: issues with main window and new top menu button

I thought I explained them already. Click the "Disable restrictions globally" and "Disable restrictions for this tab" icons and you should find out yourself what the "new" icons are for.
by skriptimaahinen
Thu Jun 28, 2018 9:13 am
Forum: NoScript Development
Topic: [Fixed] Guardian page causes 100% CPU Usage, UI Lockup
Replies: 8
Views: 3286

Re: Guardian page causes 100% CPU Usage, UI Lockup

Update: Turns out the problem is in the XSS filter. So if you absolutely need to be tracked by Facebook, you could disable XSS in the Options and then allow facebook.net. ;) @Giorgio: If you have not yet checked on this: The problematic call is to https://www.facebook.com/tr/ , which returns with so...
by skriptimaahinen
Mon Jun 25, 2018 7:38 am
Forum: NoScript Development
Topic: [Invalid] Disappearing menu with sites to enable/disable.
Replies: 3
Views: 1100

Re: Disappearing menu with sites to enable/disable.

Both your Firefox and NoScript are bit old. Could you update them and see if the problem persists?
by skriptimaahinen
Mon Jun 25, 2018 7:37 am
Forum: NoScript Development
Topic: [Fixed] Guardian page causes 100% CPU Usage, UI Lockup
Replies: 8
Views: 3286

Re: Guardian page causes 100% CPU Usage, UI Lockup

Can confirm the spike in cpu and ram usage (can cause whole OS to hang for a while) and crashing of Firefox. The culprit appears to be script from connect.facebook.net, so avoid allowing that domain until fix is found. For the facebook.net to appear in the popup, you need to enable: theguardian.com ...
by skriptimaahinen
Sun Jun 24, 2018 6:43 pm
Forum: NoScript General
Topic: NoScript on Mozilla Firefox Forum?
Replies: 4
Views: 88252

Re: NoScript on Mozilla Firefox Forum?

If you do trust support.mozilla.com and wish to enable the scripts there, then everything is OK already. Like I said - NoScript cannot function on that site, meaning that it cannot block scripts there. So the scripts are running fine already.
by skriptimaahinen
Sun Jun 24, 2018 6:17 pm
Forum: NoScript General
Topic: NoScript on Mozilla Firefox Forum?
Replies: 4
Views: 88252

Re: NoScript on Mozilla Firefox Forum?

support.mozilla.com is one of the restricted (extensions.webextensions.restrictedDomains) domains where NoScript cannot function due to design decision by Mozilla.

Unfortunately the message in the popup that should explain this is wrong. It is a known NoScript bug and hopefully will be fixed soon.
by skriptimaahinen
Thu Jun 21, 2018 6:50 pm
Forum: NoScript Support
Topic: NoScript v10: websites in the default whitelist from NS v5?
Replies: 5
Views: 1662

Re: NoScript v10: websites in the default whitelist from NS

Oh no. I don't actually have any of them added. I just copied the list straight from the (NS10) sourcecode. So that is the default whitelist you should get on fresh install of NS10. But like you, I also deleted all the whitelisted sites way back when I was using NS5. Even though block_mozAddonManage...
by skriptimaahinen
Wed Jun 20, 2018 7:17 pm
Forum: NoScript Support
Topic: NoScript v10: websites in the default whitelist from NS v5?
Replies: 5
Views: 1662

Re: NoScript v10: websites in the default whitelist from NS

Default TRUSTED sites (all permissions enabled): addons.mozilla.org afx.ms ajax.aspnetcdn.com ajax.googleapis.com bootstrapcdn.com code.jquery.com firstdata.com firstdata.lv gfx.ms google.com googlevideo.com gstatic.com hotmail.com live.com live.net maps.googleapis.com mozilla.net netflix.com nflxex...
by skriptimaahinen
Tue Jun 19, 2018 6:02 am
Forum: NoScript Support
Topic: temptrusted\disable restriction for tab = still blocked stuf
Replies: 13
Views: 2709

Re: temptrusted\disable restriction for tab = still blocked

That is odd, as I would imagine that the "script is undefined" error will surely lead to the condition... You don't need to enable script for default. The required domains are: twitch.tv twitchcdn.net twitchsvc.net (why does this trigger antispamfilter?) Though I did try it your way and still got th...
by skriptimaahinen
Tue Jun 19, 2018 4:14 am
Forum: NoScript Support
Topic: temptrusted\disable restriction for tab = still blocked stuf
Replies: 13
Views: 2709

Re: temptrusted\disable restriction for tab = still blocked

The bug is caused by some async functions getting executed in unexpected order, so there's no telling when it happens. To trigger the problem, you need to initially have webgl blocked for the twitch.tv. Refresh the page few times in attempt to trigger it. If you get "script undefined" error in conso...
by skriptimaahinen
Tue Jun 19, 2018 12:52 am
Forum: NoScript Support
Topic: temptrusted\disable restriction for tab = still blocked stuf
Replies: 13
Views: 2709

Re: temptrusted\disable restriction for tab = still blocked

Can confirm the problem. Sending fix suggestion to Giorgio. Not easy fix though.
by skriptimaahinen
Thu Jun 14, 2018 9:22 pm
Forum: NoScript Support
Topic: Sales force loading scripts causes FIrefox to go offline
Replies: 1
Views: 939

Re: Sales force loading scripts causes FIrefox to go offline

Using Firefox 60 I do not notice anything out of place allowing scripts on those pages. Or is this FF52 only thing? Can you elaborate a bit on the steps necessary to reproduce the problem?
by skriptimaahinen
Sat Jun 09, 2018 5:36 am
Forum: NoScript Support
Topic: Bloomberg video not playing
Replies: 6
Views: 2418

Re: Bloomberg video not playing

I got the video working after enabling these sites and permissions. bloomberg.com script, fetch akamaihd.net fetch bwbx.io script gotraffic.net script imasdk.googleapis.com script, frame lldns.net fetch That's for FF60/NS10, but since you appear to use FF52, maybe there's something in this ( https:/...