Per Site Permissions not Persisting

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Per Site Permissions not Persisting

Per Site Permissions not Persisting

by RakkuRii » Sat Jun 08, 2019 5:37 pm

I have had an issue recently where NoScript keeps reapplying the default white list after I have cleared it (by deleting the entries in the Debug box found in advanced settings). The settings will persist for sometime, including after a browser reset. Within a few days though I inevitably find the default white list has resurrected itself. I have to do some more testing to be sure, but I am thinking perhaps it is triggered by a system reset.

I am running Firefox Portable (Portableapps.com build) version 67.0.1 (64-bit), and NoScript 10.6.2. I am not sure the exact version numbers when the the issue first began, but to the best of my recollection it was right after the Firefox update that fixed the extension signing issue from a month or so ago that was disabling NoScript and many other add-ons.

Also here is what the settings look like in the debug box after I clear the defaults and added the temp settings in order to post here (so you can see if I am making some stupid mistake in my manual editing):

{
"DEFAULT": {
"capabilities": [
"frame",
"fetch",
"other"
],
"temp": false
},
"TRUSTED": {
"capabilities": [
"script",
"object",
"media",
"frame",
"font",
"webgl",
"fetch",
"other"
],
"temp": false
},
"UNTRUSTED": {
"capabilities": [],
"temp": false
},
"sites": {
"trusted": [],
"untrusted": [],
"custom": {},
"temp": [
"§:superuser.com",
"§:sstatic.net",
"§:informaction.com",
"§:google.com",
"§:gstatic.com"
]
},
"enforced": true,
"autoAllowTop": false
}

Top