NoScript 10 and publishwith.me

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: NoScript 10 and publishwith.me

Re: NoScript 10 and publishwith.me

by Peter 123 » Mon Dec 04, 2017 3:16 am

No. :( By allowing google.analytics first happened the same as when clicking on the blue bar on top: The contents/text of the pad disappeared. (After refreshing the page the contents were here again.)

Later (e.g. when creating a new pad) the situation is the same as described above: click on the blue bar ---> contents disappear ---> refreshing of the page ---> (only now) the redirection to the starting page works.

PS:
Peter 123 wrote: With NoScript 10 something strange happens after clicking on the blue bar:
- The opened page (the pad) remains, but its contents (the text) disappears from the editor.
- Only after refreshing the page (the one with the pad) (either via NoScript either via Firefox) the starting page will appear as desired.
I just tested it with the first version of NoScript 10 (10.1.1): The problem already exists there. (After deactivating NoScript, all works again as it should.)

Re: NoScript 10 and publishwith.me

by barbaz » Mon Dec 04, 2017 3:06 am

So does allowing google-analytics.com get it working?

Re: NoScript 10 and publishwith.me

by Peter 123 » Mon Dec 04, 2017 2:59 am

I have allowed publishwith.me and explicitely blocked no site (google.analytics is on default):

Image

Re: NoScript 10 and publishwith.me

by Thrawn » Sun Dec 03, 2017 10:40 pm

Which sites have you allowed vs blocked?

NoScript 10 and publishwith.me

by Peter 123 » Sun Dec 03, 2017 1:34 pm

"publishwith.me" is a site where you can create online a document (called "pad") in order to collaborate on this document together with others:
https://publishwith.me/

That's the starting page:

Image



When clicking on "Create new pad" a page like this will appear (in case that you allow the script for publishwith.me):

Image

Usually, when clicking on the blue bar on top of the pad (the bar with the words "PublishWith.me") you should be transferred back to the starting page. This worked without problems with NoScript 5.

With NoScript 10 something strange happens after clicking on the blue bar:
- The opened page (the pad) remains, but its contents (the text) disappears from the editor.
- Only after refreshing the page (the one with the pad) (either via NoScript either via Firefox) the starting page will appear as desired.

It must have to do with NoScript because when deactivating it, all works fine.

Edited:
Images in smaller size.

Top