[FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by anshoe » Mon Jan 29, 2018 1:49 pm

Noscript is the most useful addon ever for Firefox. If you are tampering with it, I don't need your updates. I'll go back to an older version of Firefox, like 50 or something. I need my security of browsing back with noscript, nothing else has worked as good.

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Rawreth Bridleway » Sat Dec 02, 2017 1:00 pm

I finally noticed that the Noscript symbol on the upper right top of the screen. You can click on that and allow/temporarily allow scripts. Seems to work, although not sure I understand it fully.

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by barbaz » Fri Nov 24, 2017 3:08 pm

Guest wrote:Georgio,

please just give us back the old NoScript for v56

Phil
You're already using Firefox 56, so just go get NoScript Classic from https://noscript.net/getit.

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Guest » Fri Nov 24, 2017 9:58 am

Georgio,

please just give us back the old NoScript for v56

Phil

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by muscovado » Sun Nov 19, 2017 8:59 am

As my pref.js is readonly (on purpose) and user_pref("noscript.version", "5.x.y"); was clearly out-of-sync with the latest installed noscript, changing to user_pref("noscript.version", "5.1.7rc1"); brought back the noscript button.

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Popolon » Sat Nov 18, 2017 5:01 pm

I use littlefox theme, and this problem already come in my case one or two year ago. The solution is the same that at this time to resolve the bug:
* Disable the theme
* disable and enable noscript (forgot If I had to remove/reinstall it).
* Enable the theme again.

Everything should work fine after that.

Hope it will help.

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Guest » Thu Nov 16, 2017 10:39 am

I found the problem in my system.
I use Firefox Portable, up to the version 56.0.2 (I have several folders and versions, but NOT 57).
I don't know why - I still have to find the cause, maybe antivirus - it is not capable anymore to write correctly settings to his file prefs.js,
path: c:\PortableApps\FirefoxPortable\Data\profile.
So when I make some updates, for example Firefox from 56.0.1 to 56.0.2, prefs.js reports

user_pref("noscript.firstRunRedirection.pending", "5.1.2");
user_pref("noscript.version", "5.1.2");

while i already have 5.1.5. The above lines don't change anymore.
This forces Firefox to open the update page of NoScript every time I launch it, and makes the Noscript icon disappear.
I edited manually the file, modifying the lines in

user_pref("noscript.firstRunRedirection.pending", "5.1.5");
user_pref("noscript.version", "5.1.5");

the icon is back and the update page doesn't open anymore. :D

Bye, David

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Johnhullaballo » Mon Nov 13, 2017 2:52 am

boteman wrote:
Johnhullaballo wrote:So a hard boot seemed to fix this. But we'll see as the day goes on. Happily right now, i have noscript and the other stuff working.

Thanks again,
John
Or it could be that after your reboot when Firefox was restarted NoScript auto-updated to 5.15 and now it has been fixed or at least mitigated?

Well, i already had 5.15 and I think that's what broke it. I get a separate tab when noscript updates that tells me. So I'm pretty sure it was the safe mode thing mentioned in the first post, combined with a hard boot, instead of just restarting firefox.

I had mentioned 5.15 up there somewhere. But my posts probably don't make that much sense. This is not my field of expertise by any stretch.

Thanks
John

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by boteman » Sun Nov 12, 2017 9:49 pm

Johnhullaballo wrote:So a hard boot seemed to fix this. But we'll see as the day goes on. Happily right now, i have noscript and the other stuff working.

Thanks again,
John
Or it could be that after your reboot when Firefox was restarted NoScript auto-updated to 5.15 and now it has been fixed or at least mitigated?

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Johnhullaballo » Sun Nov 12, 2017 3:10 pm

Johnhullaballo wrote:
barbaz wrote:
Johnhullaballo wrote:This was on 5.15 update, sorry about that. It's also messing up other extensions. The common thread is that turning off noscript fixes things. Even the Lastpass Vault stops working after a while.

Thanks again,
John
John, does the workaround in the first post of this thread prevent the problem from recurring?

Hello, I just tried it and no it doesn't. It's very strange behavior. It's preventing some extensions from showing their "properties" screens, on lastpass it prevents the login screen on others it brings up blank screens. But turning off noscript always seems to fix things. Then I turn it back on as I don't really like to run without it. But to get anywhere with most of the extensions, I have to turn it back off again.

I can see the "pointer" to the extension, a very small arrow type of thing, but can't get to the properties, or login to do anything.

I'm not big on blaming things, but I did have an update just before all this happened. First lastpass disappeared and the fun started.

But thank you for answering.

John

Hello again,

Today it seems to be behaving better? The instructions I followed just talked about restarting firefox, but after turning off the computer for the night, now I can get to those extension icons. I guess a better word for properties screen would be info. But it was extensions like traffic light, abp. They would just bring up a blank page or nothing at all.

So a hard boot seemed to fix this. But we'll see as the day goes on. Happily right now, i have noscript and the other stuff working.

Thanks again,
John

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Johnhullaballo » Sun Nov 12, 2017 5:25 am

barbaz wrote:
Johnhullaballo wrote:This was on 5.15 update, sorry about that. It's also messing up other extensions. The common thread is that turning off noscript fixes things. Even the Lastpass Vault stops working after a while.

Thanks again,
John
John, does the workaround in the first post of this thread prevent the problem from recurring?

Hello, I just tried it and no it doesn't. It's very strange behavior. It's preventing some extensions from showing their "properties" screens, on lastpass it prevents the login screen on others it brings up blank screens. But turning off noscript always seems to fix things. Then I turn it back on as I don't really like to run without it. But to get anywhere with most of the extensions, I have to turn it back off again.

I can see the "pointer" to the extension, a very small arrow type of thing, but can't get to the properties, or login to do anything.

I'm not big on blaming things, but I did have an update just before all this happened. First lastpass disappeared and the fun started.

But thank you for answering.

John

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by barbaz » Sat Nov 11, 2017 4:08 pm

Johnhullaballo wrote:This was on 5.15 update, sorry about that. It's also messing up other extensions. The common thread is that turning off noscript fixes things. Even the Lastpass Vault stops working after a while.

Thanks again,
John
John, does the workaround in the first post of this thread prevent the problem from recurring?

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Johnhullaballo » Sat Nov 11, 2017 4:05 pm

Johnhullaballo wrote:Your last update seemingly killed the lastpass icon. It inhibits the login box. Disabling noscript allows it. But I don't want to disable noscript. So I have to turn it off and on. Not a good thing really.

Posted here because it may be related to this. The Lastpass icon also disappeared and I had to reinstall it. Nothing but trouble right now.

Thanks,
John
This was on 5.15 update, sorry about that. It's also messing up other extensions. The common thread is that turning off noscript fixes things. Even the Lastpass Vault stops working after a while.

Thanks again,
John

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by Johnhullaballo » Sat Nov 11, 2017 4:56 am

Your last update seemingly killed the lastpass icon. It inhibits the login box. Disabling noscript allows it. But I don't want to disable noscript. So I have to turn it off and on. Not a good thing really.

Posted here because it may be related to this. The Lastpass icon also disappeared and I had to reinstall it. Nothing but trouble right now.

Thanks,
John

Re: [FIX] Fx 56 - NoScript icon disappeared on 5.1.2 update

by ready-4-HELL » Fri Nov 10, 2017 7:11 am

Yeah guys... Have been seeing that problm since weeks.
Not sure abt vrsn 5.1.2 or something close around it ..

Anyways it doesn't bother me much. I just hit on
Bookmark > noscript.net/getit > INSTALL .

No safe-mode, no touching other addons, No uninstalls .

Top