[FIXED] file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: [FIXED] file:\\\ links fail with NoScript 5.0.2 & FF 53.0

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by ADPD » Sun May 14, 2017 7:14 am

Hi.
Thank you sooo much for fixing it...now all is normal again, I can open local files again...thank you, thank you, thank you!!!
Keep the excellent work! :D

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by ADPD » Thu May 11, 2017 1:24 am

barbaz wrote:ADPD, did you try NoScript latest development build where this should already be fixed?
Hi.
Sorry for answering late. Yes I did and I still having issues.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by barbaz » Thu May 04, 2017 7:23 pm

ADPD, did you try NoScript latest development build where this should already be fixed?

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by ADPD » Thu May 04, 2017 6:59 pm

Hi.
I have the same issue, I tried disabling addon by add-on until I found that was NoScript that is having this bug, when I disabled it, my local files works again, also I had checked the advanced option "Allow local links" and still having problems...looks like they will have to check this...for now, I'll have to look for another alternative for this add-on.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by barbaz » Mon May 01, 2017 6:52 pm

Threads merged.

Re: cannot open HTML file on my hard drive

by therube » Mon May 01, 2017 6:48 pm

cannot open HTML file on my hard drive

by slickrcbd » Mon May 01, 2017 6:05 pm

I have checked the option
advanced->trusted->allow local links.
Yet I cannot open a saved story in HTML format on my hard drive in the browser, instead about:blank opens, nor can I browse the directory structure of the E partition with FILE:///e:/ff/ or just the root directory (dropping the ff)
The NoScript icon simply gives me the option to "allow about:blank", which is already chosen.

Disabling NoScript and restarting the browser fixes the problem, as does restarting the browser in safe mode.

This is a recent development, but I don't know if it was a browser update or a NoScript update that introduced it since I haven't opened a file on this computer in at least a month.
How do I fix it?

I have Firefox 53 (64-bit) with Windows 7 64-bit professional and NoScript 5.0.3.

I'm trying to open it by double-clicking on the file in Agent Ransack, but I also tried using the "open file" method and typing file:/// into the location bar or whatever they call it these days ("awesome bar"?). I learned the terminology with Netscape 2.02 so bear with me with old habits dying hard.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by Giorgio Maone » Tue Apr 25, 2017 10:11 pm

Fixed in latest development build 5.0.4rc1, thanks.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by Giorgio Maone » Tue Apr 25, 2017 9:14 pm

  1. This is a bug triggered with e10s enabled on Firefox 53 only when NoScript Options>Advanced>Trusted>Allow local links is checked (it's unchecked by default), and I'm gonna fix it in NoScript 5.0.4.
  2. This options is, in facts, advanced and disabled by default for a reason (it lowers your security level).
  3. It is needed only in very specific scenarios, in very legacy environments and configurations, and that's why I (reluctantly) keep it around. I'll probably hide it away even more as soon as possible, though.
  4. Therefore, if you don't know what this options is for and/or you don't actually need it enabled, please keep it disabled, thank you.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by mzs » Tue Apr 25, 2017 5:18 pm

I get the same problem with FF 53.0 and NoScript 5.0.3....

Disabled NoScript and file open works...

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by Aybee » Tue Apr 25, 2017 3:30 pm

Celebrated too soon. With

Code: Select all

browser.tabs.remote.force-enable = true
NoScript did not work anymore. There is nothing in the dropdown you can click on.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by Aybee » Mon Apr 24, 2017 2:11 pm

Seems to work if you create a new boolean param with about:config

Code: Select all

browser.tabs.remote.force-enable = true
You can test if multiprocess is enabled in about:support - "Multiprocess Windows"
see here https://superuser.com/questions/1029400 ... refox-beta

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by therube » Mon Apr 24, 2017 12:58 pm

Suppose it would be helpful to know:

OS
32 or 64-bit FF
e10's enabled or not
& then testing in a new, clean Profile, with only NoScript installed - at its default settings

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by periboob » Sun Apr 23, 2017 11:03 pm

Partial Work around/perhaps a hint as to whats happening. I only need much access to one file, so as a trial, rather than a bookmark, I made a desktop shortcut to that file. It works. No idea what the difference between a bookmark to a file, and a file shortcut is, maybe someone smarter can use this hint to work on a real fix.

Re: file:\\\ links fail with NoScript 5.0.2 & FF 53.0

by periboob » Sat Apr 22, 2017 6:06 pm

Problem just started for me, with latest FF. Win-10. Tried suggestions above. Disableing NoScript fixes, but I cant live that way!

Top