Blocking data uri

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Blocking data uri

Re: Blocking data uri

by RobertJ » Sun Jul 08, 2012 5:19 pm

.
Sorry I've been MIA; apparently I am not receiving emails about replies for some reason.

Allowing globally works after manually reloading of the page; however, that is using a sledgehammer. I would like to do a more precise action. I have played with numerous options in NS and cannot find the "Magic" to make this work.

.

Re: Blocking data uri

by therube » Tue Jul 03, 2012 10:36 pm

Maybe the only way to get it to work is to Allow Global?

(Or maybe it is a bug?
Messing with; noscript.allowURLBarImports, noscript.allowURLBarJS, & noscript.forbidXBL didn't seem to accomplish anything?)


Note: May need a manual page refresh after Allow Global.

Re: Blocking data uri

by therube » Tue Jul 03, 2012 10:27 pm

You need to allow file://

So either load a local html page, allowing file:// or add file:// to your whitelist.
(Maybe there should be a way to add a URI temporarily to the whitelist?)

Never mind, that is not it.

Re: Blocking data uri

by therube » Tue Jul 03, 2012 10:16 pm

> If fails to work

>> Fails in what way?
>> Page doesn't load, or?

The page loads, but does not return any results when you type in a "password".

Blocking data uri

by RobertJ » Tue Jul 03, 2012 9:23 pm

If you go here

http://flagfox.wordpress.com/2012/07/03/an-etropy-based-password-strength-checker-in-a-data-uri/

and scroll down the page halfway, there is a link to a data uri labeled

Load my entropy based password checker (data URI)

If fails to work unless I disable NoScript. What particular part of NS is blocking it and how to I allow it. I thought it might be noscript.allowURLBarJS but that is not it.

Thank you

Top