[RESOLVED 2.0.9.6] NoScript blocking routers config page

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
SHORTCUTS

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: [RESOLVED 2.0.9.6] NoScript blocking routers config page

Re: [RESOLVED 2.0.9.6] NoScript blocking routers config page

Post by therube » Thu Feb 03, 2011 7:03 pm

(SeaMonkey intends on waiting for 4.0.1 before releasing <SeaMonkey> 2.1 - so that they have less to fix :lol:.)

Re: [RESOLVED 2.0.9.6] NoScript blocking routers config page

Post by dhouwn » Thu Feb 03, 2011 5:55 pm

Or wait until the release if 4.0, so they have something to fix for 4.0.1

/me finds it funny how the Mozilla guys started dismissing other patches that would very unlikely break anything quite some time ago but this one they hurried to get in.

Re: [RESOLVED 2.0.9.6] NoScript blocking routers config page

Post by Giorgio Maone » Wed Feb 02, 2011 11:13 pm

Everybody in this thread: could you check whether latest Minefield on a clean profile, without NoScript but with the Tools|Options|Advanced|Tell websites that I do not want to be tracked box checked, causes the same problem?

Re: NoScript blocking routers config page

Post by Giorgio Maone » Sat Jan 15, 2011 12:51 am

latest development build 2.0.9.4rc2 should work-around this router web server implementation bug automatically, without any preference change.
Please check it, after reverting the noscript.doNotTrack.* preferences to their default values.

Re: NoScript blocking routers config page

Post by Di3S3L » Fri Jan 14, 2011 7:17 pm

I think it's not both, I tried adding my router's IP address to the 'noscript.doNotTrack.exceptions' string but the problem persists. I'll try your dev build next.

Details on my problem are about the same. I use a Linksys WRT120N, firmware version 1.0.05. Login through FireFox fails on this specific machine that I use, but not the other machines. All machines have NoScript and are fully updated. Pretty weird huh, you'd think that since all machines have the same browser and add-ons that you'd get the same problem across your network.

By failed login, I mean that the dialogue login box clears each time I enter the correct credentials, but if I press cancel, it gives me a 401 message: authentication failure or browser is not authentication capable.

Anyway, just thought you should know that it probably isn't the string that gives the workaround, but possibly the dev build.

[EDIT]
I read up on this thread some more, and the boolean noscript.doNotTrack.enabled toggled to false lets me access my router settings now. Mind you, I had the string noscript.doNotTrack.exceptions modified to my router's IP[192.168.1.1], so I don't know if it's a combination of both, or just the boolean that gives the workaround.

Re: NoScript blocking routers config page

Post by goose » Fri Jan 14, 2011 10:00 am

Hallo,
I had the same Problem with my Router called 'Easybox802' by vodafone.
After installing development build v2.0.9.4rc1 AND adding 192.168.2.1 to my 'noscript.doNotTrack.exceptions' i have no problems any more to login to my routers configuration page. :D :D

Thank you for your support Maone!

Re: NoScript blocking routers config page

Post by Giorgio Maone » Thu Jan 13, 2011 9:01 pm

tekkie wrote:problem exists when i try to logg in to my speedport w700v or easybox 802/803.
firefox 3.6.13
noscript 2.0.9.3
windows xp sp3

Did you check whether latest development build helps you?

Re: NoScript blocking routers config page

Post by tekkie » Thu Jan 13, 2011 8:46 pm

problem exists when i try to logg in to my speedport w700v or easybox 802/803.
firefox 3.6.13
noscript 2.0.9.3
windows xp sp3

there are a few customers which i support with their online provider, which have the same problem.

never had the problem bevor noscript version 2.0.9.3

Re: NoScript blocking routers config page

Post by Alfdererste » Fri Jan 07, 2011 8:50 am

Version 9.0.4rc1 works pretty well! No more Router problems!

:)

Thank you for your fast response.

Re: NoScript blocking routers config page

Post by Giorgio Maone » Thu Jan 06, 2011 4:23 pm

Could you try latest development build?
It has implements tentative work-around (reordering the headers putting "Connection" in the end) for the router bug, which I've got no means to test.

Should that not work, you can work-around by adding your router(s) IP(s) to the noscript.doNotTrack.exception about:config prefs, which in this release is finally enforced at it should (yes, a NoScript bug this time).

@Delyrium:
Obviously, please test with noscript.doNotTrack.enabled set to true and no exception first, to check whether the header reordering actually works around the bug.

Thank you.

Re: NoScript blocking routers config page

Post by Alfdererste » Thu Jan 06, 2011 3:05 pm

Hi,

I have the same problem with my Router. Its a Speedport w722v from Telekom.
When I enter my password and press return the Router even resets.

This only happens when a newer Noscript version is active. (2.0.9.3)

I tried also to deactivate ABE and clearing the browser cache and noscript settings.

With version 2.0.7 it just works fine.

Re: NoScript blocking routers config page

Post by Delyrium » Wed Jan 05, 2011 1:25 pm

Still no luck adding the address to the exception list. :x

Re: NoScript blocking routers config page

Post by Giorgio Maone » Wed Jan 05, 2011 8:59 am

Looks like ABP does not send the header by default. Weird.
However, Universal Behavioral Advertising Opt-out seems to confirm that the bug is in your router's firmware.

Delyrium wrote:I added the routers IP to the exception list but that didn't work, still unable to login unless I turn off the X-Do-Not-Track header option.

Strange, could you try prefixing the protocol, i.e. http://192.168.1.1 ?
Thanks.

Re: NoScript blocking routers config page

Post by Delyrium » Wed Jan 05, 2011 2:04 am

Giorgio Maone wrote:It definitely seems a router bug.
Could you check whether the problem happens also on a clean profile with Adblock Plust 1.3.3 (which implements the X-Do-Not-Track header) and/or on a clean profile with https://addons.mozilla.org/en-US/firefox/addon/12765 ?

However, if you want to keep both the feature and your router UI, you can add 192.168.1.1 to your noscript.doNotTrack.exceptions about:config preference.


With ad-block Plus 1.3.3 there was no problem accessing my router, I wasn't able to find an option to check if X-Do-Not-Track was on by default and/or if it could be turned off.

Code: Select all
00:03:59.571   0.039   473   132   GET   200   text/html   http://192.168.1.1/

Code: Select all
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.5
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
Authorization   Basic [redacted]
Cache-Control   max-age=0

Code: Select all
(Status-Line)   HTTP/1.0 200 OK
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html


With the Universal Behavioral Advertising Opt-out I was unable to login to my router, the exact same behavior as with NoScript.

Code: Select all
00:00:15.306   0.057   494   171   GET   401   text/html   http://192.168.1.1/

Code: Select all
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.5
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
X-Behavioral-Ad-Opt-Out   1
X-Do-Not-Track   1
Authorization   Basic [redacted]
[code](Status-Line)   HTTP/1.0 401 Unauthorized
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html
WWW-Authenticate   Basic realm="WRT54GH"


I added the routers IP to the exception list but that didn't work, still unable to login unless I turn off the X-Do-Not-Track header option.

Re: NoScript blocking routers config page

Post by Giorgio Maone » Tue Jan 04, 2011 11:47 pm

It definitely seems a router bug.
Could you check whether the problem happens also on a clean profile with Adblock Plust 1.3.3 (which implements the X-Do-Not-Track header) and/or on a clean profile with https://addons.mozilla.org/en-US/firefox/addon/12765 ?

However, if you want to keep both the feature and your router UI, you can add 192.168.1.1 to your noscript.doNotTrack.exceptions about:config preference.

Top

cron