Lithium Forum Software

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Lithium Forum Software

Re: Lithium Forum Software

by GµårÐïåñ » Wed Apr 08, 2009 8:40 pm

Agreed, their JS code is completely mangled but the funny thing is that I am having the reverse experience for some reason. Without the JS (NS normal block) it works (except for the buttons and extended features of course) but you can type and post. With the JS (NS Allowed) it will make everything function but makes the main message box where you would enter the information disappear. The most bizarre thing ever since I have been using these along with my current configuration for years now, this is just odd. I suppose it could have been a change in the lithium code but I know one board that has NOT updated, so it should still work on there but it doesn't and the only thing that I changed was to move to the dev build, so I was wondering maybe if Giorgio knew of something that might be causing this. If not then I need to go hunting elsewhere to see what could be causing it.

Re: Lithium Forum Software

by dhouwn » Wed Apr 08, 2009 8:44 am

With Javascript disabled I can't even click the "New Message" button, and with it enabled everything seems to work fine for me (tested at http://lithosphere.lithium.com/lithium/ ... .id=forums).


BTW: Their JS code is a mess.

Lithium Forum Software

by GµårÐïåñ » Wed Apr 08, 2009 2:32 am

There are 3 forums where I mod/use that are lithium based and there is a problem that started occurring using the latest dev build. When you try to compose a reply or pm or anything, if site is not allowed it works fine but if you allow the site the text box portion disappears. Let me demonstrate visually:

With NS not allowed on the site (which means you can do everything except WYSIWYG functions, such as formatting, quote, spellcheck, etc.)
Image

With NS allowing the site, immediately upon the page being painted (loaded)
Image

any ideas what is going on here?

Top