ajax.googleapis.com not loading issue?

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: ajax.googleapis.com not loading issue?

Re: ajax.googleapis.com not loading issue?

by Tree » Tue Jul 21, 2020 1:23 am

barbaz wrote:
Tue Jul 21, 2020 12:47 am
As a test, does it work for you if you "Disable restrictions for this tab" in NoScript?
It does.

I tried to think of anything else that it could be and tested the built in Firefox tracking protection. Turns out Firefox must have added ajax.googleapis.com to be blocked when using the Level 2 Strict protection very recently (last week or two at most). Setting it to Level 1 Basic and then allowing it in NoScript makes it work again like it used to. I have had it set to Level 2 Strict for ages so didn't even think of that changing to add it after all this time (as Level 2 never blocked it before).

Thanks again barbaz for your time and help.

Re: ajax.googleapis.com not loading issue?

by barbaz » Tue Jul 21, 2020 12:47 am

As a test, does it work for you if you "Disable restrictions for this tab" in NoScript?

Re: ajax.googleapis.com not loading issue?

by Tree » Tue Jul 21, 2020 12:45 am

barbaz wrote:
Mon Jul 20, 2020 9:51 pm
How do you have your Trusted preset configured? (NoScript Options > General > TRUSTED
Thanks barbaz for the help.

Trusted = Script/Fetch/Ping. Same as it was when it was working.

Since is working for you, what else can I look into in order to figure the cause (hopefully short of temporarily disabling NoScript)? I can't think of what else might be the cause as no other system settings, updates or extension seem releated to this specific script not working when allowed.

Re: ajax.googleapis.com not loading issue?

by barbaz » Mon Jul 20, 2020 9:51 pm

How do you have your Trusted preset configured? (NoScript Options > General > TRUSTED)
Tree wrote:
Mon Jul 20, 2020 6:41 pm
hxxps//w.w.w.deepdiscount.com/search?mod=AV&ft=Blu-ray#!?pagenum=1&sortby=PriceLowHigh&perpage=250 (requires deepdiscount, ajax.googleapis.com and jsdelivr in order to bring up sort by options menu).

Does the same happen for anyone else or do those sites function with those options when allowed?
I went to this one and not only am I not seeing what you're describing, I didn't need to allow jsdelivr to get the sort by options menu.

ajax.googleapis.com not loading issue?

by Tree » Mon Jul 20, 2020 6:41 pm

I do not know if this is an issue on my end or not (my understanding level is limited).

Just recently, with no other known system changes, a couple of sites I visit that require the ajax.googleapis.com script as allowed in order to function have stopped working as they were when allowed. I am not sure but it seemed to happen around the time the time noscript updated over the last couple of versions (within the last two weeks).

hxxps//titantv.com/default.aspx (requires titantv and ajax.googleapis.com in order to scroll through time periods or change TV provider)

hxxps//w.w.w.deepdiscount.com/search?mod=AV&ft=Blu-ray#!?pagenum=1&sortby=PriceLowHigh&perpage=250 (requires deepdiscount, ajax.googleapis.com and jsdelivr in order to bring up sort by options menu).

Does the same happen for anyone else or do those sites function with those options when allowed? The TitanTV one just sits on a loading wheel saying loading please wait.

Top