How to Undo Cross-Script block

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: How to Undo Cross-Script block

Re: How to Undo Cross-Script block

by YakForger » Fri Feb 28, 2020 9:55 am

Glad to see there's a solution to that, I was stuck as well as I did the same mistake...

Re: How to Undo Cross-Script block

by AuntyJack » Sat Feb 01, 2020 11:15 pm

Thanks Barbaz! I'll need to do it the long way, but hopefully this will do the trick.

Re: How to Undo Cross-Script block

by barbaz » Sat Feb 01, 2020 12:49 pm

If you don't have any XSS choices you care about, you can just go NoScript Options > Advanced and click "Clear XSS Choices".

If you have other XSS choices you would like to preserve, there isn't currently any user-friendly way to do this, but it can still be done:

1) Export your entire NoScript config

2) Open the export file in a text editor, manually delete the offending entry from "xssUserChoices" section

3) import the modified NoScript config

How to Undo Cross-Script block

by AuntyJack » Sat Feb 01, 2020 10:20 am

When clicking on a Google link to a Wikipedia article, I got the popup message about cross-scripting, but stupidly clicked "Always block". Now I cannot open any Wiki links in Google. How do I undo this?

Top