Context menu popup

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Context menu popup

Re: Context menu popup

by Guest » Sat Dec 28, 2019 5:24 pm

A very simple fix, at least for my configuration was to change the value from 500 to 1500 in main.js. No more popups.

Re: Context menu popup

by Guest » Sat Dec 28, 2019 4:57 pm

Since this change only helps users of the Tor Browser would it be possible to add a pref for them that can switch between the old and new behavior?

Re: Context menu popup

by Guest » Sat Dec 28, 2019 2:55 pm

With a clean profile there's no popup and the toolbar permission tabs open as before.

After going through the other addons there appears to be a conflict with at least two: foxclocks and user switcher agent. When they are disabled there's no popup but since I must have those unless you can fix the bug on your end I'm stuck on this older version. 11.0.9 works good anyway.

Re: Context menu popup

by Giorgio Maone » Sat Dec 28, 2019 10:14 am

This is the intended behavior when the toolbar icon is hidden (e.g. in the Tor Browser's default configuration since version 9).
Unfortunately there's no way for a WebExtension to tell whether the toolbar icon is actually hidden or not; not even by catching an exception when trying to programmatically open its popup: browser.browserAction.openPopup() just silently fails, and in NoScript 11.0.9 and below you would use the keyboard shortcut or the context menu and nothing happened, which became quite apparent and painful in latest Tor Browser.
Therefore NoScript 11.0.10rc2 introduces this hack: it sends back a message from the popup if it manages to load, and if this message doesn't arrive within 500ms from trying to open the popup, it loads the UI in a separate window (which should work much like the native popup, even closing automatically when it losts focus and triggering a reload if permissions have been changed).
Now in your case I can see two problems, possibly bugs:
  1. The separate window seems to be forced unconditionally, even though NoScript's toolbar icon is visible. This might be due to 500ms not being enough in your specific configuration? Could you check on a clean profile with just NoScript installed?
  2. The UI in the window is not functional. Can you show us some screenshots and/or check for error messages, either in the global browser console (ctrl+shift+J) or in the unfunctional UI window (ctrl+shift+K)?

Re: Context menu popup

by Guest » Fri Dec 27, 2019 10:22 pm

There's been a noscript entry in the context menu since the quantum version and even before. The only difference is that the quantum version only opens the toolbar button permission tabs whereas pre-quantum had its own separate menu. The context menu item can be disabled in noscript options/Appearance.

Now in 11.0.10 the context menu entry opens a whole separate popup window to do what was simple before. It's somewhat annoying and unnecessary, hope it's not intentional. For now I've gone back to 11.0.09.

Re: Context menu popup

by therube » Fri Dec 27, 2019 10:00 pm

Are you new to FF Quantum (& webextensions)?

I wasn't particularly aware that that combination had a (meaningful) NoScript context menu.
Nature of the beast. (Shame.)

Context menu popup

by Guest » Fri Dec 27, 2019 8:17 pm

Hello,

Using Windows 7, firefox 68esr with the 11.0.10 version when I right click to use the context menu to change/set permissions it's opening up a mostly blank popup window and it's impossible to do anything with it. The only way to make changes is with the toolbar button.

Is this intentional? Hope not since I would miss the context menu function working as it did in the previous versions.

Top