NoScipt 5.1.9 asking to allow file:// in Waterfox

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: NoScipt 5.1.9 asking to allow file:// in Waterfox

Re: NoScipt 5.1.9 asking to allow file:// in Waterfox

by File » Fri Aug 09, 2019 12:12 pm

Just in case anyone is interested I figure this out

uBlock Origin supports hosts file "style" IP re-mapping
Peter Lowe’s Ad and tracking server list for uBlock Origin contains a number a Ad sites which are re-mapped 127.0.0.1 one is googletagservices.com
When one of these re-mapped sites is allowed via NoScript it is redirected to 127.0.0.1
Therefore any requests to that url look to Waterfox like they are coming from the local machine, which causes NoScript to put file:// in its list of blocked domains. Why this doesn't happen in Firefox with the latest NoScript I am not sure

Re: NoScipt 5.1.9 asking to allow file:// in Waterfox

by File » Thu Aug 08, 2019 1:30 pm

Waterfox 56.2.12 and I also have uBlock Origin (that's all). I have the same NoScript 11.0.2 and uBlock Origin in Firefox 68 but I never see file:// in Firefox

Re: NoScipt 5.1.9 asking to allow file:// in Waterfox

by barbaz » Thu Aug 08, 2019 1:26 pm

What version of Waterfox?
What other extensions do you have?

NoScipt 5.1.9 asking to allow file:// in Waterfox

by File » Thu Aug 08, 2019 12:15 pm

I am using Waterfox and NoScript "Classic" 5.1.9, I've noticed that some domains after a few refreshes, NoScirpt will show "file://" as a domain that is blocked. If I refresh the page file:// will disappear from the list, I cannot re-create this behavior in Firefox 68 with NoScript 11.0.2. Is there any reason "file://" may appear at random in the NoScript blocked domains? Maybe something from cache? I am also running uBlock Origin. I have seen this issue one other place: https://www.reddit.com/r/noscript/comme ... e_domains/

Top