google search results displaying in mobile mode with Noscript, despite being on desktop

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: google search results displaying in mobile mode with Noscript, despite being on desktop

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Mon May 27, 2019 3:02 am

Thanks Rereser - all working now for google.com.au

I have also followed your other advice:

"set homepage or shortcut to this.
https://www.google.com/?noj=1
and for the correct search plugin go here.
https://mycroftproject.com/google-search-plugins.html
search for ... Google (no JS) (google.com) by Dmitry Alexandrov
make this the default.
temp allow the above page for the plugin to install.
this will also remove "&rls=org.mozilla:en-US:unofficial" from the end of the search url's."

And I found a no JS for google.com.au in the mycroftproject page you mentioned.

Thanks to all that helped. Google search & it's other tentacles are back in it's box!

~S.O

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sun May 26, 2019 5:08 pm

my mistake.
after testing google.com.au , i went to google.com. (not com.au)
obviously that went to the mobile mode then.
thanks for the feedback and great you got it to work.
will correct my other post.
grtz.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by skriptimaahinen » Sun May 26, 2019 5:00 pm

rereser wrote:
Sun May 26, 2019 7:22 am
just tested.
general.useragent.override.google.com.au
Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 7.1; Trident/5.0)
does not work.
For me that does work. As well as any other country specific override. Did you actually test it on https://www.google.com.au and not just https://www.google.com ?

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sun May 26, 2019 7:22 am

additional tip.
set homepage or shortcut to this.
https://www.google.com/?noj=1
and for the correct search plugin go here.
https://mycroftproject.com/google-search-plugins.html
search for ... Google (no JS) (google.com) by Dmitry Alexandrov
make this the default.
temp allow the above page for the plugin to install.
this will also remove "&rls=org.mozilla:en-US:unofficial" from the end of the search url's.

this may be what is going on.
https://www.zdnet.com/article/former-mo ... for-years/
a script could have been added that some browsers can't work with.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Sun May 26, 2019 7:15 am

Thanks!

I'll try that report back.

~SO

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sun May 26, 2019 7:11 am

@sprocketoctopus

general.useragent.override.google.com
Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 7.1; Trident/5.0)

not Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0)

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Sun May 26, 2019 5:06 am

Thanks Barbaz - and apologies for not logging in.

I have tried your suggestion: Firefox 67.0

general.useragent.override.google.com.au;
Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0)

Still same does not work.

As suggested previously -Is this is a Google change?

Thanks again for your help.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by barbaz » Sun May 26, 2019 2:56 am

@sprocketoctopus Remember to log in before posting so that you can use your chosen username and don't need to repeatedly solve the CAPTCHA each time. (I've fixed your post above)

You can just use as-is the suggested UA string for "general.useragent.override.google.com". There should be no need to alter the suggestion for different OS.

As for "general.useragent.override", I think rereser may have done that for reasons unrelated to this thread. Try without it.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Sun May 26, 2019 12:22 am

Thanks Rereser!

I think I understand your fix.

To Quote for an MS machine:

three new strings in about:config.

general.useragent.override
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

general.useragent.override.google.com
Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 7.1; Trident/5.0)

general.useragent.override.youtube.com
Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0)
------------------------------------------------------------------------------------------------------------------------
For my Linux box is it:
general.useragent.override
Mozilla/5.0 (X11; Linux i686; rv:64.0) Gecko/20100101 Firefox/64.0

general.useragent.override.google.com <--- (I will also add ".au" for my local flavor of Google)
Mozilla/5.0 (X11; Linux i686; rv:64.0) Gecko/20100101 Firefox/64.0

general.useragent.override.youtube.com
Mozilla/5.0 (X11; Linux i686; rv:64.0) Gecko/20100101 Firefox/64.0
-------------------------------------------------------------------------------------------------------------------------------------------------

Thank you and others who chimed in for help.

Cheers

~S.O

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by skriptimaahinen » Sat May 25, 2019 5:24 pm

Looks like something about the client and locale. Probably added by the search engine?

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sat May 25, 2019 5:09 pm

think you are correct.
just something i just saw on each google search result.
that is with and without the google override mod.
at the end of the url there is always something like this "&rls=org.mozilla:en-US:unofficial"
removing that from the url and reload displays the same results.
never noticed that before.
keeps getting stranger ...

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by skriptimaahinen » Sat May 25, 2019 4:57 pm

So as I assumed - general.useragent.override.youtube.com is just to get the old youtube design - not necessary to fix the search pages.

And the general.useragent.override is necessary only if you have other problems like outdated browser.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sat May 25, 2019 4:11 pm

no , not for search.
that was only to load the youtube page from the google homepage with videos instead of a blank page with placeholders.
hardly ever go there , just checked by accident.
used the internet explorer strings.
maybe some from firefox or chrome work better.
again , can't test other browser versions.
don't know what is going on but for me it works for now.
i need the first one for my outdated system. (outdated browser message)
added the second for google for the mobile view fix.
and another (not the same as for google) when i found the youtube page did not load.
only registered here to post my findings after your post.
thanks again for your solution.
now just to find the right combination for the effected systems.
windows , linux and browser version.
noscript settings here for youtube.
Image

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by skriptimaahinen » Sat May 25, 2019 3:59 pm

rereser wrote:
Sat May 25, 2019 3:56 pm
in my case the youtube string was needed.
Is that for some specific search?

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sat May 25, 2019 3:56 pm

in my case the youtube string was needed.
by reading your reply you might only need the google.ca one.

Top