google search results displaying in mobile mode with Noscript, despite being on desktop

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: google search results displaying in mobile mode with Noscript, despite being on desktop

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by asaone7 » Thu Nov 28, 2019 1:29 am

skriptimaahinen, I would definitely do that if I didn't already know how unresponsive, unhelpful and just all around unpleasant Google has been to support inquiries. Any support requests has to go through the product forums, and even there, you aren't receiving help from google directly, but a bunch of volunteers who merely relay information and hope to get a response. It's pretty much a given 100% that any suggestions given this way goes completely ignored.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Thu Nov 28, 2019 12:00 am

Thanks skriptimaahinen for your efforts.

Hopefully there may be a fix soon - it's beyond my skillset!

Cheers

~SO

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by skriptimaahinen » Wed Nov 27, 2019 12:29 pm

I have tested few useragent strings but none of them seem to bring back the old search. There might be other ways, but I have no clue what those might be.

You could always send feedback to Google and urge them to enable the old search interface for those that disable scripting. Personally I switched to using Startpage and DDG back when Google made the first change.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by asaone7 » Wed Nov 27, 2019 5:44 am

Any solution to this? I really would like to get back the desktop view but keep noscript enabled.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sat Nov 23, 2019 12:14 pm

no fault of noscript , using 5.1.9 on pale moon 28.7.2.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/70.0 set as google override.
new profile without noscript.
about:config > javascript.enabled = true > new layout
about:config > javascript.enabled = false > mobile view.
tried a few hundred Mozilla/5.0 user agents.
some will provide the old black bar on google launch.
but all will display the new layout when running a search.
one advantage is that now you have access to the google settings with the above user agent.
maybe some code in the browser profile / chrome / userContent.css holds a solution.
don't have the knowledge for that.

have the below user agent set as general to test other sites.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Sat Nov 23, 2019 10:40 am

rereser wrote:
Sat Nov 23, 2019 10:32 am
no solution yet.
strangely the google image search displays the old layout with javascript disabled.
and it returns desktop mode results.
no site specific user agent set for google.
Thanks rereser.

I wonder could it be something to do with NoScript itself?

I noticed an update of the FF addon the day before. Something maybe broke?

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sat Nov 23, 2019 10:32 am

no solution yet.
strangely the google image search displays the old layout with javascript disabled.
and it returns desktop mode results.
no site specific user agent set for google.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by asaone7 » Fri Nov 22, 2019 4:15 am

Thank you, yes, I'm experiencing the same issue. I am hoping there's another edit to about:config to get around this.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Fri Nov 22, 2019 12:10 am

Good Morning.

Sorry for the thread mine - but it appears Google is up to their shenanigans again!

As of this morning in AUS, Google Search results showing in mobile/tablet mode again - FF V70.0.1 - Ubuntu/Linux

As before I have:

Cleared all my Cache/cookies & History.
Restarted the machine.
Restarted Firefox in safe mode (no addons)
Disabled all addons.

For the temporary fix, is for me to delete the string in Firefox about:config:

general.useragent.override.google.com.au;Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 7.1; Trident/5.0)

Appreciate any help please to sort this out.

Thanks

~SO

EDIT: The http://www.useragentstring.com/ website seems out of date the last Firefox useragent string that I can find is V.64. Thanks.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by skriptimaahinen » Fri Aug 02, 2019 4:16 am

I see nothing out of ordinary on YouTube.
What are your current useragent overrides?
Screenshot of the problem?

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by asaone7 » Thu Aug 01, 2019 3:43 pm

Any settings to add to about:config for a workaround to this, like what was provided here for the google search results?

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by therube » Mon Jul 29, 2019 10:42 am

Are you blocking JavaScript in IE?
Try it.

Did you try spoofing the UA in FF?
Try it.
(If you do, it will likely still have some unwanted consequences.)

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by asaone7 » Mon Jul 29, 2019 5:01 am

Sorry to have to bump this. But now youtube itself is displaying incorrectly, probably as mentioned due to it detecting JavaScript as disabled. Basically the youtube homepage contains very large thumbnails of videos and is overall plainer. Looks like it's loading the mobile view by default for this. If I view the page in IE, it's just fine.

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by sprocketoctopus » Mon May 27, 2019 3:02 am

Thanks Rereser - all working now for google.com.au

I have also followed your other advice:

"set homepage or shortcut to this.
https://www.google.com/?noj=1
and for the correct search plugin go here.
https://mycroftproject.com/google-search-plugins.html
search for ... Google (no JS) (google.com) by Dmitry Alexandrov
make this the default.
temp allow the above page for the plugin to install.
this will also remove "&rls=org.mozilla:en-US:unofficial" from the end of the search url's."

And I found a no JS for google.com.au in the mycroftproject page you mentioned.

Thanks to all that helped. Google search & it's other tentacles are back in it's box!

~S.O

Re: google search results displaying in mobile mode with Noscript, despite being on desktop

by rereser » Sun May 26, 2019 5:08 pm

my mistake.
after testing google.com.au , i went to google.com. (not com.au)
obviously that went to the mobile mode then.
thanks for the feedback and great you got it to work.
will correct my other post.
grtz.

Top