Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browser

Post a reply

:
In an effort to prevent automatic submissions, we require that you enter both of the words displayed into the text field underneath.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
SHORTCUTS

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browser

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by CuF » Fri Nov 25, 2016 3:26 am

Pale Moon v27 is now out and neither the official nor the modified version of FlashGot work.

If you are using an external download manager like JDownloader2, etc. FG properly passes the link.
Unfortunately if you want to use the browser's built-in download, it reports as "Failed".

I don't know what's changed in PM to produce this but it is disappointing.

I'm open to any suggestions or ideas.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by therube » Thu Oct 27, 2016 5:51 pm

DoctorM wrote:Again, the only change is to SDownloadsAPI.jsm to change the version check from 26.01a to 29.0.

A cursory inspection shows that to be correct.
(I didn't look at the "signing", nor do I have any clue about FlashGot, this or the mod'd one, & PaleMoon, in general.)

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by CuF » Wed Oct 26, 2016 2:56 pm

A Pale Moon compatible version of the most recent version of FlashGot is on this thread: https://forum.palemoon.org/viewtopic.php?f=16&t=11534#p82603

Any bugs or issues with the program's normal functionality is up to its author to deal with... who has been MIA for quite a while.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by Habby » Wed Oct 26, 2016 7:10 am

FlashEmAll wrote:Hello! Congratulations and thanks for your excellent FlashGot extension - it has always been very helpful. Just registered to also ask about the Hydromax if this Pale Moon compatibility problem might be hopefully fixed. :)


Good question, I love the extension and I use it a lot but it needs a few fixes. I'd do it myself if I knew how.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by FlashEmAll » Wed Mar 30, 2016 1:27 pm

Hello! Congratulations and thanks for your excellent FlashGot extension - it has always been very helpful. Just registered to also ask if this Pale Moon compatibility problem might be hopefully fixed. :)

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by Will Pittenger » Mon Mar 28, 2016 4:41 am

Definitely needs a fix.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by sgtph3n1x » Wed Mar 23, 2016 3:00 am

The only fix I could find for this was disable add-on updates for this add-on and reinstall FlashGot Version: 1.5.5.8.1, It worked for me.

Here's a link.
https://addons.mozilla.org/en-US/firefox/addon/flashgot/versions/1.5.5.8.1-signed

I am also looking for a solution myself.

But I thought I'd share this, while I patiently wait for a fix.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by anotherGuest » Tue Mar 22, 2016 11:19 am

There's a thread on the Pale Moon support forum concerning this. Am linking it hoping it will be helpful: http://forum.palemoon.org/viewtopic.php?f=16&t=11534

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by twistedvincent » Mon Mar 21, 2016 7:44 pm

Someone sent me a beta (?) to use until something permanent comes along and after a reboot it didn't work again a tall.

So I'm back to using a version from last year but we'll see after another reboot.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by Guest » Mon Mar 21, 2016 7:42 pm

Guest wrote:Please fix FlashGot to work with Pale Moon.

Old versions of FlashGot can be found here: https://flashgot.net/feeds

or here: https://addons.mozilla.org/en-US/firefox/addon/flashgot/versions/?page=1#version-1.5.6.12.1-signed

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by Guest » Mon Mar 21, 2016 7:08 pm

Please fix FlashGot to work with Pale Moon.

Old versions of FlashGot can be found here: https://flashgot.net/feeds

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by twistedvincent » Sat Mar 19, 2016 7:15 pm

Well it's down again/. West to use it this afternoon and nothing was where it supposed to be. I hope reverting to an old version helps until you guys get it fixxed

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by barbaz » Thu Mar 17, 2016 11:59 pm

CuF wrote:Wasn't logged in, so I can 't edit that post.

Fixed.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by CuF » Thu Mar 17, 2016 11:21 pm

Guest wrote:Ditto. Another PM user who would like to see FlashGot keep up with it.

Wasn't logged in, so I can 't edit that post.

I've seen two problems:

First, starting with 1.5.6.12, JSDownloadsAPI.jsm contains the line "return Services.vc.compare(Services.appinfo.version, "26.0a1") >= 0;".
Pale Moon is a higher version number but needs the pre-v26 JSM version to function, especially on YouTube.

With v1.5.6.13, the above is possibly still an issue, but FlashGot is now completely non-functional. It throws an error that a core component is missing.

Re: Incompatiblility-FlashGot1.5.6.13 & PaleMoon26.1.1Browse

Post by CuF » Thu Mar 17, 2016 11:09 pm

Ditto. Another PM user who would like to see FlashGot keep up with it.

Top