ABE prevents local links

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: ABE prevents local links

Re: ABE prevents local links

by alexo » Sat Apr 08, 2017 6:30 am

barbaz wrote:Do you have some sort of deployment software for all your corporate machines?
IT handles it.
barbaz wrote:
alexo wrote:Further investigation shows that that machine does not have an IPv4 address for some reason, only IPv6. Can that be the reason?
Likely yes, but I don't know the details of how ABE handles IPv6 addresses, sorry.
I'd say it's a bug then.

Re: ABE prevents local links

by barbaz » Fri Apr 07, 2017 10:43 pm

alexo wrote:Yes, the change makes it work.
Image

Do you have some sort of deployment software for all your corporate machines?
alexo wrote:Further investigation shows that that machine does not have an IPv4 address for some reason, only IPv6. Can that be the reason?
Likely yes, but I don't know the details of how ABE handles IPv6 addresses, sorry.

Re: ABE prevents local links

by alexo » Fri Apr 07, 2017 10:36 pm

Yes, the change makes it work.

Further investigation shows that that machine does not have an IPv4 address for some reason, only IPv6. Can that be the reason?

Re: ABE prevents local links

by barbaz » Fri Apr 07, 2017 9:16 pm

If ComputerName resolves both to an IP that falls under LOCAL *and* to an IP that doesn't fall under LOCAL, ABE might be expected to block ComputerName from redirecting to itself.

Does the ABE rule change get it working?

Re: ABE prevents local links

by alexo » Fri Apr 07, 2017 9:07 pm

For each machine on our corporate network? I am pretty sure this is not how it's supposed to work.

Re: ABE prevents local links

by barbaz » Fri Apr 07, 2017 6:01 pm

NoScript Options > Advanced > ABE, add at the very top of SYSTEM

Code: Select all

Site ComputerName:8080
Accept from ComputerName:8080

ABE prevents local links

by alexo » Fri Apr 07, 2017 5:41 pm

When trying to click on links from a Tomcat page on a computer on the local network, I get the following:

Code: Select all

[ABE] < LOCAL> Deny on {GET http://ComputerName:8080/manager/status <<< http://ComputerName:8080/ - 6}
SYSTEM rule:
Site LOCAL
Accept from LOCAL
Deny
Where "ComputerName" is a machine on the LAN.

How do I fix it?

Top