Problem with Pi-Hole and Prevent Internet sites from request

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Problem with Pi-Hole and Prevent Internet sites from request

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Sat May 13, 2017 4:28 pm

Thanks for reporting back, glad it's working for you again. 8-)

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Sat May 13, 2017 7:52 am

I solve my problem.
The problem was uBlock Origin :mrgreen:

After i allow Websocket & Worker for XDA, the thanks button works.
Even with Pi-Hole & Decentraleyes

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Thu Apr 20, 2017 9:15 pm

Dont think so because the Thanks button on XDA forums dont even work without Decentraleyes

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Tue Apr 18, 2017 7:28 pm

yes_noscript wrote:If i disable the "Prevent Internet sites from requesting LAN resources." System ABE rule the testsite works, but i get a CORS error:
Warning: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://ajax.googleapis.com/ajax/libs/j ... ery.min.js. (Reason: CORS header 'Access-Control-Allow-Origin' missing).

Maybe because of that this problem here exist ?
I think that is likely related to Decentraleyes, not this problem.

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Sat Apr 15, 2017 8:48 pm

I found a good test site: https://decentraleyes.org/test/

If i disable the "Prevent Internet sites from requesting LAN resources." System ABE rule the testsite works, but i get a CORS error:
Warning: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://ajax.googleapis.com/ajax/libs/j ... ery.min.js. (Reason: CORS header 'Access-Control-Allow-Origin' missing).

Maybe because of that this problem here exist ?

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Thu Apr 13, 2017 4:40 pm

Thats interessing, because i enable my IPv6 settings with Pi-Hole.
Make sense then

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Sun Apr 09, 2017 6:08 pm

I notice that you're using IPv6. May or may not be related, but FWIW you're not the only user reporting problems with ABE LOCAL and IPv6 - viewtopic.php?f=23&t=22715

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Sun Apr 09, 2017 3:35 pm

I dont block google stuff with Pi-Hole

It looks NoScript have problems with requests from own local network with ABE enabled

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Sun Apr 02, 2017 7:16 pm

I'd check Pi-Hole to see if it's blocking that domain. If so, that's an error with a list it's using, unless you actually want everything Google blocked for some reason.

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Sun Apr 02, 2017 6:13 pm

It give the local IP from Pi-Hole :shock:

But not for others domains

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Sun Apr 02, 2017 5:18 pm

Hmm. When you get that error, what does about:networking give for the DNS lookup of ajax.googleapis.com?

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Sun Apr 02, 2017 4:51 pm

Yes, i still get the ABE errors with disabled Decentralyes and a browser restart.
I use Decentraleyes a long time but the error is new.

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Sun Apr 02, 2017 3:16 pm

yes_noscript wrote:When i disable Pi-Hole and clear the DNS-Cache i get the same DNS result
Then the ABE warning cannot related to Pi-Hole, can it? So please try re-enabling Pi-Hole and disabling Decentraleyes. Do you still get the ABE warning?

Probably the DNS failure is at your upstream DNS servers then.
yes_noscript wrote:Did you have the same problem with for example XDA-forums and the Thanks-button?
I'm not a member of that site, so I'm not sure what you're referring to. Image

Re: Problem with Pi-Hole and Prevent Internet sites from req

by yes_noscript » Sun Apr 02, 2017 7:58 am

I mean i got no such ABE errors before Pi-Hole.

When i disable Pi-Hole and clear the DNS-Cache i get the same DNS result

Did you have the same problem with for example XDA-forums and the Thanks-button?

Re: Problem with Pi-Hole and Prevent Internet sites from req

by barbaz » Sat Apr 01, 2017 9:28 pm

Image That's a rather odd response for a dnsmasq-based blacklist. Maybe I'm still missing something about how Pi-Hole works, but my own dnsmasq-based blacklisting attempts always resulted in either 0.0.0.0 or NXDOMAIN being returned.
yes_noscript wrote:But i wonder why i doesnt get that before Pi-Hole
So if you disable Pi-Hole, any change in the ABE warning and/or DNS lookup of ajax.googleapis.com?

Top