[RESOLVED 2.0.9.6] NoScript blocking routers config page

Ask for help about NoScript, no registration needed to post

Re: NoScript blocking routers config page

Postby Giorgio Maone » Tue Jan 04, 2011 10:14 pm

I'm, truly sorry, if you tested the above with RC4 I guess I wasted some of your time :(

v 2.0.9
==========================================================================
- Removed JAR blocking (obsolete in supported browser versions)
- Removed emulated TLD service
x Hidden status bar icon option on applications which have no status bar
x Fixed noscript.doNotTrack.* preferences not being honored

Please repeat with latest version (2.0.9.3), thanks.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript blocking routers config page

Postby Delyrium » Tue Jan 04, 2011 10:33 pm

I only tested with RC4 because it is when the problem appeared, no waste of time at all.

Code: Select all
2.0.9
***********
00:01:49.350   0.034   494   171   GET   401   text/html   http://192.168.1.1/
***********
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.5
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
X-Behavioral-Ad-Opt-Out   1
X-Do-Not-Track   1
Authorization   Basic [redacted]
***********
(Status-Line)   HTTP/1.0 401 Unauthorized
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html
WWW-Authenticate   Basic realm="WRT54GH"


Code: Select all
2.0.9.3
***********
00:01:21.884   0.037   494   171   GET   401   text/html   http://192.168.1.1/
***********
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.5
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
X-Behavioral-Ad-Opt-Out   1
X-Do-Not-Track   1
Authorization   Basic [redacted]
***********
(Status-Line)   HTTP/1.0 401 Unauthorized
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html
WWW-Authenticate   Basic realm="WRT54GH"


No difference at all, making the option noscript.donottrack.enabled false or true has no impact.

I do get this message on the error console [ABE WAN] Detected WAN IP XXX.XXX.XXX.XXX but I guess is normal as ABE is active in NS.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Delyrium
 
Posts: 10
Joined: Tue Jan 04, 2011 3:55 pm

Re: NoScript blocking routers config page

Postby Giorgio Maone » Tue Jan 04, 2011 11:00 pm

Delyrium wrote:No difference at all, making the option noscript.donottrack.enabled false or true has no impact.

This is really weird (please notice the preference name is case sensitive and it's noscript.doNotTrack.enabled), because it switches the two headers on and off in real time for me :(
Delyrium wrote:I do get this message on the error console [ABE WAN] Detected WAN IP XXX.XXX.XXX.XXX but I guess is normal as ABE is active in NS.

You're correct, this one is normal indeed.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript blocking routers config page

Postby Delyrium » Tue Jan 04, 2011 11:19 pm

You are right, that was my bad, changing to false this key noscript.doNotTrack.enabled does let me open the routers page with no problems.

Code: Select all
00:25:30.450   0.056   438   132   GET   200   text/html   http://192.168.1.1/
00:25:30.596   0.032   416   87   GET   200   application/x-javascript   http://192.168.1.1/jslib.js
00:25:30.661   0.208   418   87   GET   200   application/x-javascript   http://192.168.1.1/LANG_EN.js
00:25:30.688   0.199   417   87   GET   200   application/x-javascript   http://192.168.1.1/header.js
00:25:30.717   0.234   431   4396   GET   200   text/css   http://192.168.1.1/main.css
00:25:30.740   0.221   459   1720   GET   200   image/gif   http://192.168.1.1/images/UI_Linksys.gif
00:25:30.766   0.256   454   332   GET   200   image/gif   http://192.168.1.1/images/UI_10.gif
00:25:30.792   0.244   454   640   GET   200   image/gif   http://192.168.1.1/images/UI_03.gif
00:25:30.821   0.237   454   1114   GET   200   image/gif   http://192.168.1.1/images/UI_02.gif
00:25:30.847   0.220   415   87   GET   200   application/x-javascript   http://192.168.1.1/func.js
00:25:31.530   0.320   454   384   GET   200   image/gif   http://192.168.1.1/images/UI_07.gif
00:25:31.560   0.298   454   399   GET   200   image/gif   http://192.168.1.1/images/UI_06.gif
00:25:31.652   0.330   454   1121   GET   200   image/gif   http://192.168.1.1/images/UI_05.gif
00:25:31.677   0.293   454   244   GET   200   image/gif   http://192.168.1.1/images/UI_04.gif
00:25:31.772   0.221   457   3006   GET   200   image/gif   http://192.168.1.1/images/UI_Cisco.gif

Code: Select all
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.7,es-hn;q=0.3
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
Authorization   Basic [redacted]
[code](Status-Line)   HTTP/1.0 200 OK
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html


Thanks a lot for all the help, if you need something else tested with this little problem of my router let me know.

Sorry about the "case sensitive" issue of that key, this should've been solved some time ago. :oops:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Delyrium
 
Posts: 10
Joined: Tue Jan 04, 2011 3:55 pm

Re: NoScript blocking routers config page

Postby Giorgio Maone » Tue Jan 04, 2011 11:47 pm

It definitely seems a router bug.
Could you check whether the problem happens also on a clean profile with Adblock Plust 1.3.3 (which implements the X-Do-Not-Track header) and/or on a clean profile with https://addons.mozilla.org/en-US/firefox/addon/12765 ?

However, if you want to keep both the feature and your router UI, you can add 192.168.1.1 to your noscript.doNotTrack.exceptions about:config preference.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript blocking routers config page

Postby Delyrium » Wed Jan 05, 2011 2:04 am

Giorgio Maone wrote:It definitely seems a router bug.
Could you check whether the problem happens also on a clean profile with Adblock Plust 1.3.3 (which implements the X-Do-Not-Track header) and/or on a clean profile with https://addons.mozilla.org/en-US/firefox/addon/12765 ?

However, if you want to keep both the feature and your router UI, you can add 192.168.1.1 to your noscript.doNotTrack.exceptions about:config preference.


With ad-block Plus 1.3.3 there was no problem accessing my router, I wasn't able to find an option to check if X-Do-Not-Track was on by default and/or if it could be turned off.

Code: Select all
00:03:59.571   0.039   473   132   GET   200   text/html   http://192.168.1.1/

Code: Select all
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.5
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
Authorization   Basic [redacted]
Cache-Control   max-age=0

Code: Select all
(Status-Line)   HTTP/1.0 200 OK
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html


With the Universal Behavioral Advertising Opt-out I was unable to login to my router, the exact same behavior as with NoScript.

Code: Select all
00:00:15.306   0.057   494   171   GET   401   text/html   http://192.168.1.1/

Code: Select all
(Request-Line)   GET / HTTP/1.1
Host   192.168.1.1
User-Agent   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   en-us,en;q=0.5
Accept-Encoding   gzip,deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
X-Behavioral-Ad-Opt-Out   1
X-Do-Not-Track   1
Authorization   Basic [redacted]
[code](Status-Line)   HTTP/1.0 401 Unauthorized
Server   Apache
Pragma   no-cache
Cache-Control   max-age=0, must-revalidate
Connection   close
Content-Type   text/html
WWW-Authenticate   Basic realm="WRT54GH"


I added the routers IP to the exception list but that didn't work, still unable to login unless I turn off the X-Do-Not-Track header option.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Delyrium
 
Posts: 10
Joined: Tue Jan 04, 2011 3:55 pm

Re: NoScript blocking routers config page

Postby Giorgio Maone » Wed Jan 05, 2011 8:59 am

Looks like ABP does not send the header by default. Weird.
However, Universal Behavioral Advertising Opt-out seems to confirm that the bug is in your router's firmware.

Delyrium wrote:I added the routers IP to the exception list but that didn't work, still unable to login unless I turn off the X-Do-Not-Track header option.

Strange, could you try prefixing the protocol, i.e. http://192.168.1.1 ?
Thanks.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript blocking routers config page

Postby Delyrium » Wed Jan 05, 2011 1:25 pm

Still no luck adding the address to the exception list. :x
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Delyrium
 
Posts: 10
Joined: Tue Jan 04, 2011 3:55 pm

Re: NoScript blocking routers config page

Postby Alfdererste » Thu Jan 06, 2011 3:05 pm

Hi,

I have the same problem with my Router. Its a Speedport w722v from Telekom.
When I enter my password and press return the Router even resets.

This only happens when a newer Noscript version is active. (2.0.9.3)

I tried also to deactivate ABE and clearing the browser cache and noscript settings.

With version 2.0.7 it just works fine.
Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Alfdererste
 

Re: NoScript blocking routers config page

Postby Giorgio Maone » Thu Jan 06, 2011 4:23 pm

Could you try latest development build?
It has implements tentative work-around (reordering the headers putting "Connection" in the end) for the router bug, which I've got no means to test.

Should that not work, you can work-around by adding your router(s) IP(s) to the noscript.doNotTrack.exception about:config prefs, which in this release is finally enforced at it should (yes, a NoScript bug this time).

@Delyrium:
Obviously, please test with noscript.doNotTrack.enabled set to true and no exception first, to check whether the header reordering actually works around the bug.

Thank you.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript blocking routers config page

Postby Alfdererste » Fri Jan 07, 2011 8:50 am

Version 9.0.4rc1 works pretty well! No more Router problems!

:)

Thank you for your fast response.
Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Alfdererste
 
Posts: 1
Joined: Thu Jan 06, 2011 3:06 pm

Re: NoScript blocking routers config page

Postby tekkie » Thu Jan 13, 2011 8:46 pm

problem exists when i try to logg in to my speedport w700v or easybox 802/803.
firefox 3.6.13
noscript 2.0.9.3
windows xp sp3

there are a few customers which i support with their online provider, which have the same problem.

never had the problem bevor noscript version 2.0.9.3
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ImageShackToolbar/5.2.4
tekkie
 

Re: NoScript blocking routers config page

Postby Giorgio Maone » Thu Jan 13, 2011 9:01 pm

tekkie wrote:problem exists when i try to logg in to my speedport w700v or easybox 802/803.
firefox 3.6.13
noscript 2.0.9.3
windows xp sp3

Did you check whether latest development build helps you?
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: NoScript blocking routers config page

Postby goose » Fri Jan 14, 2011 10:00 am

Hallo,
I had the same Problem with my Router called 'Easybox802' by vodafone.
After installing development build v2.0.9.4rc1 AND adding 192.168.2.1 to my 'noscript.doNotTrack.exceptions' i have no problems any more to login to my routers configuration page. :D :D

Thank you for your support Maone!
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
goose
 

Re: NoScript blocking routers config page

Postby Di3S3L » Fri Jan 14, 2011 7:17 pm

I think it's not both, I tried adding my router's IP address to the 'noscript.doNotTrack.exceptions' string but the problem persists. I'll try your dev build next.

Details on my problem are about the same. I use a Linksys WRT120N, firmware version 1.0.05. Login through FireFox fails on this specific machine that I use, but not the other machines. All machines have NoScript and are fully updated. Pretty weird huh, you'd think that since all machines have the same browser and add-ons that you'd get the same problem across your network.

By failed login, I mean that the dialogue login box clears each time I enter the correct credentials, but if I press cancel, it gives me a 401 message: authentication failure or browser is not authentication capable.

Anyway, just thought you should know that it probably isn't the string that gives the workaround, but possibly the dev build.

[EDIT]
I read up on this thread some more, and the boolean noscript.doNotTrack.enabled toggled to false lets me access my router settings now. Mind you, I had the string noscript.doNotTrack.exceptions modified to my router's IP[192.168.1.1], so I don't know if it's a combination of both, or just the boolean that gives the workaround.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729; .NET4.0E)
Di3S3L
 
Posts: 1
Joined: Fri Jan 14, 2011 7:05 pm

PreviousNext

Return to NoScript Support

Who is online

Users browsing this forum: No registered users and 3 guests