VistaPrint image uploading - blocked

Ask for help about NoScript, no registration needed to post

VistaPrint image uploading - blocked

Postby KirGo » Thu Jul 19, 2012 8:46 pm

I've been using the VistaPrint website for a while. Up until the last month or so, I'd never had a problem with uploading images to their site. Recently I tried (repeatedly) to upload. Each time the upload was blocked. Unfortunately, the box that opens for the upload seems fine, but then to confirm the uploading is in progress the box flashes only very briefly then is replaced with "File Transfer Error: We were unable to receive your file".

I tried repeatedly to get it to work, but finally opened IE9 (which, obviously, doesn't have NoScript on it), and the upload went smoothly as usual.

I have VistaPrint.com whitelisted, but I suspect that there is another script which becomes active after clicking the image to upload and then 'Open' to transmit it. I suspect that the script that runs for this may be one I may have marked as "untrusted" for a different site. So there is no sound from NoScript showing a temporary/automatic blocked script, and the box that - for a fraction of a second - comes up to say 'loading' isn't on screen long enough to get a NoScript banner across the bottom showing it was blocked even if it was not being automatically blocked (plus it shifts to the 'File Transfer Error' box so one couldn't have been examined even if there was one).

I don't know how to get NoScript to accept that site and this link from it automatically. Since "vistaprint.com" is whitelisted, I can't understand why the uploading is blocked.

I have SO many scripts blocked that I don't like the idea of deleting them all [even if I could find a listing of them, which I can't, either in the interface, or files in the Mozilla/Firefox folders]. But I can't locate what I need to approve in order to upload, since I can't identify it.

Please help. Thank you!
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
KirGo
 

Re: VistaPrint image uploading - blocked

Postby Thrawn » Fri Jul 20, 2012 4:06 am

Have you looked in Recently Blocked Sites?
Working out what a site needs is often a matter of trial and error, I'm afraid. The JSView addon might help, if you can read JavaScript.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (Linux; U; Android 2.2.1; en-gb; GT-S5570 Build/FROYO) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1
User avatar
Thrawn
Senior Member
 
Posts: 1718
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia

Re: VistaPrint image uploading - blocked

Postby Guest » Sat Jul 21, 2012 3:57 am

Thrawn wrote:Have you looked in Recently Blocked Sites?
Working out what a site needs is often a matter of trial and error, I'm afraid. The JSView addon might help, if you can read JavaScript.


Thank you.

Unfortunately, the last time I tried to upload to VistaPrint was a good 4-8 months ago... so ANYTHING that I blocked in that time could be the culprit (and that is probably 70-90% of what I've blocked with NoScript). :(

Unfortunately, I can't read JavaScript.

Perhaps I'll just install Chrome (since it has such a tiny memory footprint) and set its home page for VistaPrint's upload page. Then when I need to upload I can just open that. Seems like a bunch of work, but better than no uploading at all I guess.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Guest
 

Re: VistaPrint image uploading - blocked

Postby Thrawn » Sat Jul 21, 2012 5:28 am

Guest wrote:Unfortunately, the last time I tried to upload to VistaPrint was a good 4-8 months ago... so ANYTHING that I blocked in that time could be the culprit (and that is probably 70-90% of what I've blocked with NoScript). :(

Er...I meant the Recently Blocked Sites submenu, where NoScript reports which domains have recently attempted to run scripts and been blocked. If you look there after attempting to upload, it may give you an idea of which sites might be needed.

Perhaps I'll just install Chrome (since it has such a tiny memory footprint) and set its home page for VistaPrint's upload page. Then when I need to upload I can just open that. Seems like a bunch of work, but better than no uploading at all I guess.

Or you could create a new Firefox profile and use that...and it may be useful for diagnosis, too. New profile, install only NoScript, and see what is being blocked at VistaPrint and what is needed to make it work.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0.1
User avatar
Thrawn
Senior Member
 
Posts: 1718
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia

Re: VistaPrint image uploading - blocked

Postby KirGo » Sun Jul 22, 2012 8:15 am

Thank you! I hadn't a clue about the Recently Blocked telling what had just tried to activate; I'd thought it was only for what you had recently marked to block.

Good point with the Firefox profile with just NoScript. That would tell me what VistaPrint is trying to run, or if it is some other program/add-on doing the blocking.

Thank you VERY much for the help! I'll stop back in after trying it/those to say what I found (or didn't find).
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
KirGo
 

Re: VistaPrint image uploading - blocked

Postby KirGo » Sun Jul 22, 2012 9:10 am

Well, I tried that. And the alternate Profile allowed me to upload just fine with NoScript installed (and the two core VistaPrint addresses approved, just as they are in my main Profile setup).

So I went back to my 'regular' Firefox Profile, and started disabling add-ons, restarting the program, then checking to see if I could upload to VistaPrint. And it kept getting blocked, and getting blocked, until every add-on except for NoScript was disabled. And it STILL wouldn't upload.

So I'm really confused. The new Profile - for which I matched, tab for tab, every setting in my 'Options' area to my regular Profile - was allowing the upload, when, effectively what SHOULD have been functioning as an identical set-up (my regular profile with all add-ons but NoScript disabled) was still refusing it. :(

Any ideas? [Possibly the only idea will be to try Firefox's Help forum at this point, but I thought I'd ask just in case.]

Thank you so VERY much for all the help. I would never have known all of this - and would have still believed it was a NoScript issue - if not for your assistance. :)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
KirGo
 

Re: VistaPrint image uploading - blocked

Postby Thrawn » Sun Jul 22, 2012 10:50 pm

Sometimes profiles get corrupted. You can try uninstalling & reinstalling NoScript, or you can try using the new one as your main profile.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (Linux; U; Android 2.2.1; en-gb; GT-S5570 Build/FROYO) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1
User avatar
Thrawn
Senior Member
 
Posts: 1718
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia

Re: VistaPrint image uploading - blocked

Postby KirGo » Mon Jul 23, 2012 3:40 am

Thank you.

I'll try uninstalling/reinstalling NoScript, and if that doesn't take care of it, I'll likely just use Chrome (or the 'bare bones' Firefox profile) to upload pics to VistaPrint. Since I have so much of the program tweaked to my liking (including some add-ons I count on that are apparently no longer available), it would be too much effort to sort through and re-do it all to get things as they are now.

I really appreciate all the help you've given me. :)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
KirGo
 


Return to NoScript Support

Who is online

Users browsing this forum: No registered users and 14 guests