Can't stop NoScript from blocking Disqus

Ask for help about NoScript, no registration needed to post

Can't stop NoScript from blocking Disqus

Postby Drewett » Sun Apr 29, 2012 10:02 pm

NoScript keeps blocking Disqus comments on certain pages, despite the fact that I have white-listed both disqus and the site on which the comments reside.

Here are two example pages:

http://www.telegraph.co.uk/finance/newsbysector/banksandfinance/9234983/Barclays-accused-in-mis-selling-report.html
http://www.telegraph.co.uk/finance/newsbysector/banksandfinance/9233840/KPMG-faces-inquiry-over-rescue-of-HBOS.html

However, on blog pages from the very same web site, disqus comments do work with NoScript enabled (for example the web page below)

http://blogs.telegraph.co.uk/finance/andrewlilico/100016769/why-does-cutting-government-spending-mean-faster-growth/

I've tried using ABE (both with and without a "from" restriction) but that just seemed to make things worse by breaking disqus functionality on the blog pages as well as the main pages.

When I select "Allow Scripts Globally", NoScript continues to interfere with pages and still blocks scripts. The only way to prevent such interference by NoScript is to completely disable the NoScript extension from the Add-Ons page (I'm using Firefox 11) and then restart the browser. But it's really annoying to have to keep doing this whenever I just want to read comments or check whether a page is functioning properly.

1. What do I need to do to enable disqus comments on all web sites and prevent NoScript from ever blocking them?

2. Why is NoScript still blocking scripts when 'Allow Scripts Globally' has been selected?

Thanks
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Drewett
 
Posts: 3
Joined: Sun Apr 29, 2012 9:24 pm

Re: Can't stop NoScript from blocking Disqus

Postby Giorgio Maone » Sun Apr 29, 2012 10:42 pm

It works for me as soon as I allow skimlinks.com.

Did you mark "skimlinks.com" as untrusted (which would keep it disabled also in "Globally allowed" mode)?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 7328
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: Can't stop NoScript from blocking Disqus

Postby Giorgio Maone » Sun Apr 29, 2012 10:47 pm

BTW, I'm gonna include a surrogate script for skimlinks.com in next dev build, in order to make allowing it unnecessary.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 7328
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: Can't stop NoScript from blocking Disqus

Postby Globe199 » Sun Apr 29, 2012 10:48 pm

Drewett wrote:1. What do I need to do to enable disqus comments on all web sites and prevent NoScript from ever blocking them?

2. Why is NoScript still blocking scripts when 'Allow Scripts Globally' has been selected?

Thanks


I've noticed this on Disqus too. When it happens, I do one of two things: (1) give up; (2) use Chrome. On a side note, I'm finding myself using Chrome for any important web use, like making purchases. I don't trust Firefox with NoScript on many sites anymore.
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Globe199
 
Posts: 6
Joined: Fri Feb 10, 2012 8:26 pm

Re: Can't stop NoScript from blocking Disqus

Postby Tom T. » Sun Apr 29, 2012 11:35 pm

Globe199 wrote:I've noticed this on Disqus too. When it happens, I do one of two things: (1) give up; (2) use Chrome.

Did you not read the post above? Giorgio said that he was going to fix it, and very soon.
Globe199 wrote: On a side note, I'm finding myself using Chrome for any important web use, like making purchases. I don't trust Firefox with NoScript on many sites anymore.

Why not, exactly?

Do you think Chrome is safer? Perhaps with NotScripts?

Firefox + NoScript has been recommended by the US Department of Homeland Security's Cybersecurity division. And by many others, including independent security experts.

Browse the thread NoScript Sightings for many such recommendations.

Also try "Google Chrome vs. FX+NS"
Don't miss the post by Nick P., who is so security-conscious that he posted a PGP-signed message, with his SHA-1 signature. I know Nick P. well (via 'Net, not live). He has spent his life designing so-called "high-assurance" (high-security) systems for governments, military, and other organizations that require a level of security beyond what COTS (commercial, off-the-shelf software) or open-source software can provide. Yet he chooses Fx + NS for his daily browsing.

Please consider these things before exposing yourself to unnecessary risks.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/12.0
Tom T.
Field Marshal
 
Posts: 3620
Joined: Fri Mar 20, 2009 6:58 am

Re: Can't stop NoScript from blocking Disqus

Postby Giorgio Maone » Mon Apr 30, 2012 12:21 am

Please check latest development build 2.4rc6, including the aforementioned surrogate.
You can forbid/mark as untrust skimlinks.com if you want now.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
User avatar
Giorgio Maone
Site Admin
 
Posts: 7328
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: Can't stop NoScript from blocking Disqus

Postby Tom T. » Mon Apr 30, 2012 3:50 am

Giorgio Maone wrote:Please check latest development build 2.4rc6, including the aforementioned surrogate.
You can forbid/mark as untrust skimlinks.com if you want now.

Added to List of scripts for which NS runs surrogate.

Thanks to Giorgio for yet another prompt response and permanent fix.
Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Tom T.
Field Marshal
 
Posts: 3620
Joined: Fri Mar 20, 2009 6:58 am

Re: Can't stop NoScript from blocking Disqus

Postby Guest » Tue May 01, 2012 3:25 am

Giorgio Maone wrote:It works for me as soon as I allow skimlinks.com.

Did you mark "skimlinks.com" as untrusted (which would keep it disabled also in "Globally allowed" mode)?


Thank you SO much for your reply Giorgio.

I did have skimlinks.com as untrusted (I had no idea that it was related to Disqus). I have now allowed it and I can finally see Disqus comments.

I have been putting up with this issue for so long. I wish I had posted here sooner.

Thanks for the advice (and also for kindly including the surrogate script in the next version).
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Guest
 

Re: Can't stop NoScript from blocking Disqus

Postby Tom T. » Tue May 01, 2012 10:38 am

Guest wrote:....I did have skimlinks.com as untrusted (I had no idea that it was related to Disqus). I have now allowed it and I can finally see Disqus comments. ... Thanks for the advice (and also for kindly including the surrogate script in the next version).

Note that the latest development build already has it. The support team and many users use development builds, which are generally only incremental in changes, rather than radical restructuring. So not much chance of anything going wrong. if it does, do please report, and it will be fixed. You can always reinstall the last stable release if needed.

This allows you to forbid skimlinks. Note that if you allow skimlinks (or any other of the scripts for which NS runs surrogate ), the actual script will run, not the surrogate.
Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Tom T.
Field Marshal
 
Posts: 3620
Joined: Fri Mar 20, 2009 6:58 am

Re: Can't stop NoScript from blocking Disqus

Postby Drewett » Tue May 08, 2012 7:08 am

Just found another page (on the same site) that doesn't work. :?

http://www.telegraph.co.uk/finance/newsbysector/banksandfinance/7688306/Santanders-pain-in-Spain-wont-hit-UK-customers.html

Have I done something to mess things up, or are there yet more scripts that need to be allowed to show Disqus comments? (Skimlinks is already unblocked).

I don't know how to determine which scripts need to be unblocked to make the comments display. Is there an easy way to figure this out if the problem arises again in future?
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Drewett
 
Posts: 3
Joined: Sun Apr 29, 2012 9:24 pm

Re: Can't stop NoScript from blocking Disqus

Postby Tom T. » Tue May 08, 2012 9:09 am

Drewett wrote:Just found another page (on the same site) that doesn't work. :?

http://www.telegraph.co.uk/finance/newsbysector/banksandfinance/7688306/Santanders-pain-in-Spain-wont-hit-UK-customers.html

Have I done something to mess things up, or are there yet more scripts that need to be allowed to show Disqus comments? (Skimlinks is already unblocked).

Per changelog, the Skimlinks surrogate is now in the latest stable release of NoScript (2.4), so with that, you should be able to block Skimlinks again without issue.

I don't have a Disqus account with which to login and test this, but pending someone who does, is it possible for you to update the very obsolete Firefox 9.01 for the supported version, currently 12.0?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/12.0
Tom T.
Field Marshal
 
Posts: 3620
Joined: Fri Mar 20, 2009 6:58 am

Re: Can't stop NoScript from blocking Disqus

Postby Drewett » Wed May 09, 2012 10:15 pm

Tom T. wrote:I don't have a Disqus account with which to login and test this ...

You don't need one (I don't have a Disqus account either). I just want to be able to read the comments, and you don't need to log in for that, they should just display on the page by default.

If I open the same page with NoScript disabled, then the comments display just fine. However, as soon as NoScript is enabled, then the Disqus comments disappear on that page.

BTW I am use Firefox v9.0.1 (which due to Mozilla's rapid releases is only 5 months old) because newer versions introduced a bug that breaks one of my most needed extensions. The extension author has filed a bug report on Bugzilla about this. Using a newer Firefox version wouldn't make any difference to this particular issue anyway because, as I said above, it already works fine on v9.0.1 just as long as NoScript is disabled.

I temporarily upgraded to the latest version of Firefox (v12 with my existing user profile) just to confirm this. Sure enough, the page exhibits exactly the same problem as before (Disqus comments are not visible). So using a newer Firefox version does not make any difference.

It's probably a case of a required script being marked as untrusted, but disqus seems to rely on so many unrelated scripts that I'm not sure how you're supposed to know which ones to unblock.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Drewett
 
Posts: 3
Joined: Sun Apr 29, 2012 9:24 pm

Re: Can't stop NoScript from blocking Disqus

Postby Thrawn » Thu May 10, 2012 3:35 am

Drewett wrote:Just found another page (on the same site) that doesn't work. :?

http://www.telegraph.co.uk/finance/newsbysector/banksandfinance/7688306/Santanders-pain-in-Spain-wont-hit-UK-customers.html

Have I done something to mess things up, or are there yet more scripts that need to be allowed to show Disqus comments? (Skimlinks is already unblocked).

I don't know how to determine which scripts need to be unblocked to make the comments display. Is there an easy way to figure this out if the problem arises again in future?

That page shows comments for me with only 'disqus.com' and 'telegraph.co.uk' temporarily-allowed, everything else blocked.
======
Thrawn
------------
Religion is not the opium of the masses. Daily life is the opium of the masses.

True religion, which dares to acknowledge death and challenge the way we live, is an attempt to wake up.
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
User avatar
Thrawn
Senior Member
 
Posts: 1720
Joined: Mon Jan 16, 2012 3:46 am
Location: Australia

Re: Can't stop NoScript from blocking Disqus

Postby Tom T. » Thu May 10, 2012 4:46 am

Drewett wrote:Just found another page (on the same site) that doesn't work. :?

If you have the RequestPolicy add-on, you must allow requests from telegraph to skimlinks, so the page will be happy. Also, from telegraph to disqus.
(discovered by process of elimination)

Note that this does not mean allowing skimlinks in the NoScript menu, because the new surrogate will run instead, fooling the page while protecting your privacy.

Does this apply to you?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/12.0
Tom T.
Field Marshal
 
Posts: 3620
Joined: Fri Mar 20, 2009 6:58 am

Re: Can't stop NoScript from blocking Disqus

Postby Tucci78 » Thu May 17, 2012 8:49 pm

Giorgio Maone wrote:It works for me as soon as I allow skimlinks.com.

Did you mark "skimlinks.com" as untrusted (which would keep it disabled also in "Globally allowed" mode)?

Sorry. I added "skimlinks.com" to the whitelist on No-Script and got no functionality on
Disqus whatsoever. Couldn't even read comments, much less post, a problem I've noted ever since I added No-Script to Firefox some months ago. I just figured that I was being blocked by site proprietors or something similar.

On the other hand, with Internet Explorer 8.5 I have no such difficulties, and can get right into Disqus-powered comments.

So do I ditch No-Script altogether or is there some kind of fix for this "feature" that actually works?
Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
Tucci78
 

Next

Return to NoScript Support

Who is online

Users browsing this forum: No registered users and 5 guests